summaryrefslogtreecommitdiffstats
path: root/meta/packages/avahi/avahi_0.6.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/avahi/avahi_0.6.13.bb')
-rw-r--r--meta/packages/avahi/avahi_0.6.13.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/packages/avahi/avahi_0.6.13.bb b/meta/packages/avahi/avahi_0.6.13.bb
new file mode 100644
index 0000000000..0898bf036c
--- /dev/null
+++ b/meta/packages/avahi/avahi_0.6.13.bb
@@ -0,0 +1,71 @@
1DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
2SECTION = "network"
3PRIORITY = "optional"
4AUTHOR = "Lennart Poettering <lennart@poettering.net>"
5HOMEPAGE = "http://avahi.org"
6MAINTAINER = "Philipp Zabel <philipp.zabel@gmail.com>"
7LICENSE= "GPL"
8PR = "r1"
9
10DEPENDS = "expat libdaemon dbus"
11RRECOMMENDS = "libnss-mdns"
12
13SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
14
15PACKAGES =+ "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
16
17FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
18FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
19FILES_avahi-daemon = "${sbindir}/avahi-daemon \
20 ${sysconfdir}/avahi/avahi-daemon.conf \
21 ${sysconfdir}/avahi/hosts \
22 ${sysconfdir}/avahi/services \
23 ${sysconfdir}/dbus-1 \
24 ${sysconfdir}/init.d/avahi-daemon \
25 ${datadir}/avahi/introspection/*.introspect \
26 ${datadir}/avahi/avahi-service.dtd \
27 ${datadir}/avahi/service-types"
28FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
29FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
30 ${sysconfdir}/avahi/avahi-dnsconfd.action \
31 ${sysconfdir}/init.d/avahi-dnsconfd"
32FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
33FILES_avahi-utils = "${bindir}/avahi-*"
34
35CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
36
37EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
38inherit autotools pkgconfig update-rc.d
39
40
41do_stage() {
42 autotools_stage_all
43}
44
45INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
46INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
47INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
48INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
49INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
50
51# At the time the postinst runs, dbus might not be setup so only restart if running
52
53pkg_postinst_avahi-daemon () {
54 # can't do this offline
55 if [ "x$D" != "x" ]; then
56 exit 1
57 fi
58 grep avahi /etc/group || addgroup avahi
59 grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
60
61 DBUSPID=`pidof dbus-daemon`
62
63 if [ "x$DBUSPID" != "x" ]; then
64 /etc/init.d/dbus-1 force-reload
65 fi
66}
67
68pkg_postrm_avahi-daemon () {
69 deluser avahi || true
70 delgroup avahi || true
71}