summaryrefslogtreecommitdiffstats
path: root/meta/packages/avahi/avahi_0.6.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/avahi/avahi_0.6.10.bb')
-rw-r--r--meta/packages/avahi/avahi_0.6.10.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/packages/avahi/avahi_0.6.10.bb b/meta/packages/avahi/avahi_0.6.10.bb
new file mode 100644
index 0000000000..2b12d91c8d
--- /dev/null
+++ b/meta/packages/avahi/avahi_0.6.10.bb
@@ -0,0 +1,58 @@
1DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
2SECTION = "network"
3PRIORITY = "optional"
4AUTHOR = "Lennart Poettering <lennart@poettering.net>"
5HOMEPAGE = "http://avahi.org"
6MAINTAINER = "Philipp Zabel <philipp.zabel@gmail.com>"
7LICENSE= "GPL"
8
9DEPENDS = "expat libdaemon dbus"
10RRECOMMENDS = "libnss-mdns"
11
12SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
13
14PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
15
16FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
17FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
18FILES_avahi-daemon = "${sbindir}/avahi-daemon \
19 ${sysconfdir}/avahi/avahi-daemon.conf \
20 ${sysconfdir}/avahi/hosts \
21 ${sysconfdir}/avahi/services \
22 ${sysconfdir}/dbus-1 \
23 ${sysconfdir}/init.d/avahi-daemon \
24 ${datadir}/avahi/introspection/*.introspect \
25 ${datadir}/avahi/avahi-service.dtd \
26 ${datadir}/avahi/service-types"
27FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
28FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
29 ${sysconfdir}/avahi/avahi-dnsconfd.action \
30 ${sysconfdir}/init.d/avahi-dnsconfd"
31FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
32FILES_avahi-utils = "${bindir}/avahi-*"
33
34CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
35
36EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
37inherit autotools pkgconfig update-rc.d
38
39INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
40INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
41INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
42INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
43INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
44
45pkg_postinst_avahi-daemon () {
46 if [ "x$D" != "x" ]; then
47 exit 1
48 fi
49
50 grep avahi /etc/group || addgroup avahi
51 grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
52 /etc/init.d/dbus-1 force-reload
53}
54
55pkg_postrm_avahi-daemon () {
56 deluser avahi || true
57 delgroup avahi || true
58}