summaryrefslogtreecommitdiffstats
path: root/meta/packages/automake
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/automake')
-rw-r--r--meta/packages/automake/automake-1.9.3/automake182-update-configscripts.patch201
-rw-r--r--meta/packages/automake/automake-native.inc11
-rw-r--r--meta/packages/automake/automake-native_1.9.3.bb3
-rw-r--r--meta/packages/automake/automake.inc23
-rw-r--r--meta/packages/automake/automake_1.9.3.bb28
-rw-r--r--meta/packages/automake/files/path_prog_fixes.patch60
6 files changed, 326 insertions, 0 deletions
diff --git a/meta/packages/automake/automake-1.9.3/automake182-update-configscripts.patch b/meta/packages/automake/automake-1.9.3/automake182-update-configscripts.patch
new file mode 100644
index 0000000000..52992b3b26
--- /dev/null
+++ b/meta/packages/automake/automake-1.9.3/automake182-update-configscripts.patch
@@ -0,0 +1,201 @@
1--- automake-1.8.2/lib/config.guess.old 2004-01-11 15:33:12.000000000 -0500
2+++ automake-1.8.2/lib/config.guess 2004-04-24 22:42:44.000000000 -0400
3@@ -3,7 +3,7 @@
4 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
5 # 2000, 2001, 2002, 2003 Free Software Foundation, Inc.
6
7-timestamp='2004-01-05'
8+timestamp='2004-03-12'
9
10 # This file is free software; you can redistribute it and/or modify it
11 # under the terms of the GNU General Public License as published by
12@@ -197,12 +197,18 @@
13 # CPU_TYPE-MANUFACTURER-OPERATING_SYSTEM is used.
14 echo "${machine}-${os}${release}"
15 exit 0 ;;
16+ amd64:OpenBSD:*:*)
17+ echo x86_64-unknown-openbsd${UNAME_RELEASE}
18+ exit 0 ;;
19 amiga:OpenBSD:*:*)
20 echo m68k-unknown-openbsd${UNAME_RELEASE}
21 exit 0 ;;
22 arc:OpenBSD:*:*)
23 echo mipsel-unknown-openbsd${UNAME_RELEASE}
24 exit 0 ;;
25+ cats:OpenBSD:*:*)
26+ echo arm-unknown-openbsd${UNAME_RELEASE}
27+ exit 0 ;;
28 hp300:OpenBSD:*:*)
29 echo m68k-unknown-openbsd${UNAME_RELEASE}
30 exit 0 ;;
31@@ -239,10 +245,24 @@
32 *:OpenBSD:*:*)
33 echo ${UNAME_MACHINE}-unknown-openbsd${UNAME_RELEASE}
34 exit 0 ;;
35+ *:ekkoBSD:*:*)
36+ echo ${UNAME_MACHINE}-unknown-ekkobsd${UNAME_RELEASE}
37+ exit 0 ;;
38+ macppc:MirBSD:*:*)
39+ echo powerppc-unknown-mirbsd${UNAME_RELEASE}
40+ exit 0 ;;
41+ *:MirBSD:*:*)
42+ echo ${UNAME_MACHINE}-unknown-mirbsd${UNAME_RELEASE}
43+ exit 0 ;;
44 alpha:OSF1:*:*)
45- if test $UNAME_RELEASE = "V4.0"; then
46+ case $UNAME_RELEASE in
47+ *4.0)
48 UNAME_RELEASE=`/usr/sbin/sizer -v | awk '{print $3}'`
49- fi
50+ ;;
51+ *5.*)
52+ UNAME_RELEASE=`/usr/sbin/sizer -v | awk '{print $4}'`
53+ ;;
54+ esac
55 # According to Compaq, /usr/sbin/psrinfo has been available on
56 # OSF/1 and Tru64 systems produced since 1995. I hope that
57 # covers most systems running today. This code pipes the CPU
58@@ -280,11 +300,12 @@
59 "EV7.9 (21364A)")
60 UNAME_MACHINE="alphaev79" ;;
61 esac
62+ # A Pn.n version is a patched version.
63 # A Vn.n version is a released version.
64 # A Tn.n version is a released field test version.
65 # A Xn.n version is an unreleased experimental baselevel.
66 # 1.2 uses "1.2" for uname -r.
67- echo ${UNAME_MACHINE}-dec-osf`echo ${UNAME_RELEASE} | sed -e 's/^[VTX]//' | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' 'abcdefghijklmnopqrstuvwxyz'`
68+ echo ${UNAME_MACHINE}-dec-osf`echo ${UNAME_RELEASE} | sed -e 's/^[PVTX]//' | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' 'abcdefghijklmnopqrstuvwxyz'`
69 exit 0 ;;
70 Alpha*:OpenVMS:*:*)
71 echo alpha-hp-vms
72@@ -405,6 +426,9 @@
73 *:*MiNT:*:* | *:*mint:*:* | *:*TOS:*:*)
74 echo m68k-unknown-mint${UNAME_RELEASE}
75 exit 0 ;;
76+ m68k:machten:*:*)
77+ echo m68k-apple-machten${UNAME_RELEASE}
78+ exit 0 ;;
79 powerpc:machten:*:*)
80 echo powerpc-apple-machten${UNAME_RELEASE}
81 exit 0 ;;
82@@ -829,6 +853,9 @@
83 ia64:Linux:*:*)
84 echo ${UNAME_MACHINE}-unknown-linux-gnu
85 exit 0 ;;
86+ m32r*:Linux:*:*)
87+ echo ${UNAME_MACHINE}-unknown-linux-gnu
88+ exit 0 ;;
89 m68*:Linux:*:*)
90 echo ${UNAME_MACHINE}-unknown-linux-gnu
91 exit 0 ;;
92@@ -1230,8 +1257,8 @@
93 SEI:*:*:SEIUX)
94 echo mips-sei-seiux${UNAME_RELEASE}
95 exit 0 ;;
96- *:DRAGONFLY:*:*)
97- echo ${UNAME_MACHINE}-unknown-dragonfly${UNAME_RELEASE}
98+ *:DragonFly:*:*)
99+ echo ${UNAME_MACHINE}-unknown-dragonfly`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`
100 exit 0 ;;
101 esac
102
103--- automake-1.8.2/lib/config.sub.old 2004-01-11 15:33:12.000000000 -0500
104+++ automake-1.8.2/lib/config.sub 2004-04-24 22:42:44.000000000 -0400
105@@ -3,7 +3,7 @@
106 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
107 # 2000, 2001, 2002, 2003 Free Software Foundation, Inc.
108
109-timestamp='2004-01-05'
110+timestamp='2004-03-12'
111
112 # This file is (in principle) common to ALL GNU software.
113 # The presence of a machine in this file suggests that SOME GNU software
114@@ -237,7 +237,7 @@
115 | h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
116 | i370 | i860 | i960 | ia64 \
117 | ip2k | iq2000 \
118- | m32r | m68000 | m68k | m88k | mcore \
119+ | m32r | m32rle | m68000 | m68k | m88k | mcore \
120 | mips | mipsbe | mipseb | mipsel | mipsle \
121 | mips16 \
122 | mips64 | mips64el \
123@@ -262,7 +262,7 @@
124 | pyramid \
125 | sh | sh[1234] | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
126 | sh64 | sh64le \
127- | sparc | sparc64 | sparc86x | sparclet | sparclite | sparcv9 | sparcv9b \
128+ | sparc | sparc64 | sparc86x | sparclet | sparclite | sparcv8 | sparcv9 | sparcv9b \
129 | strongarm \
130 | tahoe | thumb | tic4x | tic80 | tron \
131 | v850 | v850e \
132@@ -308,7 +308,7 @@
133 | hppa-* | hppa1.[01]-* | hppa2.0-* | hppa2.0[nw]-* | hppa64-* \
134 | i*86-* | i860-* | i960-* | ia64-* \
135 | ip2k-* | iq2000-* \
136- | m32r-* \
137+ | m32r-* | m32rle-* \
138 | m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
139 | m88110-* | m88k-* | mcore-* \
140 | mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
141@@ -336,7 +336,7 @@
142 | sh-* | sh[1234]-* | sh[23]e-* | sh[34]eb-* | shbe-* \
143 | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
144 | sparc-* | sparc64-* | sparc86x-* | sparclet-* | sparclite-* \
145- | sparcv9-* | sparcv9b-* | strongarm-* | sv1-* | sx?-* \
146+ | sparcv8-* | sparcv9-* | sparcv9b-* | strongarm-* | sv1-* | sx?-* \
147 | tahoe-* | thumb-* \
148 | tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
149 | tron-* \
150@@ -363,6 +363,9 @@
151 basic_machine=a29k-amd
152 os=-udi
153 ;;
154+ abacus)
155+ basic_machine=abacus-unknown
156+ ;;
157 adobe68k)
158 basic_machine=m68010-adobe
159 os=-scout
160@@ -442,12 +445,20 @@
161 basic_machine=j90-cray
162 os=-unicos
163 ;;
164+ cr16c)
165+ basic_machine=cr16c-unknown
166+ os=-elf
167+ ;;
168 crds | unos)
169 basic_machine=m68k-crds
170 ;;
171 cris | cris-* | etrax*)
172 basic_machine=cris-axis
173 ;;
174+ crx)
175+ basic_machine=crx-unknown
176+ os=-elf
177+ ;;
178 da30 | da30-*)
179 basic_machine=m68k-da30
180 ;;
181@@ -1070,7 +1081,7 @@
182 sh64)
183 basic_machine=sh64-unknown
184 ;;
185- sparc | sparcv9 | sparcv9b)
186+ sparc | sparcv8 | sparcv9 | sparcv9b)
187 basic_machine=sparc-sun
188 ;;
189 cydra)
190@@ -1143,8 +1154,9 @@
191 | -aos* \
192 | -nindy* | -vxsim* | -vxworks* | -ebmon* | -hms* | -mvs* \
193 | -clix* | -riscos* | -uniplus* | -iris* | -rtu* | -xenix* \
194- | -hiux* | -386bsd* | -knetbsd* | -netbsd* | -openbsd* | -kfreebsd* | -freebsd* | -riscix* \
195- | -lynxos* | -bosx* | -nextstep* | -cxux* | -aout* | -elf* | -oabi* \
196+ | -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* | -openbsd* \
197+ | -ekkobsd* | -kfreebsd* | -freebsd* | -riscix* | -lynxos* \
198+ | -bosx* | -nextstep* | -cxux* | -aout* | -elf* | -oabi* \
199 | -ptx* | -coff* | -ecoff* | -winnt* | -domain* | -vsta* \
200 | -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
201 | -chorusos* | -chorusrdb* \
diff --git a/meta/packages/automake/automake-native.inc b/meta/packages/automake/automake-native.inc
new file mode 100644
index 0000000000..7b69252ff0
--- /dev/null
+++ b/meta/packages/automake/automake-native.inc
@@ -0,0 +1,11 @@
1SECTION = "devel"
2include automake_${PV}.bb
3DEPENDS = "autoconf-native"
4RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
5
6inherit native
7
8do_stage () {
9 oe_runmake install
10 install -d ${datadir}/aclocal
11}
diff --git a/meta/packages/automake/automake-native_1.9.3.bb b/meta/packages/automake/automake-native_1.9.3.bb
new file mode 100644
index 0000000000..39544b7c1d
--- /dev/null
+++ b/meta/packages/automake/automake-native_1.9.3.bb
@@ -0,0 +1,3 @@
1PV := "${PV}"
2
3include automake-native.inc
diff --git a/meta/packages/automake/automake.inc b/meta/packages/automake/automake.inc
new file mode 100644
index 0000000000..fa59c1f5cc
--- /dev/null
+++ b/meta/packages/automake/automake.inc
@@ -0,0 +1,23 @@
1RDEPENDS_automake += "\
2 autoconf \
3 perl \
4 perl-module-bytes \
5 perl-module-constant \
6 perl-module-cwd \
7 perl-module-data-dumper \
8 perl-module-dynaloader \
9 perl-module-errno \
10 perl-module-exporter-heavy \
11 perl-module-file-basename \
12 perl-module-file-compare \
13 perl-module-file-copy \
14 perl-module-file-glob \
15 perl-module-file-spec-unix \
16 perl-module-file-stat \
17 perl-module-getopt-long \
18 perl-module-io \
19 perl-module-io-file \
20 perl-module-posix \
21 perl-module-strict \
22 perl-module-text-parsewords \
23 perl-module-vars "
diff --git a/meta/packages/automake/automake_1.9.3.bb b/meta/packages/automake/automake_1.9.3.bb
new file mode 100644
index 0000000000..fb75b83b68
--- /dev/null
+++ b/meta/packages/automake/automake_1.9.3.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "A tool for automatically generating Makefiles."
2LICENSE = "GPL"
3HOMEPAGE = "http://www.gnu.org/software/automake/"
4SECTION = "devel"
5PR = "r5"
6
7SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
8 ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
9S = "${WORKDIR}/automake-${PV}"
10FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
11
12inherit autotools
13
14export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
15FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
16
17include automake.inc
18
19do_install () {
20 oe_runmake 'DESTDIR=${D}' install
21 install -d ${D}${datadir}
22 if [ ! -e ${D}${datadir}/aclocal ]; then
23 ln -sf aclocal-1.9 ${D}${datadir}/aclocal
24 fi
25 if [ ! -e ${D}${datadir}/automake ]; then
26 ln -sf automake-1.9 ${D}${datadir}/automake
27 fi
28}
diff --git a/meta/packages/automake/files/path_prog_fixes.patch b/meta/packages/automake/files/path_prog_fixes.patch
new file mode 100644
index 0000000000..a85b244205
--- /dev/null
+++ b/meta/packages/automake/files/path_prog_fixes.patch
@@ -0,0 +1,60 @@
1Index: automake-1.9.3/Makefile.am
2===================================================================
3--- automake-1.9.3.orig/Makefile.am 2004-10-25 14:57:30.000000000 -0400
4+++ automake-1.9.3/Makefile.am 2005-03-09 16:47:38.241364016 -0500
5@@ -66,7 +66,8 @@
6 -e 's,[@]SHELL[@],$(SHELL),g' \
7 -e 's,[@]VERSION[@],$(VERSION),g' \
8 -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \
9- -e 's,[@]datadir[@],$(datadir),g'
10+ -e 's,[@]datadir[@],$(datadir),g' \
11+ -e 's,[@]bindir[@],$(bindir),g'
12
13 ## These files depend on Makefile so they are rebuilt if $(VERSION),
14 ## $(datadir) or other do_subst'ituted variables change.
15Index: automake-1.9.3/Makefile.in
16===================================================================
17--- automake-1.9.3.orig/Makefile.in 2004-11-01 05:23:54.000000000 -0500
18+++ automake-1.9.3/Makefile.in 2005-03-09 16:47:54.712859968 -0500
19@@ -161,7 +161,8 @@
20 -e 's,[@]SHELL[@],$(SHELL),g' \
21 -e 's,[@]VERSION[@],$(VERSION),g' \
22 -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \
23- -e 's,[@]datadir[@],$(datadir),g'
24+ -e 's,[@]datadir[@],$(datadir),g' \
25+ -e 's,[@]bindir[@],$(bindir),g'
26
27 WGET = wget
28 WGETSGO = $(WGET) http://savannah.gnu.org/cgi-bin/viewcvs/~checkout~
29Index: automake-1.9.3/aclocal.in
30===================================================================
31--- automake-1.9.3.orig/aclocal.in 2004-10-10 12:10:24.000000000 -0400
32+++ automake-1.9.3/aclocal.in 2005-03-09 16:47:38.241364016 -0500
33@@ -1,8 +1,8 @@
34-#!@PERL@
35+#!@bindir@/env perl
36 # -*- perl -*-
37 # @configure_input@
38
39-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
40+eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac'
41 if 0;
42
43 # aclocal - create aclocal.m4 by scanning configure.ac
44Index: automake-1.9.3/automake.in
45===================================================================
46--- automake-1.9.3.orig/automake.in 2004-10-21 16:23:26.000000000 -0400
47+++ automake-1.9.3/automake.in 2005-03-09 16:47:38.245363408 -0500
48@@ -1,8 +1,10 @@
49-#!@PERL@ -w
50+#!@bindir@/env perl
51 # -*- perl -*-
52 # @configure_input@
53
54-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
55+use warnings;
56+
57+eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac'
58 if 0;
59
60 # automake - create Makefile.in from Makefile.am