summaryrefslogtreecommitdiffstats
path: root/meta/packages/automake/files/path_prog_fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/automake/files/path_prog_fixes.patch')
-rw-r--r--meta/packages/automake/files/path_prog_fixes.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/packages/automake/files/path_prog_fixes.patch b/meta/packages/automake/files/path_prog_fixes.patch
new file mode 100644
index 0000000000..a85b244205
--- /dev/null
+++ b/meta/packages/automake/files/path_prog_fixes.patch
@@ -0,0 +1,60 @@
1Index: automake-1.9.3/Makefile.am
2===================================================================
3--- automake-1.9.3.orig/Makefile.am 2004-10-25 14:57:30.000000000 -0400
4+++ automake-1.9.3/Makefile.am 2005-03-09 16:47:38.241364016 -0500
5@@ -66,7 +66,8 @@
6 -e 's,[@]SHELL[@],$(SHELL),g' \
7 -e 's,[@]VERSION[@],$(VERSION),g' \
8 -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \
9- -e 's,[@]datadir[@],$(datadir),g'
10+ -e 's,[@]datadir[@],$(datadir),g' \
11+ -e 's,[@]bindir[@],$(bindir),g'
12
13 ## These files depend on Makefile so they are rebuilt if $(VERSION),
14 ## $(datadir) or other do_subst'ituted variables change.
15Index: automake-1.9.3/Makefile.in
16===================================================================
17--- automake-1.9.3.orig/Makefile.in 2004-11-01 05:23:54.000000000 -0500
18+++ automake-1.9.3/Makefile.in 2005-03-09 16:47:54.712859968 -0500
19@@ -161,7 +161,8 @@
20 -e 's,[@]SHELL[@],$(SHELL),g' \
21 -e 's,[@]VERSION[@],$(VERSION),g' \
22 -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \
23- -e 's,[@]datadir[@],$(datadir),g'
24+ -e 's,[@]datadir[@],$(datadir),g' \
25+ -e 's,[@]bindir[@],$(bindir),g'
26
27 WGET = wget
28 WGETSGO = $(WGET) http://savannah.gnu.org/cgi-bin/viewcvs/~checkout~
29Index: automake-1.9.3/aclocal.in
30===================================================================
31--- automake-1.9.3.orig/aclocal.in 2004-10-10 12:10:24.000000000 -0400
32+++ automake-1.9.3/aclocal.in 2005-03-09 16:47:38.241364016 -0500
33@@ -1,8 +1,8 @@
34-#!@PERL@
35+#!@bindir@/env perl
36 # -*- perl -*-
37 # @configure_input@
38
39-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
40+eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac'
41 if 0;
42
43 # aclocal - create aclocal.m4 by scanning configure.ac
44Index: automake-1.9.3/automake.in
45===================================================================
46--- automake-1.9.3.orig/automake.in 2004-10-21 16:23:26.000000000 -0400
47+++ automake-1.9.3/automake.in 2005-03-09 16:47:38.245363408 -0500
48@@ -1,8 +1,10 @@
49-#!@PERL@ -w
50+#!@bindir@/env perl
51 # -*- perl -*-
52 # @configure_input@
53
54-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
55+use warnings;
56+
57+eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac'
58 if 0;
59
60 # automake - create Makefile.in from Makefile.am