summaryrefslogtreecommitdiffstats
path: root/meta/packages/automake/automake_1.9.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/automake/automake_1.9.6.bb')
-rw-r--r--meta/packages/automake/automake_1.9.6.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/packages/automake/automake_1.9.6.bb b/meta/packages/automake/automake_1.9.6.bb
new file mode 100644
index 0000000000..1235c10963
--- /dev/null
+++ b/meta/packages/automake/automake_1.9.6.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "A tool for automatically generating Makefiles."
2LICENSE = "GPL"
3HOMEPAGE = "http://www.gnu.org/software/automake/"
4SECTION = "devel"
5
6SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
7 ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
8
9S = "${WORKDIR}/automake-${PV}"
10
11FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
12
13inherit autotools
14
15export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
16FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
17
18require automake.inc
19
20do_install () {
21 oe_runmake 'DESTDIR=${D}' install
22 install -d ${D}${datadir}
23 if [ ! -e ${D}${datadir}/aclocal ]; then
24 ln -sf aclocal-1.9 ${D}${datadir}/aclocal
25 fi
26 if [ ! -e ${D}${datadir}/automake ]; then
27 ln -sf automake-1.9 ${D}${datadir}/automake
28 fi
29}