summaryrefslogtreecommitdiffstats
path: root/meta/packages/automake/automake_1.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/automake/automake_1.9.3.bb')
-rw-r--r--meta/packages/automake/automake_1.9.3.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/packages/automake/automake_1.9.3.bb b/meta/packages/automake/automake_1.9.3.bb
new file mode 100644
index 0000000000..fb75b83b68
--- /dev/null
+++ b/meta/packages/automake/automake_1.9.3.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "A tool for automatically generating Makefiles."
2LICENSE = "GPL"
3HOMEPAGE = "http://www.gnu.org/software/automake/"
4SECTION = "devel"
5PR = "r5"
6
7SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
8 ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
9S = "${WORKDIR}/automake-${PV}"
10FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
11
12inherit autotools
13
14export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
15FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
16
17include automake.inc
18
19do_install () {
20 oe_runmake 'DESTDIR=${D}' install
21 install -d ${D}${datadir}
22 if [ ! -e ${D}${datadir}/aclocal ]; then
23 ln -sf aclocal-1.9 ${D}${datadir}/aclocal
24 fi
25 if [ ! -e ${D}${datadir}/automake ]; then
26 ln -sf automake-1.9 ${D}${datadir}/automake
27 fi
28}