diff options
Diffstat (limited to 'meta/packages/autoconf')
-rw-r--r-- | meta/packages/autoconf/autoconf-2.61/fix_path_xtra.patch | 114 | ||||
-rw-r--r-- | meta/packages/autoconf/autoconf-native_2.61.bb | 2 | ||||
-rw-r--r-- | meta/packages/autoconf/autoconf_2.61.bb | 2 |
3 files changed, 118 insertions, 0 deletions
diff --git a/meta/packages/autoconf/autoconf-2.61/fix_path_xtra.patch b/meta/packages/autoconf/autoconf-2.61/fix_path_xtra.patch new file mode 100644 index 0000000000..c3a2c4578a --- /dev/null +++ b/meta/packages/autoconf/autoconf-2.61/fix_path_xtra.patch | |||
@@ -0,0 +1,114 @@ | |||
1 | We don't build xmkmf so any values returned from it are going to be wrong. | ||
2 | Using any paths in /usr/ for x headers/libs is a bad idea when cross compiling. | ||
3 | This patch removes them to stop any confusion. | ||
4 | |||
5 | RP - 20071115 | ||
6 | |||
7 | Index: autoconf-2.61/lib/autoconf/libs.m4 | ||
8 | =================================================================== | ||
9 | --- autoconf-2.61.orig/lib/autoconf/libs.m4 2006-10-15 01:12:02.000000000 +0000 | ||
10 | +++ autoconf-2.61/lib/autoconf/libs.m4 2007-11-15 12:09:59.000000000 +0000 | ||
11 | @@ -180,53 +180,6 @@ | ||
12 | # --------------------- # | ||
13 | |||
14 | |||
15 | -# _AC_PATH_X_XMKMF | ||
16 | -# ---------------- | ||
17 | -# Internal subroutine of _AC_PATH_X. | ||
18 | -# Set ac_x_includes and/or ac_x_libraries. | ||
19 | -m4_define([_AC_PATH_X_XMKMF], | ||
20 | -[AC_ARG_VAR(XMKMF, [Path to xmkmf, Makefile generator for X Window System])dnl | ||
21 | -rm -f -r conftest.dir | ||
22 | -if mkdir conftest.dir; then | ||
23 | - cd conftest.dir | ||
24 | - cat >Imakefile <<'_ACEOF' | ||
25 | -incroot: | ||
26 | - @echo incroot='${INCROOT}' | ||
27 | -usrlibdir: | ||
28 | - @echo usrlibdir='${USRLIBDIR}' | ||
29 | -libdir: | ||
30 | - @echo libdir='${LIBDIR}' | ||
31 | -_ACEOF | ||
32 | - if (export CC; ${XMKMF-xmkmf}) >/dev/null 2>/dev/null && test -f Makefile; then | ||
33 | - # GNU make sometimes prints "make[1]: Entering...", which would confuse us. | ||
34 | - for ac_var in incroot usrlibdir libdir; do | ||
35 | - eval "ac_im_$ac_var=\`\${MAKE-make} $ac_var 2>/dev/null | sed -n 's/^$ac_var=//p'\`" | ||
36 | - done | ||
37 | - # Open Windows xmkmf reportedly sets LIBDIR instead of USRLIBDIR. | ||
38 | - for ac_extension in a so sl; do | ||
39 | - if test ! -f "$ac_im_usrlibdir/libX11.$ac_extension" && | ||
40 | - test -f "$ac_im_libdir/libX11.$ac_extension"; then | ||
41 | - ac_im_usrlibdir=$ac_im_libdir; break | ||
42 | - fi | ||
43 | - done | ||
44 | - # Screen out bogus values from the imake configuration. They are | ||
45 | - # bogus both because they are the default anyway, and because | ||
46 | - # using them would break gcc on systems where it needs fixed includes. | ||
47 | - case $ac_im_incroot in | ||
48 | - /usr/include) ac_x_includes= ;; | ||
49 | - *) test -f "$ac_im_incroot/X11/Xos.h" && ac_x_includes=$ac_im_incroot;; | ||
50 | - esac | ||
51 | - case $ac_im_usrlibdir in | ||
52 | - /usr/lib | /lib) ;; | ||
53 | - *) test -d "$ac_im_usrlibdir" && ac_x_libraries=$ac_im_usrlibdir ;; | ||
54 | - esac | ||
55 | - fi | ||
56 | - cd .. | ||
57 | - rm -f -r conftest.dir | ||
58 | -fi | ||
59 | -])# _AC_PATH_X_XMKMF | ||
60 | - | ||
61 | - | ||
62 | # _AC_PATH_X_DIRECT | ||
63 | # ----------------- | ||
64 | # Internal subroutine of _AC_PATH_X. | ||
65 | @@ -234,40 +187,7 @@ | ||
66 | m4_define([_AC_PATH_X_DIRECT], | ||
67 | [# Standard set of common directories for X headers. | ||
68 | # Check X11 before X11Rn because it is often a symlink to the current release. | ||
69 | -ac_x_header_dirs=' | ||
70 | -/usr/X11/include | ||
71 | -/usr/X11R6/include | ||
72 | -/usr/X11R5/include | ||
73 | -/usr/X11R4/include | ||
74 | - | ||
75 | -/usr/include/X11 | ||
76 | -/usr/include/X11R6 | ||
77 | -/usr/include/X11R5 | ||
78 | -/usr/include/X11R4 | ||
79 | - | ||
80 | -/usr/local/X11/include | ||
81 | -/usr/local/X11R6/include | ||
82 | -/usr/local/X11R5/include | ||
83 | -/usr/local/X11R4/include | ||
84 | - | ||
85 | -/usr/local/include/X11 | ||
86 | -/usr/local/include/X11R6 | ||
87 | -/usr/local/include/X11R5 | ||
88 | -/usr/local/include/X11R4 | ||
89 | - | ||
90 | -/usr/X386/include | ||
91 | -/usr/x386/include | ||
92 | -/usr/XFree86/include/X11 | ||
93 | - | ||
94 | -/usr/include | ||
95 | -/usr/local/include | ||
96 | -/usr/unsupported/include | ||
97 | -/usr/athena/include | ||
98 | -/usr/local/x11r5/include | ||
99 | -/usr/lpp/Xamples/include | ||
100 | - | ||
101 | -/usr/openwin/include | ||
102 | -/usr/openwin/share/include' | ||
103 | +ac_x_header_dirs='' | ||
104 | |||
105 | if test "$ac_x_includes" = no; then | ||
106 | # Guess where to find include files, by looking for Xlib.h. | ||
107 | @@ -316,7 +236,6 @@ | ||
108 | [AC_CACHE_VAL(ac_cv_have_x, | ||
109 | [# One or both of the vars are not set, and there is no cached value. | ||
110 | ac_x_includes=no ac_x_libraries=no | ||
111 | -_AC_PATH_X_XMKMF | ||
112 | _AC_PATH_X_DIRECT | ||
113 | case $ac_x_includes,$ac_x_libraries in #( | ||
114 | no,* | *,no | *\'*) | ||
diff --git a/meta/packages/autoconf/autoconf-native_2.61.bb b/meta/packages/autoconf/autoconf-native_2.61.bb index aa4871e194..ad6cb79445 100644 --- a/meta/packages/autoconf/autoconf-native_2.61.bb +++ b/meta/packages/autoconf/autoconf-native_2.61.bb | |||
@@ -3,6 +3,8 @@ require autoconf_${PV}.bb | |||
3 | DEPENDS = "m4-native gnu-config-native" | 3 | DEPENDS = "m4-native gnu-config-native" |
4 | RDEPENDS_${PN} = "m4-native gnu-config-native" | 4 | RDEPENDS_${PN} = "m4-native gnu-config-native" |
5 | 5 | ||
6 | SRC_URI += "file://fix_path_xtra.patch;patch=1" | ||
7 | |||
6 | S = "${WORKDIR}/autoconf-${PV}" | 8 | S = "${WORKDIR}/autoconf-${PV}" |
7 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/autoconf-${PV}" | 9 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/autoconf-${PV}" |
8 | 10 | ||
diff --git a/meta/packages/autoconf/autoconf_2.61.bb b/meta/packages/autoconf/autoconf_2.61.bb index d9e9f91d9f..fe210a1003 100644 --- a/meta/packages/autoconf/autoconf_2.61.bb +++ b/meta/packages/autoconf/autoconf_2.61.bb | |||
@@ -1,5 +1,7 @@ | |||
1 | require autoconf.inc | 1 | require autoconf.inc |
2 | 2 | ||
3 | PR = "r1" | ||
4 | |||
3 | DEPENDS += "m4-native" | 5 | DEPENDS += "m4-native" |
4 | RDEPENDS_${PN} = "m4 gnu-config" | 6 | RDEPENDS_${PN} = "m4 gnu-config" |
5 | 7 | ||