diff options
Diffstat (limited to 'meta/packages/autoconf/autoconf-2.59/autoreconf-exclude.patch')
-rw-r--r-- | meta/packages/autoconf/autoconf-2.59/autoreconf-exclude.patch | 125 |
1 files changed, 125 insertions, 0 deletions
diff --git a/meta/packages/autoconf/autoconf-2.59/autoreconf-exclude.patch b/meta/packages/autoconf/autoconf-2.59/autoreconf-exclude.patch new file mode 100644 index 0000000000..7644955519 --- /dev/null +++ b/meta/packages/autoconf/autoconf-2.59/autoreconf-exclude.patch | |||
@@ -0,0 +1,125 @@ | |||
1 | --- autoconf-2.59/bin/autoreconf.in 2004-05-06 00:27:34.000000000 -0400 | ||
2 | +++ autoconf-2.59.new/bin/autoreconf.in 2004-05-06 00:27:46.000000000 -0400 | ||
3 | @@ -75,6 +75,7 @@ | ||
4 | -f, --force consider all files obsolete | ||
5 | -i, --install copy missing auxiliary files | ||
6 | -s, --symlink with -i, install symbolic links instead of copies | ||
7 | + -x, --exclude=STEPS steps we should not run | ||
8 | -m, --make when applicable, re-run ./configure && make | ||
9 | -W, --warnings=CATEGORY report the warnings falling in CATEGORY [syntax] | ||
10 | |||
11 | @@ -127,6 +128,13 @@ | ||
12 | # Rerun `./configure && make'? | ||
13 | my $make = 0; | ||
14 | |||
15 | +# Steps to exclude | ||
16 | +my @exclude; | ||
17 | +my @ex; | ||
18 | + | ||
19 | +my $uses_gettext; | ||
20 | +my $configure_ac; | ||
21 | + | ||
22 | ## ---------- ## | ||
23 | ## Routines. ## | ||
24 | ## ---------- ## | ||
25 | @@ -144,6 +152,7 @@ | ||
26 | 'B|prepend-include=s' => \@prepend_include, | ||
27 | 'i|install' => \$install, | ||
28 | 's|symlink' => \$symlink, | ||
29 | + 'x|exclude=s' => \@exclude, | ||
30 | 'm|make' => \$make); | ||
31 | |||
32 | # Split the warnings as a list of elements instead of a list of | ||
33 | @@ -152,6 +161,8 @@ | ||
34 | parse_WARNINGS; | ||
35 | parse_warnings '--warnings', @warning; | ||
36 | |||
37 | + @exclude = map { split /,/ } @exclude; | ||
38 | + | ||
39 | # Even if the user specified a configure.ac, trim to get the | ||
40 | # directory, and look for configure.ac again. Because (i) the code | ||
41 | # is simpler, and (ii) we are still able to diagnose simultaneous | ||
42 | @@ -237,6 +249,11 @@ | ||
43 | { | ||
44 | my ($aclocal, $flags) = @_; | ||
45 | |||
46 | + @ex = grep (/^aclocal$/, @exclude); | ||
47 | + if ($#ex != -1) { | ||
48 | + return; | ||
49 | + } | ||
50 | + | ||
51 | # aclocal 1.8+ does all this for free. It can be recognized by its | ||
52 | # --force support. | ||
53 | if ($aclocal_supports_force) | ||
54 | @@ -348,7 +365,10 @@ | ||
55 | } | ||
56 | else | ||
57 | { | ||
58 | - xsystem "$autopoint"; | ||
59 | + @ex = grep (/^autopoint$/, @exclude); | ||
60 | + if ($#ex == -1) { | ||
61 | + xsystem ("$autopoint"); | ||
62 | + } | ||
63 | } | ||
64 | |||
65 | |||
66 | @@ -501,7 +521,10 @@ | ||
67 | } | ||
68 | elsif ($install) | ||
69 | { | ||
70 | - xsystem ($libtoolize); | ||
71 | + @ex = grep (/^libtoolize$/, @exclude); | ||
72 | + if ($#ex == -1) { | ||
73 | + xsystem ("$libtoolize"); | ||
74 | + } | ||
75 | $rerun_aclocal = 1; | ||
76 | } | ||
77 | else | ||
78 | @@ -541,7 +564,10 @@ | ||
79 | # latter runs the former, and (ii) autoconf is stricter than | ||
80 | # autoheader. So all in all, autoconf should give better error | ||
81 | # messages. | ||
82 | - xsystem ($autoconf); | ||
83 | + @ex = grep (/^autoconf$/, @exclude); | ||
84 | + if ($#ex == -1) { | ||
85 | + xsystem ("$autoconf"); | ||
86 | + } | ||
87 | |||
88 | |||
89 | # -------------------- # | ||
90 | @@ -562,7 +588,10 @@ | ||
91 | } | ||
92 | else | ||
93 | { | ||
94 | - xsystem ($autoheader); | ||
95 | + @ex = grep (/^autoheader$/, @exclude); | ||
96 | + if ($#ex == -1) { | ||
97 | + xsystem ("$autoheader"); | ||
98 | + } | ||
99 | } | ||
100 | |||
101 | |||
102 | @@ -580,7 +609,10 @@ | ||
103 | # We should always run automake, and let it decide whether it shall | ||
104 | # update the file or not. In fact, the effect of `$force' is already | ||
105 | # included in `$automake' via `--no-force'. | ||
106 | - xsystem ($automake); | ||
107 | + @ex = grep (/^automake$/, @exclude); | ||
108 | + if ($#ex == -1) { | ||
109 | + xsystem ("$automake"); | ||
110 | + } | ||
111 | } | ||
112 | |||
113 | |||
114 | @@ -604,7 +636,10 @@ | ||
115 | } | ||
116 | else | ||
117 | { | ||
118 | - xsystem ("make"); | ||
119 | + @ex = grep (/^make$/, @exclude); | ||
120 | + if ($#ex == -1) { | ||
121 | + xsystem ("make"); | ||
122 | + } | ||
123 | } | ||
124 | } | ||
125 | } | ||