summaryrefslogtreecommitdiffstats
path: root/meta/packages/apt/apt-0.7.3
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/apt/apt-0.7.3')
-rw-r--r--meta/packages/apt/apt-0.7.3/noconfigure.patch35
-rw-r--r--meta/packages/apt/apt-0.7.3/nodoc.patch15
2 files changed, 50 insertions, 0 deletions
diff --git a/meta/packages/apt/apt-0.7.3/noconfigure.patch b/meta/packages/apt/apt-0.7.3/noconfigure.patch
new file mode 100644
index 0000000000..682a96da24
--- /dev/null
+++ b/meta/packages/apt/apt-0.7.3/noconfigure.patch
@@ -0,0 +1,35 @@
1---
2 apt-pkg/packagemanager.cc | 4 ++++
3 1 file changed, 4 insertions(+)
4
5--- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
6+++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
7@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
8
9 List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
10
11+#if 0
12 // Perform immedate configuration of the package.
13 if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
14 if (SmartConfigure(Pkg) == false)
15 return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
16+#endif
17
18 return true;
19 }
20@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
21 DoneSomething = true;
22 }
23
24+#if 0
25 // Final run through the configure phase
26 if (ConfigureAll() == false)
27 return Failed;
28@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
29 return Failed;
30 }
31 }
32+#endif
33
34 return Completed;
35 }
diff --git a/meta/packages/apt/apt-0.7.3/nodoc.patch b/meta/packages/apt/apt-0.7.3/nodoc.patch
new file mode 100644
index 0000000000..9101847189
--- /dev/null
+++ b/meta/packages/apt/apt-0.7.3/nodoc.patch
@@ -0,0 +1,15 @@
1---
2 Makefile | 2 +-
3 1 file changed, 1 insertion(+), 1 deletion(-)
4
5--- apt-0.6.45exp2.orig/Makefile
6+++ apt-0.6.45exp2/Makefile
7@@ -17,7 +17,7 @@ all headers library clean veryclean bina
8 $(MAKE) -C cmdline $@
9 $(MAKE) -C ftparchive $@
10 $(MAKE) -C dselect $@
11- $(MAKE) -C doc $@
12+# $(MAKE) -C doc $@
13 $(MAKE) -C po $@
14
15 # Some very common aliases