diff options
Diffstat (limited to 'meta/packages/apt/apt-0.6.46.2')
-rw-r--r-- | meta/packages/apt/apt-0.6.46.2/autofoo.patch | 84 | ||||
-rw-r--r-- | meta/packages/apt/apt-0.6.46.2/noconfigure.patch | 35 | ||||
-rw-r--r-- | meta/packages/apt/apt-0.6.46.2/nodoc.patch | 15 |
3 files changed, 134 insertions, 0 deletions
diff --git a/meta/packages/apt/apt-0.6.46.2/autofoo.patch b/meta/packages/apt/apt-0.6.46.2/autofoo.patch new file mode 100644 index 0000000000..74d787cefd --- /dev/null +++ b/meta/packages/apt/apt-0.6.46.2/autofoo.patch | |||
@@ -0,0 +1,84 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.holgerschurig.de/patcher.html | ||
4 | # | ||
5 | |||
6 | --- | ||
7 | configure.in | 20 ++++++++++---------- | ||
8 | 1 file changed, 10 insertions(+), 10 deletions(-) | ||
9 | |||
10 | --- apt-0.6.45exp2.orig/configure.in | ||
11 | +++ apt-0.6.45exp2/configure.in | ||
12 | @@ -18,9 +18,9 @@ AC_CONFIG_AUX_DIR(buildlib) | ||
13 | AC_CONFIG_HEADER(include/config.h:buildlib/config.h.in include/apti18n.h:buildlib/apti18n.h.in) | ||
14 | |||
15 | dnl -- SET THIS TO THE RELEASE VERSION -- | ||
16 | -AC_DEFINE_UNQUOTED(VERSION,"0.6.45exp2") | ||
17 | +AC_DEFINE_UNQUOTED(VERSION,"0.6.45exp2",[package version]) | ||
18 | PACKAGE="apt" | ||
19 | -AC_DEFINE_UNQUOTED(PACKAGE,"$PACKAGE") | ||
20 | +AC_DEFINE_UNQUOTED(PACKAGE,"$PACKAGE",[package name]) | ||
21 | AC_SUBST(PACKAGE) | ||
22 | |||
23 | dnl Check the archs, we want the target type. | ||
24 | @@ -47,7 +47,7 @@ AC_SUBST(SOCKETLIBS) | ||
25 | LIBS="$SAVE_LIBS" | ||
26 | |||
27 | dnl Checks for pthread -- disabled due to glibc bugs jgg | ||
28 | -dnl AC_CHECK_LIB(pthread, pthread_create,[AC_DEFINE(HAVE_PTHREAD) PTHREADLIB="-lpthread"]) | ||
29 | +dnl AC_CHECK_LIB(pthread, pthread_create,[AC_DEFINE(HAVE_PTHREAD, 1, [define if we have pthreads]) PTHREADLIB="-lpthread"]) | ||
30 | AC_SUBST(PTHREADLIB) | ||
31 | dnl if test "$PTHREADLIB" != "-lpthread"; then | ||
32 | dnl AC_MSG_ERROR(failed: I need posix threads, pthread) | ||
33 | @@ -84,14 +84,14 @@ if test "x$archset" = "x"; then | ||
34 | AC_MSG_ERROR(failed: use --host= or check buildlib/archtable) | ||
35 | fi | ||
36 | AC_MSG_RESULT($archset) | ||
37 | -AC_DEFINE_UNQUOTED(COMMON_CPU,"$archset") | ||
38 | +AC_DEFINE_UNQUOTED(COMMON_CPU,"$archset",[define to the system architecture]) | ||
39 | |||
40 | dnl Get a common name for the host OS - this is primarily only for HURD and is | ||
41 | dnl non fatal if it fails | ||
42 | AC_MSG_CHECKING(system OS) | ||
43 | osset="`awk \" ! /^#|^\\\$/ {if (match(\\\"$target_vendor-$target_os\\\",\\\$1)) {print \\\$2; exit}}\" $srcdir/buildlib/ostable`" | ||
44 | AC_MSG_RESULT($osset) | ||
45 | -AC_DEFINE_UNQUOTED(COMMON_OS,"$osset") | ||
46 | +AC_DEFINE_UNQUOTED(COMMON_OS,"$osset",[define to the system OS]) | ||
47 | |||
48 | dnl We use C99 types if at all possible | ||
49 | AC_CACHE_CHECK([for C99 integer types],c9x_ints,[ | ||
50 | @@ -105,13 +105,13 @@ AC_SUBST(HAVE_STATVFS) | ||
51 | |||
52 | dnl Arg, linux and bsd put their statfs function in different places | ||
53 | if test x"$HAVE_STATVFS" != x"yes"; then | ||
54 | - AC_EGREP_HEADER(statfs,sys/vfs.h,[AC_DEFINE(HAVE_VFS_H)],[ | ||
55 | - AC_EGREP_HEADER(statfs,sys/mount.h,[AC_DEFINE(HAVE_MOUNT_H)],[AC_MSG_ERROR(failed: Need statvfs)]) | ||
56 | + AC_EGREP_HEADER(statfs,sys/vfs.h,[AC_DEFINE(HAVE_VFS_H, 1, [define if statfs is in sys/vfs.h])],[ | ||
57 | + AC_EGREP_HEADER(statfs,sys/mount.h,[AC_DEFINE(HAVE_MOUNT_H, 1, [define if statfs is in sys/mount.h])],[AC_MSG_ERROR(failed: Need statvfs)]) | ||
58 | ]) | ||
59 | fi | ||
60 | |||
61 | dnl We should use the real timegm function if we have it. | ||
62 | -AC_CHECK_FUNC(timegm,AC_DEFINE(HAVE_TIMEGM)) | ||
63 | +AC_CHECK_FUNC(timegm,AC_DEFINE(HAVE_TIMEGM, 1, [define if we have timegm])) | ||
64 | AC_SUBST(HAVE_TIMEGM) | ||
65 | |||
66 | dnl Check the sizes etc. of the architecture | ||
67 | @@ -157,7 +157,7 @@ fi | ||
68 | dnl HP-UX sux.. | ||
69 | AC_MSG_CHECKING(for missing socklen_t) | ||
70 | AC_EGREP_HEADER(socklen_t, sys/socket.h,[AC_MSG_RESULT(no)],[ | ||
71 | - AC_DEFINE(NEED_SOCKLEN_T_DEFINE) | ||
72 | + AC_DEFINE(NEED_SOCKLEN_T_DEFINE, 1, [define if we need to define socklen_t]) | ||
73 | NEED_SOCKLEN_T_DEFINE=yes | ||
74 | AC_MSG_RESULT(missing.)]) | ||
75 | AC_SUBST(NEED_SOCKLEN_T_DEFINE) | ||
76 | @@ -204,7 +204,7 @@ dnl gettext approved makefiles, so this | ||
77 | ALL_LINGUAS="bg bs ca cs cy da de dz el en_GB es eu fi fr gl hu it ja ko nb nl nn pl pt_BR pt ro ru sk sl sv tl vi zn_CN zh_TW" | ||
78 | AM_GNU_GETTEXT(external) | ||
79 | if test x"$USE_NLS" = "xyes"; then | ||
80 | - AC_DEFINE(USE_NLS) | ||
81 | + AC_DEFINE(USE_NLS, 1, [define if we have native language support]) | ||
82 | fi | ||
83 | AC_SUBST(USE_NLS) | ||
84 | AC_PATH_PROG(BASH, bash) | ||
diff --git a/meta/packages/apt/apt-0.6.46.2/noconfigure.patch b/meta/packages/apt/apt-0.6.46.2/noconfigure.patch new file mode 100644 index 0000000000..682a96da24 --- /dev/null +++ b/meta/packages/apt/apt-0.6.46.2/noconfigure.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | --- | ||
2 | apt-pkg/packagemanager.cc | 4 ++++ | ||
3 | 1 file changed, 4 insertions(+) | ||
4 | |||
5 | --- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc | ||
6 | +++ apt-0.6.45exp2/apt-pkg/packagemanager.cc | ||
7 | @@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI | ||
8 | |||
9 | List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States); | ||
10 | |||
11 | +#if 0 | ||
12 | // Perform immedate configuration of the package. | ||
13 | if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true) | ||
14 | if (SmartConfigure(Pkg) == false) | ||
15 | return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name()); | ||
16 | +#endif | ||
17 | |||
18 | return true; | ||
19 | } | ||
20 | @@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag | ||
21 | DoneSomething = true; | ||
22 | } | ||
23 | |||
24 | +#if 0 | ||
25 | // Final run through the configure phase | ||
26 | if (ConfigureAll() == false) | ||
27 | return Failed; | ||
28 | @@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag | ||
29 | return Failed; | ||
30 | } | ||
31 | } | ||
32 | +#endif | ||
33 | |||
34 | return Completed; | ||
35 | } | ||
diff --git a/meta/packages/apt/apt-0.6.46.2/nodoc.patch b/meta/packages/apt/apt-0.6.46.2/nodoc.patch new file mode 100644 index 0000000000..9101847189 --- /dev/null +++ b/meta/packages/apt/apt-0.6.46.2/nodoc.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | --- | ||
2 | Makefile | 2 +- | ||
3 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
4 | |||
5 | --- apt-0.6.45exp2.orig/Makefile | ||
6 | +++ apt-0.6.45exp2/Makefile | ||
7 | @@ -17,7 +17,7 @@ all headers library clean veryclean bina | ||
8 | $(MAKE) -C cmdline $@ | ||
9 | $(MAKE) -C ftparchive $@ | ||
10 | $(MAKE) -C dselect $@ | ||
11 | - $(MAKE) -C doc $@ | ||
12 | +# $(MAKE) -C doc $@ | ||
13 | $(MAKE) -C po $@ | ||
14 | |||
15 | # Some very common aliases | ||