summaryrefslogtreecommitdiffstats
path: root/meta/packages/apmd/apmd_3.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/apmd/apmd_3.2.2.bb')
-rw-r--r--meta/packages/apmd/apmd_3.2.2.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/packages/apmd/apmd_3.2.2.bb b/meta/packages/apmd/apmd_3.2.2.bb
new file mode 100644
index 0000000000..4a23f39590
--- /dev/null
+++ b/meta/packages/apmd/apmd_3.2.2.bb
@@ -0,0 +1,64 @@
1DESCRIPTION = "Set of tools for managing notebook power consumption."
2SECTION = "base"
3PRIORITY = "required"
4DEPENDS = "libtool-cross"
5LICENSE = "GPL"
6PR = "r7"
7
8SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.orig.tar.gz; \
9 file://debian.patch;patch=1 \
10 file://workaround.patch;patch=1 \
11 file://zaurus24.patch;patch=1 \
12 file://init \
13 file://default \
14 file://apmd_proxy \
15 file://apmd_proxy.conf"
16
17S = "${WORKDIR}/apmd-${PV}.orig"
18
19inherit update-rc.d
20
21INITSCRIPT_NAME = "apmd"
22INITSCRIPT_PARAMS = "defaults"
23
24do_compile() {
25 oe_runmake "LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool" apm apmd
26}
27
28do_stage() {
29 install -m 0644 apm.h ${STAGING_INCDIR}
30 oe_libinstall -so libapm ${STAGING_LIBDIR}
31}
32
33do_install() {
34 install -d ${D}${sysconfdir}
35 install -d ${D}${sysconfdir}/apm
36 install -d ${D}${sysconfdir}/apm/event.d
37 install -d ${D}${sysconfdir}/apm/other.d
38 install -d ${D}${sysconfdir}/apm/suspend.d
39 install -d ${D}${sysconfdir}/apm/resume.d
40 install -d ${D}${sysconfdir}/apm/scripts.d
41 install -d ${D}${sysconfdir}/default
42 install -d ${D}${sysconfdir}/init.d
43 install -d ${D}${sbindir}
44 install -d ${D}${bindir}
45 install -d ${D}${libdir}
46 install -d ${D}${datadir}/apmd
47
48 install -m 4755 ${S}/.libs/apm ${D}${bindir}/apm
49 install -m 0755 ${S}/.libs/apmd ${D}${sbindir}/apmd
50 install -m 0755 ${WORKDIR}/apmd_proxy ${D}${sysconfdir}/apm/
51 install -m 0644 ${WORKDIR}/apmd_proxy.conf ${D}${datadir}/apmd/
52 install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/apmd
53 oe_libinstall -so libapm ${D}${libdir}
54 install -m 0644 apm.h ${D}${includedir}
55
56 cat ${WORKDIR}/init | sed -e 's,/usr/sbin,${sbindir},g; s,/etc,${sysconfdir},g;' > ${D}${sysconfdir}/init.d/apmd
57 chmod 755 ${D}${sysconfdir}/init.d/apmd
58}
59
60PACKAGES =+ "libapm libapm-dev apm"
61
62FILES_libapm = "${libdir}/libapm.so.*"
63FILES_libapm-dev = "${libdir}/libapm.* ${includedir}"
64FILES_apm = "${bindir}/apm*"