summaryrefslogtreecommitdiffstats
path: root/meta/packages/apmd/apmd_3.2.2-14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/apmd/apmd_3.2.2-14.bb')
-rw-r--r--meta/packages/apmd/apmd_3.2.2-14.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/packages/apmd/apmd_3.2.2-14.bb b/meta/packages/apmd/apmd_3.2.2-14.bb
new file mode 100644
index 0000000000..70d07c3561
--- /dev/null
+++ b/meta/packages/apmd/apmd_3.2.2-14.bb
@@ -0,0 +1,62 @@
1DESCRIPTION = "Set of tools for managing notebook power consumption."
2SECTION = "base"
3PRIORITY = "required"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
6 file://apm.h;firstline=6;endline=18;md5=c9a1f79036ab14aa157e15ed75ffd769"
7DEPENDS = "libtool-cross"
8PR = "r0"
9
10SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_3.2.2.orig.tar.gz \
11 ${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.diff.gz \
12 file://unlinux.patch \
13 file://init \
14 file://default \
15 file://apmd_proxy \
16 file://apmd_proxy.conf"
17
18S = "${WORKDIR}/apmd-3.2.2.orig"
19
20inherit update-rc.d
21
22INITSCRIPT_NAME = "apmd"
23INITSCRIPT_PARAMS = "defaults"
24
25do_compile() {
26 # apmd doesn't use whole autotools. Just libtool for installation
27 oe_runmake "LIBTOOL=${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool" apm apmd
28}
29
30do_install() {
31 install -d ${D}${sysconfdir}
32 install -d ${D}${sysconfdir}/apm
33 install -d ${D}${sysconfdir}/apm/event.d
34 install -d ${D}${sysconfdir}/apm/other.d
35 install -d ${D}${sysconfdir}/apm/suspend.d
36 install -d ${D}${sysconfdir}/apm/resume.d
37 install -d ${D}${sysconfdir}/apm/scripts.d
38 install -d ${D}${sysconfdir}/default
39 install -d ${D}${sysconfdir}/init.d
40 install -d ${D}${sbindir}
41 install -d ${D}${bindir}
42 install -d ${D}${libdir}
43 install -d ${D}${datadir}/apmd
44 install -d ${D}${includedir}
45
46 install -m 4755 ${S}/.libs/apm ${D}${bindir}/apm
47 install -m 0755 ${S}/.libs/apmd ${D}${sbindir}/apmd
48 install -m 0755 ${WORKDIR}/apmd_proxy ${D}${sysconfdir}/apm/
49 install -m 0644 ${WORKDIR}/apmd_proxy.conf ${D}${datadir}/apmd/
50 install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/apmd
51 oe_libinstall -so libapm ${D}${libdir}
52 install -m 0644 apm.h ${D}${includedir}
53
54 cat ${WORKDIR}/init | sed -e 's,/usr/sbin,${sbindir},g; s,/etc,${sysconfdir},g;' > ${D}${sysconfdir}/init.d/apmd
55 chmod 755 ${D}${sysconfdir}/init.d/apmd
56}
57
58PACKAGES =+ "libapm libapm-dev apm"
59
60FILES_libapm = "${libdir}/libapm.so.*"
61FILES_libapm-dev = "${libdir}/libapm.* ${includedir}"
62FILES_apm = "${bindir}/apm*"