summaryrefslogtreecommitdiffstats
path: root/meta/packages/alsa/alsa-lib_1.0.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/alsa/alsa-lib_1.0.10.bb')
-rw-r--r--meta/packages/alsa/alsa-lib_1.0.10.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/alsa/alsa-lib_1.0.10.bb b/meta/packages/alsa/alsa-lib_1.0.10.bb
new file mode 100644
index 0000000000..a5d5426316
--- /dev/null
+++ b/meta/packages/alsa/alsa-lib_1.0.10.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Alsa sound library"
2MAINTAINER = "Lorn Potter <lpotter@trolltech.com>"
3SECTION = "libs/multimedia"
4LICENSE = "GPL"
5
6# configure.in sets -D__arm__ on the command line for any arm system
7# (not just those with the ARM instruction set), this should be removed,
8# (or replaced by a permitted #define).
9#FIXME: remove the following
10ARM_INSTRUCTION_SET = "arm"
11
12SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2"
13
14inherit autotools pkgconfig
15
16EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes"
17
18do_stage () {
19 oe_libinstall -so -C src libasound ${STAGING_LIBDIR}/
20 install -d ${STAGING_INCDIR}/alsa/sound
21 install -m 0644 include/*.h ${STAGING_INCDIR}/alsa/
22 install -m 0644 include/sound/ainstr*.h ${STAGING_INCDIR}/alsa/sound/
23 install -d ${STAGING_DATADIR}/aclocal
24 install -m 0644 utils/alsa.m4 ${STAGING_DATADIR}/aclocal/
25}
26
27PACKAGES = "libasound alsa-server alsa-conf alsa-doc alsa-dev"
28FILES_libasound = "${libdir}/libasound.so*"
29FILES_alsa-server = "${bindir}"
30FILES_alsa-conf = "${datadir}"
31FILES_alsa-dev = "${libdir}/pkgconfig/ /usr/include/"