diff options
Diffstat (limited to 'meta/classes/package.bbclass')
-rw-r--r-- | meta/classes/package.bbclass | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/package.bbclass b/meta/classes/package.bbclass index fa53b1358c..df870142f1 100644 --- a/meta/classes/package.bbclass +++ b/meta/classes/package.bbclass | |||
@@ -23,7 +23,7 @@ def legitimize_package_name(s): | |||
23 | # Remaining package name validity fixes | 23 | # Remaining package name validity fixes |
24 | return s.lower().replace('_', '-').replace('@', '+').replace(',', '+').replace('/', '-') | 24 | return s.lower().replace('_', '-').replace('@', '+').replace(',', '+').replace('/', '-') |
25 | 25 | ||
26 | def do_split_packages(d, root, file_regex, output_pattern, description, postinst=None, recursive=False, hook=None, extra_depends=None, aux_files_pattern=None, postrm=None, allow_dirs=False, prepend=False, match_path=False, aux_files_pattern_verbatim=None): | 26 | def do_split_packages(d, root, file_regex, output_pattern, description, postinst=None, recursive=False, hook=None, extra_depends=None, aux_files_pattern=None, postrm=None, allow_dirs=False, prepend=False, match_path=False, aux_files_pattern_verbatim=None, allow_links=False): |
27 | """ | 27 | """ |
28 | Used in .bb files to split up dynamically generated subpackages of a | 28 | Used in .bb files to split up dynamically generated subpackages of a |
29 | given package, usually plugins or modules. | 29 | given package, usually plugins or modules. |
@@ -72,7 +72,7 @@ def do_split_packages(d, root, file_regex, output_pattern, description, postinst | |||
72 | continue | 72 | continue |
73 | f = os.path.join(dvar + root, o) | 73 | f = os.path.join(dvar + root, o) |
74 | mode = os.lstat(f).st_mode | 74 | mode = os.lstat(f).st_mode |
75 | if not (stat.S_ISREG(mode) or (allow_dirs and stat.S_ISDIR(mode))): | 75 | if not (stat.S_ISREG(mode) or (allow_links and stat.S_ISLNK(mode)) or (allow_dirs and stat.S_ISDIR(mode))): |
76 | continue | 76 | continue |
77 | on = legitimize_package_name(m.group(1)) | 77 | on = legitimize_package_name(m.group(1)) |
78 | pkg = output_pattern % on | 78 | pkg = output_pattern % on |