diff options
Diffstat (limited to 'meta/classes/package.bbclass')
-rw-r--r-- | meta/classes/package.bbclass | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/package.bbclass b/meta/classes/package.bbclass index a714b08225..282315567f 100644 --- a/meta/classes/package.bbclass +++ b/meta/classes/package.bbclass | |||
@@ -21,7 +21,7 @@ def legitimize_package_name(s): | |||
21 | # Remaining package name validity fixes | 21 | # Remaining package name validity fixes |
22 | return s.lower().replace('_', '-').replace('@', '+').replace(',', '+').replace('/', '-') | 22 | return s.lower().replace('_', '-').replace('@', '+').replace(',', '+').replace('/', '-') |
23 | 23 | ||
24 | def do_split_packages(d, root, file_regex, output_pattern, description, postinst=None, recursive=False, hook=None, extra_depends=None, aux_files_pattern=None, postrm=None, allow_dirs=False, prepend=False, match_path=False, aux_files_pattern_verbatim=None): | 24 | def do_split_packages(d, root, file_regex, output_pattern, description, postinst=None, recursive=False, hook=None, extra_depends=None, aux_files_pattern=None, postrm=None, allow_dirs=False, prepend=False, match_path=False, aux_files_pattern_verbatim=None, allow_links=False): |
25 | """ | 25 | """ |
26 | Used in .bb files to split up dynamically generated subpackages of a | 26 | Used in .bb files to split up dynamically generated subpackages of a |
27 | given package, usually plugins or modules. | 27 | given package, usually plugins or modules. |
@@ -70,7 +70,7 @@ def do_split_packages(d, root, file_regex, output_pattern, description, postinst | |||
70 | continue | 70 | continue |
71 | f = os.path.join(dvar + root, o) | 71 | f = os.path.join(dvar + root, o) |
72 | mode = os.lstat(f).st_mode | 72 | mode = os.lstat(f).st_mode |
73 | if not (stat.S_ISREG(mode) or (allow_dirs and stat.S_ISDIR(mode))): | 73 | if not (stat.S_ISREG(mode) or (allow_links and stat.S_ISLNK(mode)) or (allow_dirs and stat.S_ISDIR(mode))): |
74 | continue | 74 | continue |
75 | on = legitimize_package_name(m.group(1)) | 75 | on = legitimize_package_name(m.group(1)) |
76 | pkg = output_pattern % on | 76 | pkg = output_pattern % on |