summaryrefslogtreecommitdiffstats
path: root/meta/classes/libc-common.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes/libc-common.bbclass')
-rw-r--r--meta/classes/libc-common.bbclass43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/classes/libc-common.bbclass b/meta/classes/libc-common.bbclass
new file mode 100644
index 0000000000..bbc80167dd
--- /dev/null
+++ b/meta/classes/libc-common.bbclass
@@ -0,0 +1,43 @@
1do_install() {
2 oe_runmake install_root=${D} install
3 for r in ${rpcsvc}; do
4 h=`echo $r|sed -e's,\.x$,.h,'`
5 install -m 0644 ${S}/sunrpc/rpcsvc/$h ${D}/${includedir}/rpcsvc/
6 done
7 install -d ${D}/${sysconfdir}/
8 install -m 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/
9 install -d ${D}${localedir}
10 make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED"
11 # get rid of some broken files...
12 for i in ${GLIBC_BROKEN_LOCALES}; do
13 grep -v $i ${WORKDIR}/SUPPORTED > ${WORKDIR}/SUPPORTED.tmp
14 mv ${WORKDIR}/SUPPORTED.tmp ${WORKDIR}/SUPPORTED
15 done
16 rm -f ${D}${sysconfdir}/rpc
17 rm -rf ${D}${datadir}/zoneinfo
18 rm -rf ${D}${libexecdir}/getconf
19}
20
21def get_libc_fpu_setting(bb, d):
22 if d.getVar('TARGET_FPU', True) in [ 'soft', 'ppc-efd' ]:
23 return "--without-fp"
24 return ""
25
26python populate_packages_prepend () {
27 if d.getVar('DEBIAN_NAMES', True):
28 pkgs = d.getVar('PACKAGES', True).split()
29 bpn = d.getVar('BPN', True)
30 prefix = d.getVar('MLPREFIX', True) or ""
31 # Set the base package...
32 d.setVar('PKG_' + prefix + bpn, prefix + 'libc6')
33 libcprefix = prefix + bpn + '-'
34 for p in pkgs:
35 # And all the subpackages.
36 if p.startswith(libcprefix):
37 renamed = p.replace(bpn, 'libc6', 1)
38 d.setVar('PKG_' + p, renamed)
39 # For backward compatibility with old -dbg package
40 d.appendVar('RPROVIDES_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg')
41 d.appendVar('RCONFLICTS_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg')
42 d.appendVar('RREPLACES_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg')
43}