summaryrefslogtreecommitdiffstats
path: root/meta/classes/libc-common.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes/libc-common.bbclass')
-rw-r--r--meta/classes/libc-common.bbclass36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/classes/libc-common.bbclass b/meta/classes/libc-common.bbclass
new file mode 100644
index 0000000000..daf499d3eb
--- /dev/null
+++ b/meta/classes/libc-common.bbclass
@@ -0,0 +1,36 @@
1do_install() {
2 oe_runmake install_root=${D} install
3 for r in ${rpcsvc}; do
4 h=`echo $r|sed -e's,\.x$,.h,'`
5 install -m 0644 ${S}/sunrpc/rpcsvc/$h ${D}/${includedir}/rpcsvc/
6 done
7 install -d ${D}/${sysconfdir}/
8 install -m 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/
9 install -d ${D}${localedir}
10 make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED"
11 # get rid of some broken files...
12 for i in ${GLIBC_BROKEN_LOCALES}; do
13 grep -v $i ${WORKDIR}/SUPPORTED > ${WORKDIR}/SUPPORTED.tmp
14 mv ${WORKDIR}/SUPPORTED.tmp ${WORKDIR}/SUPPORTED
15 done
16 rm -f ${D}${sysconfdir}/rpc
17 rm -rf ${D}${datadir}/zoneinfo
18 rm -rf ${D}${libexecdir}/getconf
19}
20
21def get_libc_fpu_setting(bb, d):
22 if d.getVar('TARGET_FPU', True) in [ 'soft', 'ppc-efd' ]:
23 return "--without-fp"
24 return ""
25
26python populate_packages_prepend () {
27 if d.getVar('DEBIAN_NAMES', True):
28 bpn = d.getVar('BPN', True)
29 d.setVar('PKG_'+bpn, 'libc6')
30 d.setVar('PKG_'+bpn+'-dev', 'libc6-dev')
31 d.setVar('PKG_'+bpn+'-dbg', 'libc6-dbg')
32 # For backward compatibility with old -dbg package
33 d.appendVar('RPROVIDES_' + bpn + '-dbg', ' libc-dbg')
34 d.appendVar('RCONFLICTS_' + bpn + '-dbg', ' libc-dbg')
35 d.appendVar('RREPLACES_' + bpn + '-dbg', ' libc-dbg')
36}