diff options
Diffstat (limited to 'meta/classes/kernel.bbclass')
-rw-r--r-- | meta/classes/kernel.bbclass | 6 |
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/classes/kernel.bbclass b/meta/classes/kernel.bbclass index 3cd59fd749..1e0646a437 100644 --- a/meta/classes/kernel.bbclass +++ b/meta/classes/kernel.bbclass | |||
@@ -327,6 +327,10 @@ do_install[prefuncs] += "package_get_auto_pr" | |||
327 | 327 | ||
328 | # Must be ran no earlier than after do_kernel_checkout or else Makefile won't be in ${S}/Makefile | 328 | # Must be ran no earlier than after do_kernel_checkout or else Makefile won't be in ${S}/Makefile |
329 | do_kernel_version_sanity_check() { | 329 | do_kernel_version_sanity_check() { |
330 | if [ "x${KERNEL_VERSION_SANITY_SKIP}" = "x1" ]; then | ||
331 | exit 0 | ||
332 | fi | ||
333 | |||
330 | # The Makefile determines the kernel version shown at runtime | 334 | # The Makefile determines the kernel version shown at runtime |
331 | # Don't use KERNEL_VERSION because the headers it grabs the version from aren't generated until do_compile | 335 | # Don't use KERNEL_VERSION because the headers it grabs the version from aren't generated until do_compile |
332 | VERSION=$(grep "^VERSION =" ${S}/Makefile | sed s/.*=\ *//) | 336 | VERSION=$(grep "^VERSION =" ${S}/Makefile | sed s/.*=\ *//) |
@@ -350,7 +354,7 @@ do_kernel_version_sanity_check() { | |||
350 | reg="${reg}${EXTRAVERSION}" | 354 | reg="${reg}${EXTRAVERSION}" |
351 | 355 | ||
352 | if [ -z `echo ${PV} | grep -E "${reg}"` ]; then | 356 | if [ -z `echo ${PV} | grep -E "${reg}"` ]; then |
353 | bbfatal "Package Version (${PV}) does not match of kernel being built (${vers}). Please update the PV variable to match the kernel source." | 357 | bbfatal "Package Version (${PV}) does not match of kernel being built (${vers}). Please update the PV variable to match the kernel source or set KERNEL_VERSION_SANITY_SKIP=\"1\" in your recipe." |
354 | fi | 358 | fi |
355 | exit 0 | 359 | exit 0 |
356 | } | 360 | } |