summaryrefslogtreecommitdiffstats
path: root/meta/classes/insane.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes/insane.bbclass')
-rw-r--r--meta/classes/insane.bbclass3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index 6b14f90027..b7ab98d34f 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -343,11 +343,12 @@ def package_qa_check_license(workdir, d):
343 sane = True 343 sane = True
344 344
345 lic_files = bb.data.getVar('LIC_FILES_CHKSUM', d, True) 345 lic_files = bb.data.getVar('LIC_FILES_CHKSUM', d, True)
346 pn = bb.data.getVar('PN', d, True)
346 347
347 if not lic_files: 348 if not lic_files:
348 # just throw a warning now. Once licensing data in entered for enough of the recipes, 349 # just throw a warning now. Once licensing data in entered for enough of the recipes,
349 # this will be converted into error and False will be returned. 350 # this will be converted into error and False will be returned.
350 bb.warn(" Recipe (.bb) file does not have license file information (LIC_FILES_CHKSUM)") 351 bb.warn(pn + ": Recipe file does not have license file information (LIC_FILES_CHKSUM)")
351 return True 352 return True
352 353
353 srcdir = bb.data.getVar('S', d, True) 354 srcdir = bb.data.getVar('S', d, True)