diff options
Diffstat (limited to 'meta/classes/distutils3.bbclass')
-rw-r--r-- | meta/classes/distutils3.bbclass | 22 |
1 files changed, 8 insertions, 14 deletions
diff --git a/meta/classes/distutils3.bbclass b/meta/classes/distutils3.bbclass index 42e7f5ae53..05a24bfe26 100644 --- a/meta/classes/distutils3.bbclass +++ b/meta/classes/distutils3.bbclass | |||
@@ -56,24 +56,18 @@ distutils3_do_install() { | |||
56 | bbfatal_log "'${PYTHON_PN} setup.py install ${DISTUTILS_INSTALL_ARGS}' execution failed." | 56 | bbfatal_log "'${PYTHON_PN} setup.py install ${DISTUTILS_INSTALL_ARGS}' execution failed." |
57 | 57 | ||
58 | # support filenames with *spaces* | 58 | # support filenames with *spaces* |
59 | find ${D} -name "*.py" -exec grep -q ${D} {} \; -exec sed -i -e s:${D}::g {} \; | 59 | find ${D} -name "*.py" -exec grep -q ${D} {} \; \ |
60 | -exec sed -i -e s:${D}::g {} \; | ||
60 | 61 | ||
61 | if test -e ${D}${bindir} ; then | 62 | for i in ${D}${bindir}/* ${D}${sbindir}/*; do |
62 | for i in ${D}${bindir}/* ; do \ | 63 | if [ -f "$i" ]; then |
63 | sed -i -e s:${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN}:${USRBINPATH}/env\ ${DISTUTILS_PYTHON}:g $i | 64 | sed -i -e s:${PYTHON}:${USRBINPATH}/env\ ${DISTUTILS_PYTHON}:g $i |
64 | sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i | 65 | sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i |
65 | done | 66 | fi |
66 | fi | 67 | done |
67 | |||
68 | if test -e ${D}${sbindir}; then | ||
69 | for i in ${D}${sbindir}/* ; do \ | ||
70 | sed -i -e s:${STAGING_BINDIR_NATIVE}/python-${PYTHON_PN}/${PYTHON_PN}:${USRBINPATH}/env\ ${DISTUTILS_PYTHON}:g $i | ||
71 | sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i | ||
72 | done | ||
73 | fi | ||
74 | 68 | ||
75 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/easy-install.pth | 69 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/easy-install.pth |
76 | 70 | ||
77 | # | 71 | # |
78 | # FIXME: Bandaid against wrong datadir computation | 72 | # FIXME: Bandaid against wrong datadir computation |
79 | # | 73 | # |