diff options
Diffstat (limited to 'meta/classes/distutils-tools.bbclass')
-rw-r--r-- | meta/classes/distutils-tools.bbclass | 77 |
1 files changed, 77 insertions, 0 deletions
diff --git a/meta/classes/distutils-tools.bbclass b/meta/classes/distutils-tools.bbclass new file mode 100644 index 0000000000..f43450e56f --- /dev/null +++ b/meta/classes/distutils-tools.bbclass | |||
@@ -0,0 +1,77 @@ | |||
1 | DISTUTILS_BUILD_ARGS ?= "" | ||
2 | DISTUTILS_STAGE_HEADERS_ARGS ?= "--install-dir=${STAGING_INCDIR}/${PYTHON_DIR}" | ||
3 | DISTUTILS_STAGE_ALL_ARGS ?= "--prefix=${STAGING_DIR_HOST}${prefix} \ | ||
4 | --install-data=${STAGING_DATADIR}" | ||
5 | DISTUTILS_INSTALL_ARGS ?= "--prefix=${D}/${prefix} \ | ||
6 | --install-data=${D}/${datadir}" | ||
7 | |||
8 | distutils_do_compile() { | ||
9 | STAGING_INCDIR=${STAGING_INCDIR} \ | ||
10 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | ||
11 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
12 | ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py build ${DISTUTILS_BUILD_ARGS} || \ | ||
13 | bbfatal "${PYTHON_PN} setup.py build_ext execution failed." | ||
14 | } | ||
15 | |||
16 | distutils_stage_headers() { | ||
17 | install -d ${STAGING_DIR_HOST}${PYTHON_SITEPACKAGES_DIR} | ||
18 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
19 | ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py install_headers ${DISTUTILS_STAGE_HEADERS_ARGS} || \ | ||
20 | bbfatal "${PYTHON_PN} setup.py install_headers execution failed." | ||
21 | } | ||
22 | |||
23 | distutils_stage_all() { | ||
24 | STAGING_INCDIR=${STAGING_INCDIR} \ | ||
25 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | ||
26 | install -d ${STAGING_DIR_HOST}${PYTHON_SITEPACKAGES_DIR} | ||
27 | PYTHONPATH=${STAGING_DIR_HOST}${PYTHON_SITEPACKAGES_DIR} \ | ||
28 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
29 | ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py install ${DISTUTILS_STAGE_ALL_ARGS} || \ | ||
30 | bbfatal "${PYTHON_PN} setup.py install (stage) execution failed." | ||
31 | } | ||
32 | |||
33 | distutils_do_install() { | ||
34 | echo "Beginning ${PN} Install ..." | ||
35 | install -d ${D}${PYTHON_SITEPACKAGES_DIR} | ||
36 | echo "Step 2 of ${PN} Install ..." | ||
37 | STAGING_INCDIR=${STAGING_INCDIR} \ | ||
38 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | ||
39 | PYTHONPATH=${D}/${PYTHON_SITEPACKAGES_DIR} \ | ||
40 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
41 | ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py install --install-lib=${D}/${PYTHON_SITEPACKAGES_DIR} ${DISTUTILS_INSTALL_ARGS} || \ | ||
42 | bbfatal "${PYTHON_PN} setup.py install execution failed." | ||
43 | |||
44 | echo "Step 3 of ${PN} Install ..." | ||
45 | # support filenames with *spaces* | ||
46 | find ${D} -name "*.py" -print0 | while read -d $'\0' i ; do \ | ||
47 | sed -i -e s:${D}::g $i | ||
48 | done | ||
49 | |||
50 | echo "Step 4 of ${PN} Install ..." | ||
51 | if test -e ${D}${bindir} ; then | ||
52 | for i in ${D}${bindir}/* ; do \ | ||
53 | sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i | ||
54 | done | ||
55 | fi | ||
56 | |||
57 | echo "Step 4 of ${PN} Install ..." | ||
58 | if test -e ${D}${sbindir}; then | ||
59 | for i in ${D}${sbindir}/* ; do \ | ||
60 | sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i | ||
61 | done | ||
62 | fi | ||
63 | |||
64 | echo "Step 5 of ${PN} Install ..." | ||
65 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/easy-install.pth | ||
66 | |||
67 | # | ||
68 | # FIXME: Bandaid against wrong datadir computation | ||
69 | # | ||
70 | if test -e ${D}${datadir}/share; then | ||
71 | mv -f ${D}${datadir}/share/* ${D}${datadir}/ | ||
72 | fi | ||
73 | } | ||
74 | |||
75 | #EXPORT_FUNCTIONS do_compile do_install | ||
76 | |||
77 | export LDSHARED="${CCLD} -shared" | ||