summaryrefslogtreecommitdiffstats
path: root/meta/classes/distrodata.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes/distrodata.bbclass')
-rw-r--r--meta/classes/distrodata.bbclass46
1 files changed, 33 insertions, 13 deletions
diff --git a/meta/classes/distrodata.bbclass b/meta/classes/distrodata.bbclass
index f24cff8dc7..e91200d91e 100644
--- a/meta/classes/distrodata.bbclass
+++ b/meta/classes/distrodata.bbclass
@@ -215,6 +215,7 @@ python checkpkg_eventhandler() {
215addtask checkpkg 215addtask checkpkg
216do_checkpkg[nostamp] = "1" 216do_checkpkg[nostamp] = "1"
217python do_checkpkg() { 217python do_checkpkg() {
218 localdata = bb.data.createCopy(d)
218 import sys 219 import sys
219 import re 220 import re
220 import tempfile 221 import tempfile
@@ -435,18 +436,38 @@ python do_checkpkg() {
435 436
436 """generate package information from .bb file""" 437 """generate package information from .bb file"""
437 pname = bb.data.getVar('PN', d, True) 438 pname = bb.data.getVar('PN', d, True)
438 pdesc = bb.data.getVar('DESCRIPTION', d, True) 439
439 pgrp = bb.data.getVar('SECTION', d, True) 440 if pname.find("-native") != -1:
440 pversion = bb.data.getVar('PV', d, True) 441 pnstripped = pname.split("-native")
441 plicense = bb.data.getVar('LICENSE', d, True) 442 bb.note("Native Split: %s" % pnstripped)
442 psection = bb.data.getVar('SECTION', d, True) 443 bb.data.setVar('OVERRIDES', "pn-" + pnstripped[0] + ":" + bb.data.getVar('OVERRIDES', d, True), localdata)
443 phome = bb.data.getVar('HOMEPAGE', d, True) 444 bb.data.update_data(localdata)
444 prelease = bb.data.getVar('PR', d, True) 445
445 ppriority = bb.data.getVar('PRIORITY', d, True) 446 if pname.find("-cross") != -1:
446 pdepends = bb.data.getVar('DEPENDS', d, True) 447 pnstripped = pname.split("-cross")
447 pbugtracker = bb.data.getVar('BUGTRACKER', d, True) 448 bb.note("cross Split: %s" % pnstripped)
448 ppe = bb.data.getVar('PE', d, True) 449 bb.data.setVar('OVERRIDES', "pn-" + pnstripped[0] + ":" + bb.data.getVar('OVERRIDES', d, True), localdata)
449 psrcuri = bb.data.getVar('SRC_URI', d, True) 450 bb.data.update_data(localdata)
451
452 if pname.find("-initial") != -1:
453 pnstripped = pname.split("-initial")
454 bb.note("initial Split: %s" % pnstripped)
455 bb.data.setVar('OVERRIDES', "pn-" + pnstripped[0] + ":" + bb.data.getVar('OVERRIDES', d, True), localdata)
456 bb.data.update_data(localdata)
457
458 pdesc = bb.data.getVar('DESCRIPTION', localdata, True)
459 pgrp = bb.data.getVar('SECTION', localdata, True)
460 pversion = bb.data.getVar('PV', localdata, True)
461 plicense = bb.data.getVar('LICENSE', localdata, True)
462 psection = bb.data.getVar('SECTION', localdata, True)
463 phome = bb.data.getVar('HOMEPAGE', localdata, True)
464 prelease = bb.data.getVar('PR', localdata, True)
465 ppriority = bb.data.getVar('PRIORITY', localdata, True)
466 pdepends = bb.data.getVar('DEPENDS', localdata, True)
467 pbugtracker = bb.data.getVar('BUGTRACKER', localdata, True)
468 ppe = bb.data.getVar('PE', localdata, True)
469 psrcuri = bb.data.getVar('SRC_URI', localdata, True)
470 maintainer = bb.data.getVar('RECIPE_MAINTAINER', localdata, True)
450 471
451 found = 0 472 found = 0
452 for uri in src_uri.split(): 473 for uri in src_uri.split():
@@ -616,7 +637,6 @@ python do_checkpkg() {
616 else: 637 else:
617 pmstatus = "UPDATE" 638 pmstatus = "UPDATE"
618 639
619 maintainer = bb.data.getVar('RECIPE_MAINTAINER', d, True)
620 psrcuri = psrcuri.split()[0] 640 psrcuri = psrcuri.split()[0]
621 pdepends = "".join(pdepends.split("\t")) 641 pdepends = "".join(pdepends.split("\t"))
622 pdesc = "".join(pdesc.split("\t")) 642 pdesc = "".join(pdesc.split("\t"))