summaryrefslogtreecommitdiffstats
path: root/meta/classes/cve-check.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes/cve-check.bbclass')
-rw-r--r--meta/classes/cve-check.bbclass6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/classes/cve-check.bbclass b/meta/classes/cve-check.bbclass
index b0febfb2e5..75b8fa9ab9 100644
--- a/meta/classes/cve-check.bbclass
+++ b/meta/classes/cve-check.bbclass
@@ -20,6 +20,10 @@
20# the only method to check against CVEs. Running this tool 20# the only method to check against CVEs. Running this tool
21# doesn't guarantee your packages are free of CVEs. 21# doesn't guarantee your packages are free of CVEs.
22 22
23# The product name that the CVE database uses. Defaults to BPN, but may need to
24# be overriden per recipe (for example tiff.bb sets CVE_PRODUCT=libtiff).
25CVE_PRODUCT ?= "${BPN}"
26
23CVE_CHECK_DB_DIR ?= "${DL_DIR}/CVE_CHECK" 27CVE_CHECK_DB_DIR ?= "${DL_DIR}/CVE_CHECK"
24CVE_CHECK_DB_FILE ?= "${CVE_CHECK_DB_DIR}/nvd.db" 28CVE_CHECK_DB_FILE ?= "${CVE_CHECK_DB_DIR}/nvd.db"
25 29
@@ -144,7 +148,7 @@ def check_cves(d, patched_cves):
144 148
145 cves_patched = [] 149 cves_patched = []
146 cves_unpatched = [] 150 cves_unpatched = []
147 bpn = d.getVar("BPN", True) 151 bpn = d.getVar("CVE_PRODUCT")
148 pv = d.getVar("PV", True).split("git+")[0] 152 pv = d.getVar("PV", True).split("git+")[0]
149 cves = " ".join(patched_cves) 153 cves = " ".join(patched_cves)
150 cve_db_dir = d.getVar("CVE_CHECK_DB_DIR", True) 154 cve_db_dir = d.getVar("CVE_CHECK_DB_DIR", True)