summaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 82ed36816b..5ef3a89402 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -114,7 +114,7 @@ autotools_do_configure() {
114 else 114 else
115 CONFIGURE_AC=configure.ac 115 CONFIGURE_AC=configure.ac
116 fi 116 fi
117 if grep "^AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then 117 if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
118 if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then 118 if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
119 : do nothing -- we still have an old unmodified configure.ac 119 : do nothing -- we still have an old unmodified configure.ac
120 else 120 else
@@ -122,12 +122,12 @@ autotools_do_configure() {
122 echo "no" | glib-gettextize --force --copy 122 echo "no" | glib-gettextize --force --copy
123 fi 123 fi
124 fi 124 fi
125 if grep "^[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then 125 mkdir -p m4
126 if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
126 oenote Executing intltoolize --copy --force --automake 127 oenote Executing intltoolize --copy --force --automake
127 intltoolize --copy --force --automake 128 intltoolize --copy --force --automake
128 fi 129 fi
129 oenote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths 130 oenote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
130 mkdir -p m4
131 autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed." 131 autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
132 cd $olddir 132 cd $olddir
133 fi 133 fi