diff options
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r-- | meta/classes/autotools.bbclass | 12 |
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass index c43ea9a7ef..c43531b050 100644 --- a/meta/classes/autotools.bbclass +++ b/meta/classes/autotools.bbclass | |||
@@ -1,8 +1,8 @@ | |||
1 | def autotools_dep_prepend(d): | 1 | def autotools_dep_prepend(d): |
2 | if d.getVar('INHIBIT_AUTOTOOLS_DEPS', True): | 2 | if d.getVar('INHIBIT_AUTOTOOLS_DEPS'): |
3 | return '' | 3 | return '' |
4 | 4 | ||
5 | pn = d.getVar('PN', True) | 5 | pn = d.getVar('PN') |
6 | deps = '' | 6 | deps = '' |
7 | 7 | ||
8 | if pn in ['autoconf-native', 'automake-native', 'help2man-native']: | 8 | if pn in ['autoconf-native', 'automake-native', 'help2man-native']: |
@@ -14,7 +14,7 @@ def autotools_dep_prepend(d): | |||
14 | if not bb.data.inherits_class('native', d) \ | 14 | if not bb.data.inherits_class('native', d) \ |
15 | and not bb.data.inherits_class('nativesdk', d) \ | 15 | and not bb.data.inherits_class('nativesdk', d) \ |
16 | and not bb.data.inherits_class('cross', d) \ | 16 | and not bb.data.inherits_class('cross', d) \ |
17 | and not d.getVar('INHIBIT_DEFAULT_DEPS', True): | 17 | and not d.getVar('INHIBIT_DEFAULT_DEPS'): |
18 | deps += 'libtool-cross ' | 18 | deps += 'libtool-cross ' |
19 | 19 | ||
20 | return deps + 'gnu-config-native ' | 20 | return deps + 'gnu-config-native ' |
@@ -139,15 +139,15 @@ ACLOCALDIR = "${WORKDIR}/aclocal-copy" | |||
139 | python autotools_copy_aclocals () { | 139 | python autotools_copy_aclocals () { |
140 | import copy | 140 | import copy |
141 | 141 | ||
142 | s = d.getVar("AUTOTOOLS_SCRIPT_PATH", True) | 142 | s = d.getVar("AUTOTOOLS_SCRIPT_PATH") |
143 | if not os.path.exists(s + "/configure.in") and not os.path.exists(s + "/configure.ac"): | 143 | if not os.path.exists(s + "/configure.in") and not os.path.exists(s + "/configure.ac"): |
144 | if not d.getVar("AUTOTOOLS_COPYACLOCAL", False): | 144 | if not d.getVar("AUTOTOOLS_COPYACLOCAL", False): |
145 | return | 145 | return |
146 | 146 | ||
147 | taskdepdata = d.getVar("BB_TASKDEPDATA", False) | 147 | taskdepdata = d.getVar("BB_TASKDEPDATA", False) |
148 | #bb.warn(str(taskdepdata)) | 148 | #bb.warn(str(taskdepdata)) |
149 | pn = d.getVar("PN", True) | 149 | pn = d.getVar("PN") |
150 | aclocaldir = d.getVar("ACLOCALDIR", True) | 150 | aclocaldir = d.getVar("ACLOCALDIR") |
151 | oe.path.remove(aclocaldir) | 151 | oe.path.remove(aclocaldir) |
152 | bb.utils.mkdirhier(aclocaldir) | 152 | bb.utils.mkdirhier(aclocaldir) |
153 | start = None | 153 | start = None |