summaryrefslogtreecommitdiffstats
path: root/meta/classes/archiver.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes/archiver.bbclass')
-rw-r--r--meta/classes/archiver.bbclass13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/classes/archiver.bbclass b/meta/classes/archiver.bbclass
index 2c04557f79..82751c1e73 100644
--- a/meta/classes/archiver.bbclass
+++ b/meta/classes/archiver.bbclass
@@ -330,6 +330,19 @@ python do_unpack_and_patch() {
330 bb.utils.remove(src_orig, recurse=True) 330 bb.utils.remove(src_orig, recurse=True)
331} 331}
332 332
333# BBINCLUDED is special (excluded from basehash signature
334# calculation). Using it in a task signature can cause "basehash
335# changed" errors.
336#
337# Depending on BBINCLUDED also causes do_ar_recipe to run again
338# for unrelated changes, like adding or removing buildhistory.bbclass.
339#
340# For these reasons we ignore the dependency completely. The versioning
341# of the output file ensures that we create it each time the recipe
342# gets rebuilt, at least as long as a PR server is used. We also rely
343# on that mechanism to catch changes in the file content, because the
344# file content is not part of of the task signature either.
345do_ar_recipe[vardepsexclude] += "BBINCLUDED"
333python do_ar_recipe () { 346python do_ar_recipe () {
334 """ 347 """
335 archive the recipe, including .bb and .inc. 348 archive the recipe, including .bb and .inc.