summaryrefslogtreecommitdiffstats
path: root/meta/classes/archive-patched-source.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes/archive-patched-source.bbclass')
-rw-r--r--meta/classes/archive-patched-source.bbclass10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/classes/archive-patched-source.bbclass b/meta/classes/archive-patched-source.bbclass
index f9f558e652..d7ed6c8785 100644
--- a/meta/classes/archive-patched-source.bbclass
+++ b/meta/classes/archive-patched-source.bbclass
@@ -11,22 +11,26 @@ inherit archiver
11addtask do_archive_patched_sources after do_patch 11addtask do_archive_patched_sources after do_patch
12 12
13# Get archiving package with logs(temp) and scripts(.bb and .inc files) 13# Get archiving package with logs(temp) and scripts(.bb and .inc files)
14addtask do_archive_scripts_logs after do_package_write_rpm 14addtask do_archive_scripts_logs
15 15
16# Get dump date and create diff file 16# Get dump date and create diff file
17addtask do_dumpdata_create_diff_gz after do_package_write_rpm before do_build 17addtask do_dumpdata_create_diff_gz before do_build
18 18
19python () { 19python () {
20 pn = d.getVar('PN', True)
21 packaging = d.getVar('IMAGE_PKGTYPE', True)
22 d.appendVarFlag('do_dumpdata_create_diff_gz', 'depends', ' %s:do_package_write_' %pn + packaging)
23
20 if d.getVar('SOURCE_ARCHIVE_PACKAGE_TYPE', True) != 'srpm': 24 if d.getVar('SOURCE_ARCHIVE_PACKAGE_TYPE', True) != 'srpm':
21 """ 25 """
22 If package type is not 'srpm' then add tasks to move archive packages of 26 If package type is not 'srpm' then add tasks to move archive packages of
23 patched sources and scripts/logs in ${DEPLOY_DIR}/sources. 27 patched sources and scripts/logs in ${DEPLOY_DIR}/sources.
24 """ 28 """
25 pn = d.getVar('PN', True)
26 d.appendVarFlag('do_configure', 'depends', ' %s:do_archive_patched_sources' %pn) 29 d.appendVarFlag('do_configure', 'depends', ' %s:do_archive_patched_sources' %pn)
27 build_deps = ' %s:do_archive_patched_sources' %pn 30 build_deps = ' %s:do_archive_patched_sources' %pn
28 build_deps += ' %s:do_archive_scripts_logs' %pn 31 build_deps += ' %s:do_archive_scripts_logs' %pn
29 d.appendVarFlag('do_build', 'depends', build_deps) 32 d.appendVarFlag('do_build', 'depends', build_deps)
33 d.appendVarFlag('do_archive_scripts_logs', 'depends', ' %s:do_package_write_' %pn + packaging)
30 34
31 else: 35 else:
32 d.prependVarFlag('do_patch', 'postfuncs', "do_archive_patched_sources") 36 d.prependVarFlag('do_patch', 'postfuncs', "do_archive_patched_sources")