summaryrefslogtreecommitdiffstats
path: root/meta/classes-recipe/python_pep517.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes-recipe/python_pep517.bbclass')
-rw-r--r--meta/classes-recipe/python_pep517.bbclass7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/classes-recipe/python_pep517.bbclass b/meta/classes-recipe/python_pep517.bbclass
index 202dde0bc3..a1659c5f62 100644
--- a/meta/classes-recipe/python_pep517.bbclass
+++ b/meta/classes-recipe/python_pep517.bbclass
@@ -10,7 +10,7 @@
10# This class will build a wheel in do_compile, and use pypa/installer to install 10# This class will build a wheel in do_compile, and use pypa/installer to install
11# it in do_install. 11# it in do_install.
12 12
13DEPENDS:append = " python3-picobuild-native python3-installer-native" 13DEPENDS:append = " python3-build-native python3-installer-native"
14 14
15# Where to execute the build process from 15# Where to execute the build process from
16PEP517_SOURCE_PATH ?= "${S}" 16PEP517_SOURCE_PATH ?= "${S}"
@@ -18,7 +18,8 @@ PEP517_SOURCE_PATH ?= "${S}"
18# The directory where wheels will be written 18# The directory where wheels will be written
19PEP517_WHEEL_PATH ?= "${WORKDIR}/dist" 19PEP517_WHEEL_PATH ?= "${WORKDIR}/dist"
20 20
21PEP517_PICOBUILD_OPTS ?= "" 21# Other options to pass to build
22PEP517_BUILD_OPTS ?= ""
22 23
23# The interpreter to use for installed scripts 24# The interpreter to use for installed scripts
24PEP517_INSTALL_PYTHON = "python3" 25PEP517_INSTALL_PYTHON = "python3"
@@ -36,7 +37,7 @@ python_pep517_do_configure () {
36# When we have Python 3.11 we can parse pyproject.toml to determine the build 37# When we have Python 3.11 we can parse pyproject.toml to determine the build
37# API entry point directly 38# API entry point directly
38python_pep517_do_compile () { 39python_pep517_do_compile () {
39 nativepython3 -m picobuild --source ${PEP517_SOURCE_PATH} --dest ${PEP517_WHEEL_PATH} --wheel ${PEP517_PICOBUILD_OPTS} 40 nativepython3 -m build --no-isolation --wheel --outdir ${PEP517_WHEEL_PATH} ${PEP517_SOURCE_PATH} ${PEP517_BUILD_OPTS}
40} 41}
41do_compile[cleandirs] += "${PEP517_WHEEL_PATH}" 42do_compile[cleandirs] += "${PEP517_WHEEL_PATH}"
42 43