summaryrefslogtreecommitdiffstats
path: root/meta-yocto
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto')
-rw-r--r--meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb17
1 files changed, 3 insertions, 14 deletions
diff --git a/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
index 756b596913..831e4522bb 100644
--- a/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
+++ b/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
@@ -20,25 +20,14 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;nocheckout=1;
20# building a device tree as part of kern headers 20# building a device tree as part of kern headers
21KERNEL_DEVICETREE = "" 21KERNEL_DEVICETREE = ""
22 22
23set_arch() { 23inherit kernel-arch
24 case ${TARGET_ARCH} in
25 arm*) ARCH=arm ;;
26 i*86*) ARCH=i386 ;;
27 ia64*) ARCH=ia64 ;;
28 mips*) ARCH=mips ;;
29 powerpc*) ARCH=powerpc ;;
30 x86_64*) ARCH=x86_64 ;;
31 esac
32}
33 24
34do_configure() { 25do_configure() {
35 set_arch 26 oe_runmake allnoconfig
36 oe_runmake allnoconfig ARCH=$ARCH
37} 27}
38 28
39do_install() { 29do_install() {
40 set_arch 30 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}
41 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
42 31
43 # The ..install.cmd conflicts between various configure runs 32 # The ..install.cmd conflicts between various configure runs
44 find ${D}${includedir} -name ..install.cmd | xargs rm -f 33 find ${D}${includedir} -name ..install.cmd | xargs rm -f