summaryrefslogtreecommitdiffstats
path: root/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb')
-rw-r--r--meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
new file mode 100644
index 0000000000..8ab4fb18d9
--- /dev/null
+++ b/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
@@ -0,0 +1,36 @@
1require recipes-kernel/linux-libc-headers/linux-libc-headers.inc
2
3B = "${S}"
4
5PROVIDES = "linux-libc-headers"
6RPROVIDES_${PN}-dev = "linux-libc-headers-dev"
7RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg"
8
9KBRANCH = "standard/base"
10SRCREV = "a1cdb60720c452c3965eaec3ec2cd10f06261cc5"
11
12PV = "3.4+git-${SRCPV}"
13PR = "r6"
14
15SRCREV_FORMAT ?= "meta_machine"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
18
19# force this to empty to prevent installation failures, we aren't
20# building a device tree as part of kern headers
21KERNEL_DEVICETREE = ""
22
23inherit kernel-arch
24
25# The following tasks are not required when we just want
26# headers. So we override and stub them out.
27do_kernel_configme() {
28}
29
30do_patch () {
31}
32
33do_kernel_configcheck () {
34}
35
36BBCLASSEXTEND = "nativesdk"