summaryrefslogtreecommitdiffstats
path: root/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb')
-rw-r--r--meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb32
1 files changed, 7 insertions, 25 deletions
diff --git a/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
index 831e4522bb..b4222f14bb 100644
--- a/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
+++ b/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
@@ -3,18 +3,17 @@ include recipes-kernel/linux/linux-yocto.inc
3 3
4B = "${S}" 4B = "${S}"
5 5
6INHIBIT_DEFAULT_DEPS = "1"
7DEPENDS += "unifdef-native"
8PROVIDES = "linux-libc-headers" 6PROVIDES = "linux-libc-headers"
9RPROVIDES_${PN}-dev = "linux-libc-headers-dev" 7RPROVIDES_${PN}-dev = "linux-libc-headers-dev"
10RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg" 8RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg"
11SRCREV = "21ab5dca134a6bf1316aa59f69f9ee9e091d5702"
12KBRANCH ?= "standard/base"
13KMETA ?= "meta"
14PV = "3.2+git-${SRCPV}"
15PR = "r5"
16 9
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta" 10KBRANCH = "standard/base"
11SRCREV = "a1cdb60720c452c3965eaec3ec2cd10f06261cc5"
12
13PV = "3.4+git-${SRCPV}"
14PR = "r6"
15
16SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
18 17
19# force this to empty to prevent installation failures, we aren't 18# force this to empty to prevent installation failures, we aren't
20# building a device tree as part of kern headers 19# building a device tree as part of kern headers
@@ -22,17 +21,6 @@ KERNEL_DEVICETREE = ""
22 21
23inherit kernel-arch 22inherit kernel-arch
24 23
25do_configure() {
26 oe_runmake allnoconfig
27}
28
29do_install() {
30 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}
31
32 # The ..install.cmd conflicts between various configure runs
33 find ${D}${includedir} -name ..install.cmd | xargs rm -f
34}
35
36# The following tasks are not required when we just want 24# The following tasks are not required when we just want
37# headers. So we override and stub them out. 25# headers. So we override and stub them out.
38do_kernel_configme() { 26do_kernel_configme() {
@@ -41,12 +29,6 @@ do_kernel_configme() {
41do_patch () { 29do_patch () {
42} 30}
43 31
44do_compile () {
45}
46
47do_validate_branches () {
48}
49
50do_kernel_configcheck () { 32do_kernel_configcheck () {
51} 33}
52 34