summaryrefslogtreecommitdiffstats
path: root/meta-yocto/conf/local.conf.sample
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto/conf/local.conf.sample')
-rw-r--r--meta-yocto/conf/local.conf.sample219
1 files changed, 219 insertions, 0 deletions
diff --git a/meta-yocto/conf/local.conf.sample b/meta-yocto/conf/local.conf.sample
new file mode 100644
index 0000000000..434c6841bf
--- /dev/null
+++ b/meta-yocto/conf/local.conf.sample
@@ -0,0 +1,219 @@
1# CONF_VERSION is increased each time build/conf/ changes incompatibly
2CONF_VERSION = "1"
3
4# Uncomment and change to cache the files Poky downloads in an alternative
5# location, default it ${TOPDIR}/downloads
6#DL_DIR ?= "${TOPDIR}/downloads"
7# Uncomment and change to cache Poky's built staging output in an alternative
8# location, default ${TOPDIR}/sstate-cache
9#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
10
11# Uncomment and set to allow bitbake to execute multiple tasks at once.
12# For a quadcore, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would
13# be appropriate.
14# BB_NUMBER_THREADS = "4"
15# Also, make can be passed flags so it run parallel threads e.g.:
16# PARALLEL_MAKE = "-j 4"
17
18# Set a default machine to target unless a machine is selected from the
19# lists below.
20MACHINE ??= "qemux86"
21
22# Supported emulation machines
23#MACHINE ?= "qemuarm"
24#MACHINE ?= "qemumips"
25#MACHINE ?= "qemuppc"
26#MACHINE ?= "qemux86"
27#MACHINE ?= "qemux86-64"
28
29# Supported target hardware for demonstration purposes
30#MACHINE ?= "atom-pc"
31#MACHINE ?= "beagleboard"
32#MACHINE ?= "emenlow"
33#MACHINE ?= "mpc8315e-rdb"
34#MACHINE ?= "routerstationpro"
35
36DISTRO ?= "poky"
37# For bleeding edge / experimental / unstable package versions
38# DISTRO ?= "poky-bleeding"
39
40BBMASK = ""
41
42# EXTRA_IMAGE_FEATURES allows extra packages to be added to the generated images
43# (Some of these are automatically added to certain image types)
44# "dbg-pkgs" - add -dbg packages for all installed packages
45# (adds symbol information for debugging/profiling)
46# "dev-pkgs" - add -dev packages for all installed packages
47# (useful if you want to develop against libs in the image)
48# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
49# "tools-debug" - add debugging tools (gdb, strace)
50# "tools-profile" - add profiling tools (oprofile, exmap, lttng valgrind (x86 only))
51# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
52# "debug-tweaks" - make an image for suitable of development
53# e.g. ssh root access has a blank password
54# There are other application targets too, see meta/classes/poky-image.bbclass
55# and meta/packages/tasks/task-poky.bb for more details.
56
57EXTRA_IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
58
59# The default IMAGE_FEATURES above are too large for the mx31phy and
60# c700/c750 machines which have limited space. The code below limits
61# the default features for those machines.
62EXTRA_IMAGE_FEATURES_c7x0 = "tools-testapps debug-tweaks"
63EXTRA_IMAGE_FEATURES_mx31phy = "debug-tweaks"
64EXTRA_IMAGE_FEATURES_mx31ads = "tools-testapps debug-tweaks"
65
66# A list of packaging systems used in generated images
67# The first package type listed will be used for rootfs generation
68# include 'package_deb' for debs
69# include 'package_ipk' for ipks
70# include 'package_rpm' for rpms
71#PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
72PACKAGE_CLASSES ?= "package_rpm package_ipk"
73
74# mklibs library size optimization is more useful to smaller images,
75# and less useful for bigger images. Also mklibs library optimization can break the ABI compatibility, so should not be applied to the images which are tobe
76# extended or upgraded later.
77#This enabled mklibs library size optimization just for the specified image.
78#MKLIBS_OPTIMIZED_IMAGES ?= "poky-image-minimal"
79#This enable mklibs library size optimization will be for all the images.
80#MKLIBS_OPTIMIZED_IMAGES ?= "all"
81
82# A list of additional classes to use when building the system
83# include 'image-mklibs' to reduce shared library files size for an image
84# include 'image-prelink' in order to prelink the filesystem image
85# include 'image-swab' to perform host system intrusion detection
86# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
87USER_CLASSES ?= "image-mklibs image-prelink"
88
89# POKYMODE controls the characteristics of the generated packages/images by
90# telling poky which type of toolchain to use.
91#
92# Options include several different EABI combinations and a compatibility
93# mode for the OABI mode poky previously used.
94#
95# The default is "eabi"
96# Use "oabi" for machines with kernels < 2.6.18 on ARM for example.
97# Use "external-MODE" to use the precompiled external toolchains where MODE
98# is the type of external toolchain to use e.g. eabi.
99# POKYMODE = "external-eabi"
100
101# Uncomment this to specify where BitBake should create its temporary files.
102# Note that a full build of everything in OpenEmbedded will take GigaBytes of hard
103# disk space, so make sure to free enough space. The default TMPDIR is
104# <build directory>/tmp
105#TMPDIR = "${POKYBASE}/build/tmp"
106
107# The following are used to control options related to debugging.
108#
109# Uncomment this to change the optimization to make debugging easer, at the
110# possible cost of performance.
111# DEBUG_BUILD = "1"
112#
113# Uncomment this to disable the stripping of the installed binaries
114# INHIBIT_PACKAGE_STRIP = "1"
115#
116# Uncomment this to disable the split of the debug information into -dbg files
117# INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
118#
119# When splitting debug information, the following controls the results of the
120# file splitting.
121#
122# .debug (default):
123# When splitting the debug information will be placed into
124# a .debug directory in the same dirname of the binary produced:
125# /bin/foo -> /bin/.debug/foo
126#
127# debug-file-directory:
128# When splitting the debug information will be placed into
129# a central debug-file-directory, /usr/lib/debug:
130# /bin/foo -> /usr/lib/debug/bin/foo.debug
131#
132# Any source code referenced in the debug symbols will be copied
133# and made available within the /usr/src/debug directory
134#
135PACKAGE_DEBUG_SPLIT_STYLE = '.debug'
136# PACKAGE_DEBUG_SPLIT_STYLE = 'debug-file-directory'
137
138# Uncomment these to build a package such that you can use gprof to profile it.
139# NOTE: This will only work with 'linux' targets, not
140# 'linux-uclibc', as uClibc doesn't provide the necessary
141# object files. Also, don't build glibc itself with these
142# flags, or it'll fail to build.
143#
144# PROFILE_OPTIMIZATION = "-pg"
145# SELECTED_OPTIMIZATION = "${PROFILE_OPTIMIZATION}"
146# LDFLAGS =+ "-pg"
147
148# Uncomment this if you want BitBake to emit debugging output
149# BBDEBUG = "yes"
150# Uncomment this if you want BitBake to emit the log if a build fails.
151BBINCLUDELOGS = "yes"
152
153# Set this if you wish to make pkgconfig libraries from your system available
154# for native builds. Combined with extra ASSUME_PROVIDEDs this can allow
155# native builds of applications like oprofileui-native (unsupported feature).
156#EXTRA_NATIVE_PKGCONFIG_PATH = ":/usr/lib/pkgconfig"
157#ASSUME_PROVIDED += "gtk+-native libglade-native"
158
159ENABLE_BINARY_LOCALE_GENERATION = "1"
160
161# The architecture to build SDK items for, by setting this you can build SDK
162# packages for architectures other than the host i.e. building i686 packages
163# on an x86_64 host.
164# Supported values are i686 and x86_64
165#SDKMACHINE ?= "i686"
166
167# Poky can try and fetch packaged-staging packages from a http, https or ftp
168# mirror. Set this variable to the root of a pstage directory on a server.
169#SSTATE_MIRRORS ?= "\
170#file://.* http://someserver.tld/share/sstate/ \n \
171#file://.* file:///some/local/dir/sstate/"
172
173# Set IMAGETEST to qemu if you want to build testcases and start
174# testing in qemu after do_rootfs.
175#IMAGETEST = "qemu"
176
177# By default test cases in sanity suite will be ran. If you want to run other
178# test suite or specific test case(e.g. bat or boot test case under sanity suite),
179# list them like following.
180#TEST_SCEN = "sanity bat sanity:boot"
181
182#Because of the QEMU booting slowness issue(see bug #646 and #618), autobuilder
183#may suffer a timeout issue when running sanity test. We introduce variable
184#TEST_SERIALIZE here to reduce the time on sanity test. It is by default set
185#to 1. Poky will start image and run cases in the same image without reboot
186#or kill. If it is set to 0, the image will be copied and tested for each
187#case, which will take much time.
188#TEST_SERIALIZE = "1"
189
190# Set GLIBC_GENERATE_LOCALES to the locales you wish to generate should you not
191# wish to perform the time-consuming step of generating all LIBC locales.
192# NOTE: If removing en_US.UTF-8 you will also need to uncomment, and set
193# appropriate values for IMAGE_LINGUAS and LIMIT_BUILT_LOCALES
194# WARNING: this may break localisation!
195#GLIBC_GENERATE_LOCALES = "en_GB.UTF-8 en_US.UTF-8"
196# See message above as to whether setting these is required
197#IMAGE_LINGUAS ?= "en-gb"
198#LIMIT_BUILT_LOCALES ?= "POSIX en_GB"
199
200# This value is currently used by PSEUDO to determine if the recipe should
201# build both the 32-bit and 64-bit wrapper libraries on a 64-bit build system.
202#
203# PSEUDO will attempt to determine if a 32-bit wrapper is necessary, but
204# it doesn't always guess properly. If you have 32-bit executables on
205# your 64-bit build system, you likely want to set this to "0",
206# otherwise you could end up with incorrect file attributes on the
207# target filesystem.
208#
209# Default to not build 32 bit libs on 64 bit systems, comment this
210# out if that is desired
211NO32LIBS = "1"
212
213# If you do not use (or have installed) gnome-terminal you will need to
214# uncomment these variables and set them to the terminal you wish to use
215# when resolving patches which cannot be applied
216# Supported shell prefixes for *_TERMCMD and *_TERMCMDRUN ARE:
217# GNOME, SCREEN, XTERM and KONSOLE
218#TERMCMD = "${KONSOLE_TERMCMD}"
219#TERMCMDRUN = "${KONSOLE_TERMCMDRUN}"