summaryrefslogtreecommitdiffstats
path: root/meta-yocto/conf/local.conf.sample.extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto/conf/local.conf.sample.extended')
-rw-r--r--meta-yocto/conf/local.conf.sample.extended265
1 files changed, 265 insertions, 0 deletions
diff --git a/meta-yocto/conf/local.conf.sample.extended b/meta-yocto/conf/local.conf.sample.extended
new file mode 100644
index 0000000000..a2cb81bc1c
--- /dev/null
+++ b/meta-yocto/conf/local.conf.sample.extended
@@ -0,0 +1,265 @@
1# BBMASK is a regular expression that can be used to tell BitBake to ignore
2# certain recipes.
3#BBMASK = ""
4
5# eglibc configurability is used to reduce minimal image's size.
6# the all supported eglibc options are listed in DISTRO_FEATURES_LIBC
7# and disabled by default. Uncomment and copy the DISTRO_FEATURES_LIBC
8# and DISTRO_FEATURES definitions to local.conf to enable the options.
9#DISTRO_FEATURES_LIBC = "ipv6 libc-backtrace libc-big-macros libc-bsd libc-cxx-tests libc-catgets libc-charsets libc-crypt \
10# libc-crypt-ufc libc-db-aliases libc-envz libc-fcvt libc-fmtmsg libc-fstab libc-ftraverse \
11# libc-getlogin libc-idn libc-inet libc-inet-anl libc-libm libc-locales libc-locale-code \
12# libc-memusage libc-nis libc-nsswitch libc-rcmd libc-rtld-debug libc-spawn libc-streams libc-sunrpc \
13# libc-utmp libc-utmpx libc-wordexp libc-posix-clang-wchar libc-posix-regexp libc-posix-regexp-glibc \
14# libc-posix-wchar-io"
15
16#DISTRO_FEATURES = "alsa bluetooth ext2 irda pcmcia usbgadget usbhost wifi nfs zeroconf pci ${DISTRO_FEATURES_LIBC}"
17
18# If you want to get an image based on directfb without x11, Please copy this variable to build/conf/local.conf
19#DISTRO_FEATURES = "alsa argp bluetooth ext2 irda largefile pcmcia usbgadget usbhost wifi xattr nfs zeroconf pci 3g directfb ${DISTRO_FEATURES_LIBC}"
20
21# ENABLE_BINARY_LOCALE_GENERATION controls the generation of binary locale
22# packages at build time using qemu-native. Disabling it (by setting it to 0)
23# will save some build time at the expense of breaking i18n on devices with
24# less than 128MB RAM.
25#ENABLE_BINARY_LOCALE_GENERATION = "1"
26
27# Set GLIBC_GENERATE_LOCALES to the locales you wish to generate should you not
28# wish to perform the time-consuming step of generating all LIBC locales.
29# NOTE: If removing en_US.UTF-8 you will also need to uncomment, and set
30# appropriate values for IMAGE_LINGUAS and LIMIT_BUILT_LOCALES
31# WARNING: this may break localisation!
32#GLIBC_GENERATE_LOCALES = "en_GB.UTF-8 en_US.UTF-8"
33# See message above as to whether setting these is required
34#IMAGE_LINGUAS ?= "en-gb"
35#LIMIT_BUILT_LOCALES ?= "POSIX en_GB"
36
37# The following are used to control options related to debugging.
38#
39# Uncomment this to change the optimization to make debugging easer, at the
40# possible cost of performance.
41# DEBUG_BUILD = "1"
42#
43# Uncomment this to disable the stripping of the installed binaries
44# INHIBIT_PACKAGE_STRIP = "1"
45#
46# Uncomment this to disable the split of the debug information into -dbg files
47# INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
48#
49# When splitting debug information, the following controls the results of the
50# file splitting.
51#
52# .debug (default):
53# When splitting the debug information will be placed into
54# a .debug directory in the same dirname of the binary produced:
55# /bin/foo -> /bin/.debug/foo
56#
57# debug-file-directory:
58# When splitting the debug information will be placed into
59# a central debug-file-directory, /usr/lib/debug:
60# /bin/foo -> /usr/lib/debug/bin/foo.debug
61#
62# Any source code referenced in the debug symbols will be copied
63# and made available within the /usr/src/debug directory
64#
65#PACKAGE_DEBUG_SPLIT_STYLE = '.debug'
66# PACKAGE_DEBUG_SPLIT_STYLE = 'debug-file-directory'
67
68# Uncomment these to build a package such that you can use gprof to profile it.
69# NOTE: This will only work with 'linux' targets, not
70# 'linux-uclibc', as uClibc doesn't provide the necessary
71# object files. Also, don't build glibc itself with these
72# flags, or it'll fail to build.
73#
74# PROFILE_OPTIMIZATION = "-pg"
75# SELECTED_OPTIMIZATION = "${PROFILE_OPTIMIZATION}"
76# LDFLAGS =+ "-pg"
77
78# TCMODE controls the characteristics of the generated packages/images by
79# telling poky which toolchain 'profile' to use.
80#
81# The default is "default"
82# Use "external-MODE" to use the precompiled external toolchains where MODE
83# is the type of external toolchain to use e.g. eabi. You need to ensure
84# the toolchain you want to use is included in an appropriate layer
85# TCMODE ?= "external-eabi"
86
87# mklibs library size optimization is more useful to smaller images,
88# and less useful for bigger images. Also mklibs library optimization
89# can break the ABI compatibility, so should not be applied to the
90# images which are to be extended or upgraded later.
91#This enabled mklibs library size optimization just for the specified image.
92#MKLIBS_OPTIMIZED_IMAGES ?= "core-image-minimal"
93#This enable mklibs library size optimization will be for all the images.
94#MKLIBS_OPTIMIZED_IMAGES ?= "all"
95
96# Uncomment this if your host distribution provides the help2man tool.
97#ASSUME_PROVIDED += "help2man-native"
98
99# This value is currently used by pseudo to determine if the recipe should
100# build both the 32-bit and 64-bit wrapper libraries on a 64-bit build system.
101#
102# Pseudo will attempt to determine if a 32-bit wrapper is necessary, but
103# it doesn't always guess properly. If you have 32-bit executables on
104# your 64-bit build system, you likely want to set this to "0",
105# otherwise you could end up with incorrect file attributes on the
106# target filesystem.
107#
108# Default is to not build 32 bit libs on 64 bit systems, uncomment this
109# if you need the 32 bits libs
110#NO32LIBS = "0"
111
112# Uncomment the following lines to enable multilib builds
113#require conf/multilib.conf
114#MULTILIBS = "multilib:lib32"
115#DEFAULTTUNE_virtclass-multilib-lib32 = "x86"
116
117# The network based PR service host and port
118# Uncomment the following lines to enable PRservice.
119# Set PRSERV_HOST to 'localhost:0' to automatically
120# start local PRService.
121# Set to other values to use remote PRService.
122#PRSERV_HOST = "localhost:0"
123
124# Additional image generation features
125#
126# The following is a list of classes to import to use in the generation of images
127# currently an example class is image_types_uboot
128# IMAGE_CLASSES = " image_types_uboot"
129
130# Incremental rpm image generation, the rootfs would be totally removed
131# and re-created in the second generation by default, but with
132# INC_RPM_IMAGE_GEN = "1", the rpm based rootfs would be kept, and will
133# do update(remove/add some pkgs) on it. NOTE: This is not suggested
134# when you want to create a productive rootfs
135#INC_RPM_IMAGE_GEN = "1"
136
137# This is a list of packages that require a commercial license to ship
138# product. If shipped as part of an image these packages may have
139# implications so they are disabled by default. To enable them,
140# un-comment the below as appropriate.
141#LICENSE_FLAGS_WHITELIST = "commercial_gst-fluendo-mp3 \
142# commercial_gst-openmax \
143# commercial_gst-plugins-ugly \
144# commercial_lame \
145# commercial_libmad \
146# commercial_libomxil \
147# commercial_mpeg2dec \
148# commercial_qmmp"
149
150
151#
152# Disk space monitor, take action when the disk space or the amount of
153# inode is running low, it is enabled when BB_DISKMON_DIRS is set.
154#
155# Set the directory for the monitor, the format is:
156# "action,directory,minimum_space,minimum_free_inode"
157#
158# The "action" must be set and should be one of:
159# ABORT: Immediately abort
160# STOPTASKS: The new tasks can't be executed any more, will stop the build
161# when the running tasks have been done.
162# WARN: show warnings (see BB_DISKMON_WARNINTERVAL for more information)
163#
164# The "directory" must be set, any directory is OK.
165#
166# Either "minimum_space" or "minimum_free_inode" (or both of them)
167# should be set, otherwise the monitor would not be enabled,
168# the unit can be G, M, K or none, but do NOT use GB, MB or KB
169# (B is not needed).
170#BB_DISKMON_DIRS = "STOPTASKS,${TMPDIR},1G,100K WARN,${SSTATE_DIR},1G,100K"
171#
172# Set disk space and inode interval (only works when the action is "WARN",
173# the unit can be G, M, or K, but do NOT use the GB, MB or KB
174# (B is not needed), the format is:
175# "disk_space_interval,disk_inode_interval", the default value is
176# "50M,5K" which means that it would warn when the free space is
177# lower than the minimum space(or inode), and would repeat the warning
178# when the disk space reduces 50M (or the amount of inode reduces 5k).
179#BB_DISKMON_WARNINTERVAL = "50M,5K"
180
181# Archiving source code, configure what kind of sources will be archived
182# and the output format. The output files will be put in
183# ${DEPLOY_DIR}/sources/.
184#
185# You can add the following 3 lines to the conf file to get a quick
186# usage:
187#ARCHIVER_MODE ?= "original"
188#ARCHIVER_CLASS = "${@'archive-${ARCHIVER_MODE}-source' if ARCHIVER_MODE != 'none' else ''}"
189#INHERIT += "${ARCHIVER_CLASS}"
190#
191# Detailed configuration:
192# What kind of sources will be archived, the ARCHIVER_MODE could be:
193# original: the ${S} after do_unpack
194# patched : the ${S} after do_patch
195# configured: the ${S} after do_configure
196#ARCHIVER_MODE ?= "original"
197#
198# The output format type, tar or srpm, the default is "tar".
199#ARCHIVER_MODE[type] ?= "tar"
200#
201# Whether include the log file under ${T} and the recipe (.bb and .inc),
202# the default is "logs_with_scripts".
203#ARCHIVER_MODE[log_type] ?= "logs_with_scripts"
204#
205# license filter:
206# yes: Only the COPYLEFT_LICENSE_INCLUDE recipe will be archived
207# no: All kinds lof license will be archived
208# The default is "no"
209#ARCHIVER_MODE[filter] ?= "no"
210#
211# Put the following two lines in the conf file with intact.
212#ARCHIVER_CLASS = "${@'archive-${ARCHIVER_MODE}-source' if ARCHIVER_MODE != 'none' else ''}"
213#INHERIT += "${ARCHIVER_CLASS}"
214
215# Remove the old image before the new one generated to save disk space
216#RM_OLD_IMAGE = "1"
217
218# Use the following line to enable the security compiler and linker flags to your build
219#require conf/distro/include/security_flags.inc
220
221# Image level user/group configuration.
222# Inherit extrausers to make the setting of EXTRA_USERS_PARAMS effective.
223#INHERIT += "extrausers"
224# User / group settings
225# The settings are sperated by the ; character.
226# Each setting is actually a command. The supported commands are useradd,
227# groupadd, userdel, groupdel, usermod and groupmod.
228#EXTRA_USERS_PARAMS = "\
229#useradd -p '' tester; \
230#groupadd developers; \
231#userdel nobody; \
232#groupdel -g video; \
233#groupmod -g 1020 developers; \
234#usermod -s /bin/sh tester; \
235#"
236
237# Enabling FORTRAN
238# Note this is not officially supported and is just illustrated here to
239# show an example of how it can be done
240FORTRAN_forcevariable = ",fortran"
241RUNTIMETARGET_append_pn-gcc-runtime = " libquadmath libgfortran"
242export BUILD_FC = "${CCACHE}${BUILD_PREFIX}gfortran ${BUILD_CC_ARCH}"
243export FC = "${CCACHE}${HOST_PREFIX}gfortran ${HOST_CC_ARCH}"
244
245#
246# Kernel image features
247#
248# The INITRAMFS_IMAGE image variable will cause an additional recipe to
249# be built as a dependency to the what ever rootfs recipe you might be
250# using such as core-image-sato. The initramfs might be needed for
251# the initial boot of of the target system such as to load kernel
252# modules prior to mounting the root file system.
253#
254# INITRAMFS_IMAGE_BUNDLE variable controls if the image recipe
255# specified by the INITRAMFS_IMAGE will be run through an extra pass
256# through the kernel compilation in order to build a single binary
257# which contains both the kernel image and the initramfs. The
258# combined binary will be deposited into the tmp/deploy directory.
259# NOTE: You can set INITRAMFS_IMAGE in an image recipe, but
260# INITRAMFS_IMAGE_BUNDLE can only be set in a conf file.
261#
262#INITRAMFS_IMAGE = "core-image-minimal-initramfs"
263#INITRAMFS_IMAGE_BUNDLE = "1"
264
265