summaryrefslogtreecommitdiffstats
path: root/meta-yocto/conf/local.conf.sample.extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto/conf/local.conf.sample.extended')
-rw-r--r--meta-yocto/conf/local.conf.sample.extended312
1 files changed, 312 insertions, 0 deletions
diff --git a/meta-yocto/conf/local.conf.sample.extended b/meta-yocto/conf/local.conf.sample.extended
new file mode 100644
index 0000000000..a1f24649a3
--- /dev/null
+++ b/meta-yocto/conf/local.conf.sample.extended
@@ -0,0 +1,312 @@
1# BBMASK is a regular expression that can be used to tell BitBake to ignore
2# certain recipes.
3#BBMASK = ""
4
5# eglibc configurability is used to reduce minimal image's size.
6# the all supported eglibc options are listed in DISTRO_FEATURES_LIBC
7# and disabled by default. Uncomment and copy the DISTRO_FEATURES_LIBC
8# and DISTRO_FEATURES definitions to local.conf to enable the options.
9#DISTRO_FEATURES_LIBC = "ipv6 libc-backtrace libc-big-macros libc-bsd libc-cxx-tests libc-catgets libc-charsets libc-crypt \
10# libc-crypt-ufc libc-db-aliases libc-envz libc-fcvt libc-fmtmsg libc-fstab libc-ftraverse \
11# libc-getlogin libc-idn libc-inet libc-inet-anl libc-libm libc-locales libc-locale-code \
12# libc-memusage libc-nis libc-nsswitch libc-rcmd libc-rtld-debug libc-spawn libc-streams libc-sunrpc \
13# libc-utmp libc-utmpx libc-wordexp libc-posix-clang-wchar libc-posix-regexp libc-posix-regexp-glibc \
14# libc-posix-wchar-io"
15
16#DISTRO_FEATURES = "alsa bluetooth ext2 irda pcmcia usbgadget usbhost wifi nfs zeroconf pci ${DISTRO_FEATURES_LIBC}"
17
18# If you want to get an image based on directfb without x11, Please copy this variable to build/conf/local.conf
19#DISTRO_FEATURES = "alsa argp bluetooth ext2 irda largefile pcmcia usbgadget usbhost wifi xattr nfs zeroconf pci 3g directfb ${DISTRO_FEATURES_LIBC}"
20
21# ENABLE_BINARY_LOCALE_GENERATION controls the generation of binary locale
22# packages at build time using qemu-native. Disabling it (by setting it to 0)
23# will save some build time at the expense of breaking i18n on devices with
24# less than 128MB RAM.
25#ENABLE_BINARY_LOCALE_GENERATION = "1"
26
27# Set GLIBC_GENERATE_LOCALES to the locales you wish to generate should you not
28# wish to perform the time-consuming step of generating all LIBC locales.
29# NOTE: If removing en_US.UTF-8 you will also need to uncomment, and set
30# appropriate values for IMAGE_LINGUAS and LIMIT_BUILT_LOCALES
31# WARNING: this may break localisation!
32#GLIBC_GENERATE_LOCALES = "en_GB.UTF-8 en_US.UTF-8"
33# See message above as to whether setting these is required
34#IMAGE_LINGUAS ?= "en-gb"
35#LIMIT_BUILT_LOCALES ?= "POSIX en_GB"
36
37# The following are used to control options related to debugging.
38#
39# Uncomment this to change the optimization to make debugging easer, at the
40# possible cost of performance.
41# DEBUG_BUILD = "1"
42#
43# Uncomment this to disable the stripping of the installed binaries
44# INHIBIT_PACKAGE_STRIP = "1"
45#
46# Uncomment this to disable the split of the debug information into -dbg files
47# INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
48#
49# When splitting debug information, the following controls the results of the
50# file splitting.
51#
52# .debug (default):
53# When splitting the debug information will be placed into
54# a .debug directory in the same dirname of the binary produced:
55# /bin/foo -> /bin/.debug/foo
56#
57# debug-file-directory:
58# When splitting the debug information will be placed into
59# a central debug-file-directory, /usr/lib/debug:
60# /bin/foo -> /usr/lib/debug/bin/foo.debug
61#
62# Any source code referenced in the debug symbols will be copied
63# and made available within the /usr/src/debug directory
64#
65#PACKAGE_DEBUG_SPLIT_STYLE = '.debug'
66# PACKAGE_DEBUG_SPLIT_STYLE = 'debug-file-directory'
67
68# Uncomment these to build a package such that you can use gprof to profile it.
69# NOTE: This will only work with 'linux' targets, not
70# 'linux-uclibc', as uClibc doesn't provide the necessary
71# object files. Also, don't build glibc itself with these
72# flags, or it'll fail to build.
73#
74# PROFILE_OPTIMIZATION = "-pg"
75# SELECTED_OPTIMIZATION = "${PROFILE_OPTIMIZATION}"
76# LDFLAGS =+ "-pg"
77
78# TCMODE controls the characteristics of the generated packages/images by
79# telling poky which toolchain 'profile' to use.
80#
81# The default is "default" which uses the internal toolchain. With
82# additional layers, it is possible to set this to use a precompiled
83# external toolchain. One example is the Sourcery G++ Toolchain, support
84# for which is now in the separate meta-sourcery layer:
85#
86# http://github.com/MentorEmbedded/meta-sourcery/
87#
88# meta-sourcery can be used as a template for adding support for other
89# external toolchains. See the link above for further details.
90#
91# TCMODE points the system to a file in conf/distro/include/tcmode-${TCMODE}.inc,
92# so for meta-sourcery which has conf/distro/include/tcmode-external-sourcery.inc
93# you would set it as follows:
94#
95# TCMODE ?= "external-sourcery"
96
97# mklibs library size optimization is more useful to smaller images,
98# and less useful for bigger images. Also mklibs library optimization
99# can break the ABI compatibility, so should not be applied to the
100# images which are to be extended or upgraded later.
101#This enabled mklibs library size optimization just for the specified image.
102#MKLIBS_OPTIMIZED_IMAGES ?= "core-image-minimal"
103#This enable mklibs library size optimization will be for all the images.
104#MKLIBS_OPTIMIZED_IMAGES ?= "all"
105
106# Uncomment this if your host distribution provides the help2man tool.
107#ASSUME_PROVIDED += "help2man-native"
108
109# This value is currently used by pseudo to determine if the recipe should
110# build both the 32-bit and 64-bit wrapper libraries on a 64-bit build system.
111#
112# Pseudo will attempt to determine if a 32-bit wrapper is necessary, but
113# it doesn't always guess properly. If you have 32-bit executables on
114# your 64-bit build system, you likely want to set this to "0",
115# otherwise you could end up with incorrect file attributes on the
116# target filesystem.
117#
118# Default is to not build 32 bit libs on 64 bit systems, uncomment this
119# if you need the 32 bits libs
120#NO32LIBS = "0"
121
122# Uncomment the following lines to enable multilib builds
123#require conf/multilib.conf
124#MULTILIBS = "multilib:lib32"
125#DEFAULTTUNE_virtclass-multilib-lib32 = "x86"
126
127# The network based PR service host and port
128# Uncomment the following lines to enable PRservice.
129# Set PRSERV_HOST to 'localhost:0' to automatically
130# start local PRService.
131# Set to other values to use remote PRService.
132#PRSERV_HOST = "localhost:0"
133
134# Additional image generation features
135#
136# The following is a list of classes to import to use in the generation of images
137# currently an example class is image_types_uboot
138# IMAGE_CLASSES = " image_types_uboot"
139
140# Incremental rpm image generation, the rootfs would be totally removed
141# and re-created in the second generation by default, but with
142# INC_RPM_IMAGE_GEN = "1", the rpm based rootfs would be kept, and will
143# do update(remove/add some pkgs) on it. NOTE: This is not suggested
144# when you want to create a productive rootfs
145#INC_RPM_IMAGE_GEN = "1"
146
147# This is a list of packages that require a commercial license to ship
148# product. If shipped as part of an image these packages may have
149# implications so they are disabled by default. To enable them,
150# un-comment the below as appropriate.
151#LICENSE_FLAGS_WHITELIST = "commercial_gst-fluendo-mp3 \
152# commercial_gst-openmax \
153# commercial_gst-plugins-ugly \
154# commercial_lame \
155# commercial_libmad \
156# commercial_libomxil \
157# commercial_mpeg2dec \
158# commercial_qmmp"
159
160
161#
162# Disk space monitor, take action when the disk space or the amount of
163# inode is running low, it is enabled when BB_DISKMON_DIRS is set.
164#
165# Set the directory for the monitor, the format is:
166# "action,directory,minimum_space,minimum_free_inode"
167#
168# The "action" must be set and should be one of:
169# ABORT: Immediately abort
170# STOPTASKS: The new tasks can't be executed any more, will stop the build
171# when the running tasks have been done.
172# WARN: show warnings (see BB_DISKMON_WARNINTERVAL for more information)
173#
174# The "directory" must be set, any directory is OK.
175#
176# Either "minimum_space" or "minimum_free_inode" (or both of them)
177# should be set, otherwise the monitor would not be enabled,
178# the unit can be G, M, K or none, but do NOT use GB, MB or KB
179# (B is not needed).
180#BB_DISKMON_DIRS = "STOPTASKS,${TMPDIR},1G,100K WARN,${SSTATE_DIR},1G,100K"
181#
182# Set disk space and inode interval (only works when the action is "WARN",
183# the unit can be G, M, or K, but do NOT use the GB, MB or KB
184# (B is not needed), the format is:
185# "disk_space_interval,disk_inode_interval", the default value is
186# "50M,5K" which means that it would warn when the free space is
187# lower than the minimum space(or inode), and would repeat the warning
188# when the disk space reduces 50M (or the amount of inode reduces 5k).
189#BB_DISKMON_WARNINTERVAL = "50M,5K"
190
191# Archive the source and put them to ${DEPLOY_DIR}/sources/.
192#
193#INHERIT += "archiver"
194#
195# The tarball for the patched source will be created by default, and you
196# can configure the archiver as follow:
197#
198# Create archive for:
199# 1) original (or unpacked) source:
200#ARCHIVER_MODE[src] = "original"
201# 2) patched source: (default)
202#ARCHIVER_MODE[src] = "patched"
203# 3) configured source:
204#ARCHIVER_MODE[src] = "configured"
205#
206# 4) the patches between do_unpack and do_patch:
207#ARCHIVER_MODE[diff] = "1"
208# set the files that you'd like to exclude from the diff:
209#ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
210#
211# 5) the environment data, similar to 'bitbake -e recipe':
212#ARCHIVER_MODE[dumpdata] = "1"
213#
214# 6) the recipe (.bb and .inc):
215#ARCHIVER_MODE[recipe] = "1"
216#
217# 7) Whether output the .src.rpm package:
218#ARCHIVER_MODE[srpm] = "1"
219#
220# 8) Filter the license, the recipe whose license in
221# COPYLEFT_LICENSE_INCLUDE will be included, and in
222# COPYLEFT_LICENSE_EXCLUDE will be excluded.
223#COPYLEFT_LICENSE_INCLUDE = 'GPL* LGPL*'
224#COPYLEFT_LICENSE_EXCLUDE = 'CLOSED Proprietary'
225#
226# 9) Config the recipe type that will be archived, the type can be
227# target, native, nativesdk, cross, crosssdk and cross-canadian,
228# you can set one or more types. Archive all types by default.
229#COPYLEFT_RECIPE_TYPES = 'target'
230#
231
232# Remove the old image before the new one generated to save disk space
233#RM_OLD_IMAGE = "1"
234
235#
236# GCC/LD FLAGS to enable more secure code generation
237#
238# By including the security_flags include file you enable flags
239# to the compiler and linker that cause them to generate more secure
240# code, this is enabled by default in the poky-lsb distro.
241# This does affect compile speed slightly.
242#
243# Use the following line to enable the security compiler and linker flags to your build
244#require conf/distro/include/security_flags.inc
245
246# Image level user/group configuration.
247# Inherit extrausers to make the setting of EXTRA_USERS_PARAMS effective.
248#INHERIT += "extrausers"
249# User / group settings
250# The settings are sperated by the ; character.
251# Each setting is actually a command. The supported commands are useradd,
252# groupadd, userdel, groupdel, usermod and groupmod.
253#EXTRA_USERS_PARAMS = "\
254#useradd -p '' tester; \
255#groupadd developers; \
256#userdel nobody; \
257#groupdel -g video; \
258#groupmod -g 1020 developers; \
259#usermod -s /bin/sh tester; \
260#"
261
262# Various packages dynamically add users and groups to the system at package
263# install time. For programs that do not care what the uid/gid is of the
264# resulting users/groups, the order of the install will determine the final
265# uid/gid. This can lead to non-deterministic uid/gid values from one build
266# to another. Use the following settings to specify that all user/group adds
267# should be created based on a static passwd/group file.
268#
269# Note, if you enable or disable the useradd-staticids in a configured system,
270# the TMPDIR may contain incorrect uid/gid values. Clearing the TMPDIR
271# will correct this condition.
272#
273# By default the system looks in the BBPATH for files/passwd and files/group
274# the default can be overriden by spefying USERADD_UID/GID_TABLES.
275#
276#USERADDEXTENSION = "useradd-staticids"
277#USERADD_UID_TABLES = "files/passwd"
278#USERADD_GID_TABLES = "files/group"
279#
280# In order to prevent generating a system where a dynamicly assigned uid/gid
281# can exist, you should enable the following setting. This will force the
282# system to error out if the user/group name is not defined in the
283# files/passwd or files/group (or specified replacements.)
284#USERADD_ERROR_DYNAMIC = "1"
285
286# Enabling FORTRAN
287# Note this is not officially supported and is just illustrated here to
288# show an example of how it can be done
289# You'll also need your fortran recipe to depend on libgfortran
290#FORTRAN_forcevariable = ",fortran"
291#RUNTIMETARGET_append_pn-gcc-runtime = " libquadmath"
292
293#
294# Kernel image features
295#
296# The INITRAMFS_IMAGE image variable will cause an additional recipe to
297# be built as a dependency to the what ever rootfs recipe you might be
298# using such as core-image-sato. The initramfs might be needed for
299# the initial boot of of the target system such as to load kernel
300# modules prior to mounting the root file system.
301#
302# INITRAMFS_IMAGE_BUNDLE variable controls if the image recipe
303# specified by the INITRAMFS_IMAGE will be run through an extra pass
304# through the kernel compilation in order to build a single binary
305# which contains both the kernel image and the initramfs. The
306# combined binary will be deposited into the tmp/deploy directory.
307# NOTE: You can set INITRAMFS_IMAGE in an image recipe, but
308# INITRAMFS_IMAGE_BUNDLE can only be set in a conf file.
309#
310#INITRAMFS_IMAGE = "core-image-minimal-initramfs"
311#INITRAMFS_IMAGE_BUNDLE = "1"
312