summaryrefslogtreecommitdiffstats
path: root/meta-yocto/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto/conf/layer.conf')
-rw-r--r--meta-yocto/conf/layer.conf16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-yocto/conf/layer.conf b/meta-yocto/conf/layer.conf
new file mode 100644
index 0000000000..9942b518ee
--- /dev/null
+++ b/meta-yocto/conf/layer.conf
@@ -0,0 +1,16 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH =. "${LAYERDIR}:"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "yocto"
9BBFILE_PATTERN_yocto = "^${LAYERDIR}/"
10BBFILE_PRIORITY_yocto = "5"
11
12# This should only be incremented on significant changes that will
13# cause compatibility issues with other layers
14LAYERVERSION_yocto = "2"
15
16LAYERDEPENDS_yocto = "core"