summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/conf/layer.conf11
-rw-r--r--meta-yocto-bsp/conf/machine/beaglebone.conf37
-rw-r--r--meta-yocto-bsp/conf/machine/edgerouter.conf22
-rw-r--r--meta-yocto-bsp/conf/machine/genericx86-64.conf8
-rw-r--r--meta-yocto-bsp/conf/machine/genericx86.conf8
-rw-r--r--meta-yocto-bsp/conf/machine/include/genericx86-common.inc20
-rw-r--r--meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf30
-rw-r--r--meta-yocto-bsp/recipes-bsp/alsa-state/alsa-state.bbappend1
-rw-r--r--meta-yocto-bsp/recipes-bsp/alsa-state/alsa-state/beagleboard/asound.state656
-rwxr-xr-xmeta-yocto-bsp/recipes-bsp/formfactor/formfactor/beagleboard/machconfig3
-rw-r--r--meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86-64/machconfig6
-rw-r--r--meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86/machconfig6
-rw-r--r--meta-yocto-bsp/recipes-bsp/formfactor/formfactor_0.0.bbappend1
-rw-r--r--meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend2
-rw-r--r--meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86-64/uClibc.machine69
-rw-r--r--meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86/uClibc.machine69
-rw-r--r--meta-yocto-bsp/recipes-core/uclibc/uclibc_git.bbappend1
-rw-r--r--meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86-64/xorg.conf0
-rw-r--r--meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86/xorg.conf0
-rw-r--r--meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend1
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend14
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.14.bbappend17
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend7
23 files changed, 989 insertions, 0 deletions
diff --git a/meta-yocto-bsp/conf/layer.conf b/meta-yocto-bsp/conf/layer.conf
new file mode 100644
index 0000000000..44dbca60f7
--- /dev/null
+++ b/meta-yocto-bsp/conf/layer.conf
@@ -0,0 +1,11 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "yoctobsp"
9BBFILE_PATTERN_yoctobsp = "^${LAYERDIR}/"
10BBFILE_PRIORITY_yoctobsp = "5"
11LAYERVERSION_yoctobsp = "3"
diff --git a/meta-yocto-bsp/conf/machine/beaglebone.conf b/meta-yocto-bsp/conf/machine/beaglebone.conf
new file mode 100644
index 0000000000..42637158df
--- /dev/null
+++ b/meta-yocto-bsp/conf/machine/beaglebone.conf
@@ -0,0 +1,37 @@
1#@TYPE: Machine
2#@NAME: Beaglebone machine
3#@DESCRIPTION: Machine configuration for http://beagleboard.org/bone and http://beagleboard.org/black boards
4
5PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
6XSERVER ?= "xserver-xorg \
7 xf86-input-evdev \
8 xf86-input-mouse \
9 xf86-video-fbdev \
10 xf86-input-keyboard"
11
12MACHINE_EXTRA_RRECOMMENDS = " kernel-modules kernel-devicetree"
13
14EXTRA_IMAGEDEPENDS += "u-boot"
15
16DEFAULTTUNE ?= "cortexa8hf-neon"
17include conf/machine/include/tune-cortexa8.inc
18
19IMAGE_FSTYPES += "tar.bz2 jffs2"
20EXTRA_IMAGECMD_jffs2 = "-lnp "
21
22SERIAL_CONSOLE = "115200 ttyO0"
23
24PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
25PREFERRED_VERSION_linux-yocto ?= "3.14%"
26
27KERNEL_IMAGETYPE = "uImage"
28KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblack.dtb"
29KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
30
31SPL_BINARY = "MLO"
32UBOOT_SUFFIX = "img"
33UBOOT_MACHINE = "am335x_evm_config"
34UBOOT_ENTRYPOINT = "0x80008000"
35UBOOT_LOADADDRESS = "0x80008000"
36
37MACHINE_FEATURES = "usbgadget usbhost vfat alsa"
diff --git a/meta-yocto-bsp/conf/machine/edgerouter.conf b/meta-yocto-bsp/conf/machine/edgerouter.conf
new file mode 100644
index 0000000000..9cb84bc037
--- /dev/null
+++ b/meta-yocto-bsp/conf/machine/edgerouter.conf
@@ -0,0 +1,22 @@
1#@TYPE: Machine
2#@NAME: Edgerouter
3#@DESCRIPTION: Edgerouter
4
5require conf/machine/include/tune-mips64.inc
6
7MACHINE_FEATURES = "pci ext2 ext3 serial"
8
9KERNEL_IMAGETYPE = "vmlinux"
10KERNEL_ALT_IMAGETYPE = "vmlinux.bin"
11KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment"
12
13PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
14PREFERRED_VERSION_linux-yocto ?= "3.14%"
15
16SERIAL_CONSOLE = "115200 ttyS0"
17USE_VT ?= "0"
18
19MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
20
21IMAGE_FSTYPES ?= "jffs2 tar.bz2"
22JFFS2_ERASEBLOCK = "0x10000"
diff --git a/meta-yocto-bsp/conf/machine/genericx86-64.conf b/meta-yocto-bsp/conf/machine/genericx86-64.conf
new file mode 100644
index 0000000000..f76e35af67
--- /dev/null
+++ b/meta-yocto-bsp/conf/machine/genericx86-64.conf
@@ -0,0 +1,8 @@
1#@TYPE: Machine
2#@NAME: Generic X86_64.
3
4#@DESCRIPTION: Machine configuration for generic X86_64 (64-bit) PCs and servers. Supports a moderately wide range of drivers that should boot and be usable on "typical" hardware.
5
6DEFAULTTUNE ?= "core2-64"
7require conf/machine/include/tune-core2.inc
8require conf/machine/include/genericx86-common.inc
diff --git a/meta-yocto-bsp/conf/machine/genericx86.conf b/meta-yocto-bsp/conf/machine/genericx86.conf
new file mode 100644
index 0000000000..2642caba54
--- /dev/null
+++ b/meta-yocto-bsp/conf/machine/genericx86.conf
@@ -0,0 +1,8 @@
1#@TYPE: Machine
2#@NAME: Generic X86.
3
4#@DESCRIPTION: Machine configuration for generic X86 (32-bit) PCs. Supports a moderately wide range of drivers that should boot and be usable on "typical" hardware.
5
6DEFAULTTUNE ?= "core2-32"
7require conf/machine/include/tune-core2.inc
8require conf/machine/include/genericx86-common.inc
diff --git a/meta-yocto-bsp/conf/machine/include/genericx86-common.inc b/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
new file mode 100644
index 0000000000..66bfd194da
--- /dev/null
+++ b/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
@@ -0,0 +1,20 @@
1include conf/machine/include/x86-base.inc
2MACHINE_FEATURES += "wifi efi pcbios"
3
4PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
5PREFERRED_VERSION_linux-yocto ?= "3.10%"
6PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
7XSERVER ?= "${XSERVER_X86_BASE} \
8 ${XSERVER_X86_EXT} \
9 ${XSERVER_X86_I915} \
10 ${XSERVER_X86_I965} \
11 ${XSERVER_X86_FBDEV} \
12 ${XSERVER_X86_VESA} \
13 ${XSERVER_X86_MODESETTING} \
14 "
15
16MACHINE_EXTRA_RRECOMMENDS += "linux-firmware v86d eee-acpi-scripts"
17
18GLIBC_ADDONS = "nptl"
19
20EXTRA_OECONF_append_pn-matchbox-panel-2 = " --with-battery=acpi"
diff --git a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
new file mode 100644
index 0000000000..ab1eaa9101
--- /dev/null
+++ b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
@@ -0,0 +1,30 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4TARGET_FPU = ""
5
6require conf/machine/include/tune-ppce300c3.inc
7
8KERNEL_IMAGETYPE = "uImage"
9
10EXTRA_IMAGEDEPENDS += "u-boot"
11UBOOT_MACHINE_mpc8315e-rdb = "MPC8315ERDB_config"
12
13SERIAL_CONSOLE = "115200 ttyS0"
14
15MACHINE_FEATURES = "keyboard pci ext2 ext3 serial"
16
17PREFERRED_VERSION_linux-yocto ?= "3.10%"
18PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
19
20PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
21XSERVER ?= "xserver-xorg \
22 xf86-input-evdev \
23 xf86-video-fbdev"
24
25PREFERRED_VERSION_u-boot ?= "v2013.07%"
26UBOOT_ENTRYPOINT = "0x00000000"
27
28KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/mpc8315erdb.dts"
29
30MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
diff --git a/meta-yocto-bsp/recipes-bsp/alsa-state/alsa-state.bbappend b/meta-yocto-bsp/recipes-bsp/alsa-state/alsa-state.bbappend
new file mode 100644
index 0000000000..72d991c7e5
--- /dev/null
+++ b/meta-yocto-bsp/recipes-bsp/alsa-state/alsa-state.bbappend
@@ -0,0 +1 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-yocto-bsp/recipes-bsp/alsa-state/alsa-state/beagleboard/asound.state b/meta-yocto-bsp/recipes-bsp/alsa-state/alsa-state/beagleboard/asound.state
new file mode 100644
index 0000000000..f92449152c
--- /dev/null
+++ b/meta-yocto-bsp/recipes-bsp/alsa-state/alsa-state/beagleboard/asound.state
@@ -0,0 +1,656 @@
1state.omap3beagle {
2 control.1 {
3 comment.access 'read write'
4 comment.type ENUMERATED
5 comment.count 1
6 comment.item.0 'Option 2 (voice/audio)'
7 comment.item.1 'Option 1 (audio)'
8 iface MIXER
9 name 'Codec Operation Mode'
10 value 'Option 1 (audio)'
11 }
12 control.2 {
13 comment.access 'read write'
14 comment.type INTEGER
15 comment.count 2
16 comment.range '0 - 63'
17 comment.dbmin -6300
18 comment.dbmax 0
19 iface MIXER
20 name 'DAC1 Digital Fine Playback Volume'
21 value.0 0
22 value.1 0
23 }
24 control.3 {
25 comment.access 'read write'
26 comment.type INTEGER
27 comment.count 2
28 comment.range '0 - 63'
29 comment.dbmin -6300
30 comment.dbmax 0
31 iface MIXER
32 name 'DAC2 Digital Fine Playback Volume'
33 value.0 50
34 value.1 50
35 }
36 control.4 {
37 comment.access 'read write'
38 comment.type INTEGER
39 comment.count 2
40 comment.range '0 - 2'
41 comment.dbmin 0
42 comment.dbmax 1200
43 iface MIXER
44 name 'DAC1 Digital Coarse Playback Volume'
45 value.0 0
46 value.1 0
47 }
48 control.5 {
49 comment.access 'read write'
50 comment.type INTEGER
51 comment.count 2
52 comment.range '0 - 2'
53 comment.dbmin 0
54 comment.dbmax 1200
55 iface MIXER
56 name 'DAC2 Digital Coarse Playback Volume'
57 value.0 2
58 value.1 2
59 }
60 control.6 {
61 comment.access 'read write'
62 comment.type INTEGER
63 comment.count 2
64 comment.range '0 - 18'
65 comment.dbmin -2400
66 comment.dbmax 1200
67 iface MIXER
68 name 'DAC1 Analog Playback Volume'
69 value.0 0
70 value.1 0
71 }
72 control.7 {
73 comment.access 'read write'
74 comment.type INTEGER
75 comment.count 2
76 comment.range '0 - 18'
77 comment.dbmin -2400
78 comment.dbmax 1200
79 iface MIXER
80 name 'DAC2 Analog Playback Volume'
81 value.0 15
82 value.1 15
83 }
84 control.8 {
85 comment.access 'read write'
86 comment.type BOOLEAN
87 comment.count 2
88 iface MIXER
89 name 'DAC1 Analog Playback Switch'
90 value.0 false
91 value.1 false
92 }
93 control.9 {
94 comment.access 'read write'
95 comment.type BOOLEAN
96 comment.count 2
97 iface MIXER
98 name 'DAC2 Analog Playback Switch'
99 value.0 true
100 value.1 true
101 }
102 control.10 {
103 comment.access 'read write'
104 comment.type INTEGER
105 comment.count 1
106 comment.range '0 - 49'
107 comment.dbmin -3700
108 comment.dbmax 1200
109 iface MIXER
110 name 'DAC Voice Digital Downlink Volume'
111 value 0
112 }
113 control.11 {
114 comment.access 'read write'
115 comment.type INTEGER
116 comment.count 1
117 comment.range '0 - 18'
118 comment.dbmin -2400
119 comment.dbmax 1200
120 iface MIXER
121 name 'DAC Voice Analog Downlink Volume'
122 value 18
123 }
124 control.12 {
125 comment.access 'read write'
126 comment.type BOOLEAN
127 comment.count 1
128 iface MIXER
129 name 'DAC Voice Analog Downlink Switch'
130 value false
131 }
132 control.13 {
133 comment.access 'read write'
134 comment.type INTEGER
135 comment.count 2
136 comment.range '0 - 3'
137 comment.dbmin -1200
138 comment.dbmax 600
139 iface MIXER
140 name 'PreDriv Playback Volume'
141 value.0 0
142 value.1 0
143 }
144 control.14 {
145 comment.access 'read write'
146 comment.type INTEGER
147 comment.count 2
148 comment.range '0 - 3'
149 comment.dbmin -1200
150 comment.dbmax 600
151 iface MIXER
152 name 'Headset Playback Volume'
153 value.0 3
154 value.1 3
155 }
156 control.15 {
157 comment.access 'read write'
158 comment.type INTEGER
159 comment.count 2
160 comment.range '0 - 3'
161 comment.dbmin -1200
162 comment.dbmax 600
163 iface MIXER
164 name 'Carkit Playback Volume'
165 value.0 0
166 value.1 0
167 }
168 control.16 {
169 comment.access 'read write'
170 comment.type INTEGER
171 comment.count 1
172 comment.range '0 - 3'
173 comment.dbmin -600
174 comment.dbmax 1200
175 iface MIXER
176 name 'Earpiece Playback Volume'
177 value 0
178 }
179 control.17 {
180 comment.access 'read write'
181 comment.type INTEGER
182 comment.count 2
183 comment.range '0 - 31'
184 comment.dbmin 0
185 comment.dbmax 3100
186 iface MIXER
187 name 'TX1 Digital Capture Volume'
188 value.0 12
189 value.1 12
190 }
191 control.18 {
192 comment.access 'read write'
193 comment.type INTEGER
194 comment.count 2
195 comment.range '0 - 31'
196 comment.dbmin 0
197 comment.dbmax 3100
198 iface MIXER
199 name 'TX2 Digital Capture Volume'
200 value.0 0
201 value.1 0
202 }
203 control.19 {
204 comment.access 'read write'
205 comment.type INTEGER
206 comment.count 2
207 comment.range '0 - 5'
208 comment.dbmin 0
209 comment.dbmax 3000
210 iface MIXER
211 name 'Analog Capture Volume'
212 value.0 0
213 value.1 0
214 }
215 control.20 {
216 comment.access 'read write'
217 comment.type ENUMERATED
218 comment.count 1
219 comment.item.0 'Voice high priority'
220 comment.item.1 'HiFi high priority'
221 iface MIXER
222 name 'AVADC Clock Priority'
223 value 'Voice high priority'
224 }
225 control.21 {
226 comment.access 'read write'
227 comment.type ENUMERATED
228 comment.count 1
229 comment.item.0 '27/20/14 ms'
230 comment.item.1 '55/40/27 ms'
231 comment.item.2 '109/81/55 ms'
232 comment.item.3 '218/161/109 ms'
233 comment.item.4 '437/323/218 ms'
234 comment.item.5 '874/645/437 ms'
235 comment.item.6 '1748/1291/874 ms'
236 comment.item.7 '3495/2581/1748 ms'
237 iface MIXER
238 name 'HS ramp delay'
239 value '27/20/14 ms'
240 }
241 control.22 {
242 comment.access 'read write'
243 comment.type ENUMERATED
244 comment.count 1
245 comment.item.0 'Vibra H-bridge direction'
246 comment.item.1 'Audio data MSB'
247 iface MIXER
248 name 'Vibra H-bridge mode'
249 value 'Vibra H-bridge direction'
250 }
251 control.23 {
252 comment.access 'read write'
253 comment.type ENUMERATED
254 comment.count 1
255 comment.item.0 'Positive polarity'
256 comment.item.1 'Negative polarity'
257 iface MIXER
258 name 'Vibra H-bridge direction'
259 value 'Positive polarity'
260 }
261 control.24 {
262 comment.access 'read write'
263 comment.type BOOLEAN
264 comment.count 1
265 iface MIXER
266 name 'Analog Right Sub Mic Capture Switch'
267 value false
268 }
269 control.25 {
270 comment.access 'read write'
271 comment.type BOOLEAN
272 comment.count 1
273 iface MIXER
274 name 'Analog Right AUXR Capture Switch'
275 value true
276 }
277 control.26 {
278 comment.access 'read write'
279 comment.type BOOLEAN
280 comment.count 1
281 iface MIXER
282 name 'Analog Left Main Mic Capture Switch'
283 value false
284 }
285 control.27 {
286 comment.access 'read write'
287 comment.type BOOLEAN
288 comment.count 1
289 iface MIXER
290 name 'Analog Left Headset Mic Capture Switch'
291 value false
292 }
293 control.28 {
294 comment.access 'read write'
295 comment.type BOOLEAN
296 comment.count 1
297 iface MIXER
298 name 'Analog Left AUXL Capture Switch'
299 value true
300 }
301 control.29 {
302 comment.access 'read write'
303 comment.type BOOLEAN
304 comment.count 1
305 iface MIXER
306 name 'Analog Left Carkit Mic Capture Switch'
307 value false
308 }
309 control.30 {
310 comment.access 'read write'
311 comment.type ENUMERATED
312 comment.count 1
313 comment.item.0 Analog
314 comment.item.1 Digimic1
315 iface MIXER
316 name 'TX2 Capture Route'
317 value Analog
318 }
319 control.31 {
320 comment.access 'read write'
321 comment.type ENUMERATED
322 comment.count 1
323 comment.item.0 Analog
324 comment.item.1 Digimic0
325 iface MIXER
326 name 'TX1 Capture Route'
327 value Analog
328 }
329 control.32 {
330 comment.access 'read write'
331 comment.type ENUMERATED
332 comment.count 1
333 comment.item.0 'Local vibrator'
334 comment.item.1 Audio
335 iface MIXER
336 name 'Vibra Route'
337 value 'Local vibrator'
338 }
339 control.33 {
340 comment.access 'read write'
341 comment.type ENUMERATED
342 comment.count 1
343 comment.item.0 AudioL1
344 comment.item.1 AudioR1
345 comment.item.2 AudioL2
346 comment.item.3 AudioR2
347 iface MIXER
348 name 'Vibra Mux'
349 value AudioL1
350 }
351 control.34 {
352 comment.access 'read write'
353 comment.type BOOLEAN
354 comment.count 1
355 iface MIXER
356 name 'HandsfreeR Switch'
357 value false
358 }
359 control.35 {
360 comment.access 'read write'
361 comment.type ENUMERATED
362 comment.count 1
363 comment.item.0 Voice
364 comment.item.1 AudioR1
365 comment.item.2 AudioR2
366 comment.item.3 AudioL2
367 iface MIXER
368 name 'HandsfreeR Mux'
369 value Voice
370 }
371 control.36 {
372 comment.access 'read write'
373 comment.type BOOLEAN
374 comment.count 1
375 iface MIXER
376 name 'HandsfreeL Switch'
377 value false
378 }
379 control.37 {
380 comment.access 'read write'
381 comment.type ENUMERATED
382 comment.count 1
383 comment.item.0 Voice
384 comment.item.1 AudioL1
385 comment.item.2 AudioL2
386 comment.item.3 AudioR2
387 iface MIXER
388 name 'HandsfreeL Mux'
389 value Voice
390 }
391 control.38 {
392 comment.access 'read write'
393 comment.type BOOLEAN
394 comment.count 1
395 iface MIXER
396 name 'CarkitR Mixer Voice'
397 value false
398 }
399 control.39 {
400 comment.access 'read write'
401 comment.type BOOLEAN
402 comment.count 1
403 iface MIXER
404 name 'CarkitR Mixer AudioR1'
405 value false
406 }
407 control.40 {
408 comment.access 'read write'
409 comment.type BOOLEAN
410 comment.count 1
411 iface MIXER
412 name 'CarkitR Mixer AudioR2'
413 value false
414 }
415 control.41 {
416 comment.access 'read write'
417 comment.type BOOLEAN
418 comment.count 1
419 iface MIXER
420 name 'CarkitL Mixer Voice'
421 value false
422 }
423 control.42 {
424 comment.access 'read write'
425 comment.type BOOLEAN
426 comment.count 1
427 iface MIXER
428 name 'CarkitL Mixer AudioL1'
429 value false
430 }
431 control.43 {
432 comment.access 'read write'
433 comment.type BOOLEAN
434 comment.count 1
435 iface MIXER
436 name 'CarkitL Mixer AudioL2'
437 value false
438 }
439 control.44 {
440 comment.access 'read write'
441 comment.type BOOLEAN
442 comment.count 1
443 iface MIXER
444 name 'HeadsetR Mixer Voice'
445 value false
446 }
447 control.45 {
448 comment.access 'read write'
449 comment.type BOOLEAN
450 comment.count 1
451 iface MIXER
452 name 'HeadsetR Mixer AudioR1'
453 value false
454 }
455 control.46 {
456 comment.access 'read write'
457 comment.type BOOLEAN
458 comment.count 1
459 iface MIXER
460 name 'HeadsetR Mixer AudioR2'
461 value true
462 }
463 control.47 {
464 comment.access 'read write'
465 comment.type BOOLEAN
466 comment.count 1
467 iface MIXER
468 name 'HeadsetL Mixer Voice'
469 value false
470 }
471 control.48 {
472 comment.access 'read write'
473 comment.type BOOLEAN
474 comment.count 1
475 iface MIXER
476 name 'HeadsetL Mixer AudioL1'
477 value false
478 }
479 control.49 {
480 comment.access 'read write'
481 comment.type BOOLEAN
482 comment.count 1
483 iface MIXER
484 name 'HeadsetL Mixer AudioL2'
485 value true
486 }
487 control.50 {
488 comment.access 'read write'
489 comment.type BOOLEAN
490 comment.count 1
491 iface MIXER
492 name 'PredriveR Mixer Voice'
493 value false
494 }
495 control.51 {
496 comment.access 'read write'
497 comment.type BOOLEAN
498 comment.count 1
499 iface MIXER
500 name 'PredriveR Mixer AudioR1'
501 value false
502 }
503 control.52 {
504 comment.access 'read write'
505 comment.type BOOLEAN
506 comment.count 1
507 iface MIXER
508 name 'PredriveR Mixer AudioR2'
509 value false
510 }
511 control.53 {
512 comment.access 'read write'
513 comment.type BOOLEAN
514 comment.count 1
515 iface MIXER
516 name 'PredriveR Mixer AudioL2'
517 value false
518 }
519 control.54 {
520 comment.access 'read write'
521 comment.type BOOLEAN
522 comment.count 1
523 iface MIXER
524 name 'PredriveL Mixer Voice'
525 value false
526 }
527 control.55 {
528 comment.access 'read write'
529 comment.type BOOLEAN
530 comment.count 1
531 iface MIXER
532 name 'PredriveL Mixer AudioL1'
533 value false
534 }
535 control.56 {
536 comment.access 'read write'
537 comment.type BOOLEAN
538 comment.count 1
539 iface MIXER
540 name 'PredriveL Mixer AudioL2'
541 value false
542 }
543 control.57 {
544 comment.access 'read write'
545 comment.type BOOLEAN
546 comment.count 1
547 iface MIXER
548 name 'PredriveL Mixer AudioR2'
549 value false
550 }
551 control.58 {
552 comment.access 'read write'
553 comment.type BOOLEAN
554 comment.count 1
555 iface MIXER
556 name 'Earpiece Mixer Voice'
557 value false
558 }
559 control.59 {
560 comment.access 'read write'
561 comment.type BOOLEAN
562 comment.count 1
563 iface MIXER
564 name 'Earpiece Mixer AudioL1'
565 value false
566 }
567 control.60 {
568 comment.access 'read write'
569 comment.type BOOLEAN
570 comment.count 1
571 iface MIXER
572 name 'Earpiece Mixer AudioL2'
573 value false
574 }
575 control.61 {
576 comment.access 'read write'
577 comment.type BOOLEAN
578 comment.count 1
579 iface MIXER
580 name 'Earpiece Mixer AudioR1'
581 value false
582 }
583 control.62 {
584 comment.access 'read write'
585 comment.type INTEGER
586 comment.count 1
587 comment.range '0 - 41'
588 comment.dbmin -5100
589 comment.dbmax -1000
590 iface MIXER
591 name 'Voice Digital Loopback Volume'
592 value 0
593 }
594 control.63 {
595 comment.access 'read write'
596 comment.type INTEGER
597 comment.count 1
598 comment.range '0 - 7'
599 comment.dbmin -2400
600 comment.dbmax 0
601 iface MIXER
602 name 'Right Digital Loopback Volume'
603 value 0
604 }
605 control.64 {
606 comment.access 'read write'
607 comment.type INTEGER
608 comment.count 1
609 comment.range '0 - 7'
610 comment.dbmin -2400
611 comment.dbmax 0
612 iface MIXER
613 name 'Left Digital Loopback Volume'
614 value 0
615 }
616 control.65 {
617 comment.access 'read write'
618 comment.type BOOLEAN
619 comment.count 1
620 iface MIXER
621 name 'Voice Analog Loopback Switch'
622 value false
623 }
624 control.66 {
625 comment.access 'read write'
626 comment.type BOOLEAN
627 comment.count 1
628 iface MIXER
629 name 'Left2 Analog Loopback Switch'
630 value false
631 }
632 control.67 {
633 comment.access 'read write'
634 comment.type BOOLEAN
635 comment.count 1
636 iface MIXER
637 name 'Right2 Analog Loopback Switch'
638 value false
639 }
640 control.68 {
641 comment.access 'read write'
642 comment.type BOOLEAN
643 comment.count 1
644 iface MIXER
645 name 'Left1 Analog Loopback Switch'
646 value false
647 }
648 control.69 {
649 comment.access 'read write'
650 comment.type BOOLEAN
651 comment.count 1
652 iface MIXER
653 name 'Right1 Analog Loopback Switch'
654 value false
655 }
656}
diff --git a/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/beagleboard/machconfig b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/beagleboard/machconfig
new file mode 100755
index 0000000000..a46859f139
--- /dev/null
+++ b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/beagleboard/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and touchscreen are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86-64/machconfig b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86-64/machconfig
new file mode 100644
index 0000000000..a81a23bf5b
--- /dev/null
+++ b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86-64/machconfig
@@ -0,0 +1,6 @@
1HAVE_TOUCHSCREEN=0
2HAVE_KEYBOARD=1
3
4DISPLAY_CAN_ROTATE=0
5DISPLAY_ORIENTATION=0
6DISPLAY_DPI=133
diff --git a/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86/machconfig b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86/machconfig
new file mode 100644
index 0000000000..a81a23bf5b
--- /dev/null
+++ b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86/machconfig
@@ -0,0 +1,6 @@
1HAVE_TOUCHSCREEN=0
2HAVE_KEYBOARD=1
3
4DISPLAY_CAN_ROTATE=0
5DISPLAY_ORIENTATION=0
6DISPLAY_DPI=133
diff --git a/meta-yocto-bsp/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor_0.0.bbappend
new file mode 100644
index 0000000000..72d991c7e5
--- /dev/null
+++ b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -0,0 +1 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend b/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
new file mode 100644
index 0000000000..f86595c009
--- /dev/null
+++ b/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
@@ -0,0 +1,2 @@
1RDEPENDS_${PN}_append_genericx86 = " lttng-ust systemtap"
2
diff --git a/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86-64/uClibc.machine b/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86-64/uClibc.machine
new file mode 100644
index 0000000000..305dc64dec
--- /dev/null
+++ b/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86-64/uClibc.machine
@@ -0,0 +1,69 @@
1#
2# Automatically generated make config: don't edit
3# Fri Nov 23 15:49:33 2007
4#
5# TARGET_alpha is not set
6# TARGET_arm is not set
7# TARGET_bfin is not set
8# TARGET_cris is not set
9# TARGET_e1 is not set
10# TARGET_frv is not set
11# TARGET_h8300 is not set
12# TARGET_hppa is not set
13# TARGET_i386=y
14# TARGET_i960 is not set
15# TARGET_ia64 is not set
16# TARGET_m68k is not set
17# TARGET_microblaze is not set
18# TARGET_mips is not set
19# TARGET_nios is not set
20# TARGET_nios2 is not set
21# TARGET_powerpc is not set
22# TARGET_sh is not set
23# TARGET_sh64 is not set
24# TARGET_sparc is not set
25# TARGET_v850 is not set
26# TARGET_vax is not set
27TARGET_x86_64=y
28
29#
30# Target Architecture Features and Options
31#
32TARGET_ARCH="x86_64"
33FORCE_OPTIONS_FOR_ARCH=y
34# CONFIG_GENERIC_386 is not set
35# CONFIG_386 is not set
36# CONFIG_486 is not set
37# CONFIG_586 is not set
38# CONFIG_586MMX is not set
39# CONFIG_686 is not set
40# CONFIG_PENTIUMII is not set
41# CONFIG_PENTIUMIII is not set
42# CONFIG_PENTIUM4 is not set
43# CONFIG_K6 is not set
44# CONFIG_K7 is not set
45# CONFIG_ELAN is not set
46# CONFIG_CRUSOE is not set
47# CONFIG_WINCHIPC6 is not set
48# CONFIG_WINCHIP2 is not set
49# CONFIG_CYRIXIII is not set
50# CONFIG_NEHEMIAH is not set
51TARGET_SUBARCH=""
52
53#
54# Using ELF file format
55#
56ARCH_LITTLE_ENDIAN=y
57
58#
59# Using Little Endian
60#
61ARCH_HAS_MMU=y
62ARCH_USE_MMU=y
63UCLIBC_HAS_FLOATS=y
64UCLIBC_HAS_FPU=y
65DO_C99_MATH=y
66KERNEL_HEADERS="/usr/include"
67HAVE_DOT_CONFIG=y
68
69UCLIBC_HAS_FENV=y
diff --git a/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86/uClibc.machine b/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86/uClibc.machine
new file mode 100644
index 0000000000..5df15f94cb
--- /dev/null
+++ b/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86/uClibc.machine
@@ -0,0 +1,69 @@
1#
2# Automatically generated make config: don't edit
3# Fri Nov 23 15:49:33 2007
4#
5# TARGET_alpha is not set
6# TARGET_arm is not set
7# TARGET_bfin is not set
8# TARGET_cris is not set
9# TARGET_e1 is not set
10# TARGET_frv is not set
11# TARGET_h8300 is not set
12# TARGET_hppa is not set
13TARGET_i386=y
14# TARGET_i960 is not set
15# TARGET_ia64 is not set
16# TARGET_m68k is not set
17# TARGET_microblaze is not set
18# TARGET_mips is not set
19# TARGET_nios is not set
20# TARGET_nios2 is not set
21# TARGET_powerpc is not set
22# TARGET_sh is not set
23# TARGET_sh64 is not set
24# TARGET_sparc is not set
25# TARGET_v850 is not set
26# TARGET_vax is not set
27# TARGET_x86_64 is not set
28
29#
30# Target Architecture Features and Options
31#
32TARGET_ARCH="i386"
33FORCE_OPTIONS_FOR_ARCH=y
34CONFIG_GENERIC_386=y
35# CONFIG_386 is not set
36# CONFIG_486 is not set
37# CONFIG_586 is not set
38# CONFIG_586MMX is not set
39# CONFIG_686 is not set
40# CONFIG_PENTIUMII is not set
41# CONFIG_PENTIUMIII is not set
42# CONFIG_PENTIUM4 is not set
43# CONFIG_K6 is not set
44# CONFIG_K7 is not set
45# CONFIG_ELAN is not set
46# CONFIG_CRUSOE is not set
47# CONFIG_WINCHIPC6 is not set
48# CONFIG_WINCHIP2 is not set
49# CONFIG_CYRIXIII is not set
50# CONFIG_NEHEMIAH is not set
51TARGET_SUBARCH=""
52
53#
54# Using ELF file format
55#
56ARCH_LITTLE_ENDIAN=y
57
58#
59# Using Little Endian
60#
61ARCH_HAS_MMU=y
62ARCH_USE_MMU=y
63UCLIBC_HAS_FLOATS=y
64UCLIBC_HAS_FPU=y
65DO_C99_MATH=y
66KERNEL_HEADERS="/usr/include"
67HAVE_DOT_CONFIG=y
68
69UCLIBC_HAS_FENV=y
diff --git a/meta-yocto-bsp/recipes-core/uclibc/uclibc_git.bbappend b/meta-yocto-bsp/recipes-core/uclibc/uclibc_git.bbappend
new file mode 100644
index 0000000000..72d991c7e5
--- /dev/null
+++ b/meta-yocto-bsp/recipes-core/uclibc/uclibc_git.bbappend
@@ -0,0 +1 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86-64/xorg.conf b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86-64/xorg.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86-64/xorg.conf
diff --git a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86/xorg.conf b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86/xorg.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86/xorg.conf
diff --git a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 0000000000..72d991c7e5
--- /dev/null
+++ b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
new file mode 100644
index 0000000000..41fd57511b
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -0,0 +1,14 @@
1KBRANCH_genericx86 = "standard/common-pc/base"
2KBRANCH_genericx86-64 = "standard/common-pc-64/base"
3KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
4
5KMACHINE_genericx86 ?= "common-pc"
6KMACHINE_genericx86-64 ?= "common-pc-64"
7
8SRCREV_machine_genericx86 ?= "2ee37bfe732c73f7d39af55875ce8d30b282471c"
9SRCREV_machine_genericx86-64 ?= "2ee37bfe732c73f7d39af55875ce8d30b282471c"
10SRCREV_machine_mpc8315e-rdb ?= "2688f74bf2bb01ec355bbdd4b6fa00a0d39302de"
11
12COMPATIBLE_MACHINE_genericx86 = "genericx86"
13COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
14COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.14.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.14.bbappend
new file mode 100644
index 0000000000..e0964eb40a
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -0,0 +1,17 @@
1KBRANCH_genericx86 = "standard/common-pc/base"
2KBRANCH_genericx86-64 = "standard/common-pc-64/base"
3KBRANCH_edgerouter = "standard/edgerouter"
4KBRANCH_beaglebone = "standard/beaglebone"
5
6KMACHINE_genericx86 ?= "common-pc"
7KMACHINE_genericx86-64 ?= "common-pc-64"
8
9SRCREV_machine_genericx86 ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
10SRCREV_machine_genericx86-64 ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
11SRCREV_machine_edgerouter ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
12SRCREV_machine_beaglebone ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
13
14COMPATIBLE_MACHINE_genericx86 = "genericx86"
15COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
16COMPATIBLE_MACHINE_edgerouter = "edgerouter"
17COMPATIBLE_MACHINE_beaglebone = "beaglebone"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
new file mode 100644
index 0000000000..13aa5d97ad
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -0,0 +1,7 @@
1KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
2
3SRCREV_machine_genericx86 ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d"
4SRCREV_machine_mpc8315e-rdb ?= "b2f78892b3ff6cc940e4661f7b2017a73b289c73"
5
6COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
7