summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto-bsp/recipes-kernel')
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend23
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend15
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend19
3 files changed, 57 insertions, 0 deletions
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
new file mode 100644
index 0000000000..aa43b15bb0
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -0,0 +1,23 @@
1KBRANCH_genericx86 = "standard/common-pc/base"
2KBRANCH_genericx86-64 = "standard/common-pc-64/base"
3KBRANCH_routerstationpro = "standard/routerstationpro"
4KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
5KBRANCH_beagleboard = "standard/beagleboard"
6
7KMACHINE_genericx86 ?= "common-pc"
8KMACHINE_genericx86-64 ?= "common-pc-64"
9
10SRCREV_machine_genericx86 ?= "702040ac7c7ec66a29b4d147665ccdd0ff015577"
11SRCREV_machine_genericx86-64 ?= "702040ac7c7ec66a29b4d147665ccdd0ff015577"
12SRCREV_machine_routerstationpro ?= "d4e6adefaf92a1e7b6539d371ba49b78bd194a84"
13SRCREV_machine_mpc8315e-rdb ?= "12dc46ba4efb80e135fec4dce913eeb87ee671b3"
14SRCREV_machine_beagleboard ?= "702040ac7c7ec66a29b4d147665ccdd0ff015577"
15
16COMPATIBLE_MACHINE_genericx86 = "genericx86"
17COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
18COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
19COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
20COMPATIBLE_MACHINE_beagleboard = "beagleboard"
21
22# routerstationpro has a flash size of 16mb
23KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
new file mode 100644
index 0000000000..7c2bd67708
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -0,0 +1,15 @@
1KBRANCH_routerstationpro = "standard/routerstationpro"
2KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
3KBRANCH_beagleboard = "standard/beagleboard"
4
5SRCREV_machine_genericx86 ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d"
6SRCREV_machine_routerstationpro ?= "62b86dc8ac794cd97c61a99418d7429e6a83ec1a"
7SRCREV_machine_mpc8315e-rdb ?= "b2f78892b3ff6cc940e4661f7b2017a73b289c73"
8SRCREV_machine_beagleboard ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d"
9
10COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
11COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
12COMPATIBLE_MACHINE_beagleboard = "beagleboard"
13
14# routerstationpro has a flash size of 16mb
15KERNEL_IMAGE_MAXSIZE_append_routerstationpro = "16777216"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend
new file mode 100644
index 0000000000..216b384a43
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -0,0 +1,19 @@
1KBRANCH_genericx86 = "standard/common-pc/base"
2KBRANCH_routerstationpro = "standard/routerstationpro"
3KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
4KBRANCH_beagleboard = "standard/beagleboard"
5
6SRCREV_machine_genericx86 ?= "f20047520a57322f05d95a18a5fbd082fb15cb87"
7SRCREV_machine_routerstationpro ?= "4a94f39d429fa284ce69b13bb635b29b1319e372"
8SRCREV_machine_mpc8315e-rdb ?= "f467c72937de0e4a2a66e21b9855c4aee844f936"
9SRCREV_machine_beagleboard ?= "f20047520a57322f05d95a18a5fbd082fb15cb87"
10
11COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
12COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
13COMPATIBLE_MACHINE_beagleboard = "beagleboard"
14COMPATIBLE_MACHINE_genericx86 = "genericx86"
15
16# routerstationpro has a flash size of 16mb
17KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216"
18
19KMACHINE_genericx86 = "common-pc"