summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto-bsp/recipes-kernel/linux')
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend25
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend15
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.2.bbappend14
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend15
4 files changed, 69 insertions, 0 deletions
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 0000000000..274eb822ce
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,25 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3# atom-pc support
4COMPATIBLE_MACHINE_atom-pc = "atom-pc"
5KMACHINE_atom-pc = "atom-pc"
6KBRANCH_atom-pc = "yocto/standard/preempt-rt/base"
7SRCREV_machine_pn-linux-yocto-rt_atom-pc = "bbd5bfe49403fdcca294ca4b163d5f7195ea3a8e"
8
9# mpc8315e-rdb support
10COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
11KMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb"
12KBRANCH_mpc8315e-rdb = "yocto/standard/preempt-rt/base"
13SRCREV_machine_pn-linux-yocto-rt_mpc8315e-rdb = "bbd5bfe49403fdcca294ca4b163d5f7195ea3a8e"
14
15# beagleboard support - 3.0 support has not yet been completed, build failure
16#COMPATIBLE_MACHINE_beagleboard = "beagleboard"
17#KMACHINE_beagleboard = "beagleboard"
18#KBRANCH_beagleboard = "yocto/standard/preempt-rt/base"
19#SRCREV_machine_pn-linux-yocto-rt_beagleboard =
20
21# routerstationpro support - preempt-rt kernel build failure
22COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
23KMACHINE_routerstationpro = "routerstationpro"
24KBRANCH_routerstationpro = "yocto/standard/preempt-rt/routerstationpro"
25SRCREV_machine_pn-linux-yocto-rt_routerstationpro = "634ba79510753eecd27a39a315f690f1c9d46efe"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend
new file mode 100644
index 0000000000..9641336cf6
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -0,0 +1,15 @@
1KBRANCH_atom-pc = "yocto/standard/common-pc/atom-pc"
2KBRANCH_routerstationpro = "yocto/standard/routerstationpro"
3KBRANCH_mpc8315e-rdb = "yocto/standard/fsl-mpc8315e-rdb"
4KBRANCH_beagleboard = "yocto/standard/beagleboard"
5
6SRCREV_machine_atom-pc ?= "834c2a69c87ee7211932f8ec5102a472828abcb1"
7SRCREV_machine_routerstationpro ?= "1c17c082b6ee565acc176cde5be835ac4269817b"
8SRCREV_machine_mpc8315e-rdb ?= "f2312437b52dda4499310aacb4c561ba8b8cbeb7"
9SRCREV_machine_beagleboard ?= "3ab688a78cac7b2e32afc83376a53370f2bd13b7"
10
11
12COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
13COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
14COMPATIBLE_MACHINE_beagleboard = "beagleboard"
15COMPATIBLE_MACHINE_atom-pc = "atom-pc"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.2.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.2.bbappend
new file mode 100644
index 0000000000..fa160f8caf
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.2.bbappend
@@ -0,0 +1,14 @@
1KBRANCH_atom-pc = "standard/default/common-pc/atom-pc"
2KBRANCH_routerstationpro = "standard/default/routerstationpro"
3KBRANCH_mpc8315e-rdb = "standard/default/fsl-mpc8315e-rdb"
4KBRANCH_beagleboard = "standard/default/beagleboard"
5
6SRCREV_machine_atom-pc ?= "41074a778d251a77e036fd8a99915cd4da6cd8f7"
7SRCREV_machine_routerstationpro ?= "94abc0d75d0a99c40c53402570cd9c569539fee9"
8SRCREV_machine_mpc8315e-rdb ?= "a04e94f4dae9cf6d32d059cf9e0308abe7341a3a"
9SRCREV_machine_beagleboard ?= "40bde7a43ef3cd85729ab02464a7ecdf71e522a6"
10
11COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
12COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
13COMPATIBLE_MACHINE_beagleboard = "beagleboard"
14COMPATIBLE_MACHINE_atom-pc = "atom-pc"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
new file mode 100644
index 0000000000..e9a6d9de48
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -0,0 +1,15 @@
1KBRANCH_atom-pc = "standard/common-pc/atom-pc"
2KBRANCH_routerstationpro = "standard/routerstationpro"
3KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
4KBRANCH_beagleboard = "standard/beagleboard"
5
6SRCREV_machine_atom-pc ?= "0985844fa6235422c67ef269952fa4e765f252f9"
7SRCREV_machine_routerstationpro ?= "a2907c57acfb8fa71095a3ce5b20994ff859dbc5"
8SRCREV_machine_mpc8315e-rdb ?= "363a6f7e0c95aabec779a7ea3474662d191b935c"
9SRCREV_machine_beagleboard ?= "0985844fa6235422c67ef269952fa4e765f252f9"
10
11
12COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
13COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
14# COMPATIBLE_MACHINE_beagleboard = "beagleboard"
15COMPATIBLE_MACHINE_atom-pc = "atom-pc"