summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend')
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
new file mode 100644
index 0000000000..aa43b15bb0
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -0,0 +1,23 @@
1KBRANCH_genericx86 = "standard/common-pc/base"
2KBRANCH_genericx86-64 = "standard/common-pc-64/base"
3KBRANCH_routerstationpro = "standard/routerstationpro"
4KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
5KBRANCH_beagleboard = "standard/beagleboard"
6
7KMACHINE_genericx86 ?= "common-pc"
8KMACHINE_genericx86-64 ?= "common-pc-64"
9
10SRCREV_machine_genericx86 ?= "702040ac7c7ec66a29b4d147665ccdd0ff015577"
11SRCREV_machine_genericx86-64 ?= "702040ac7c7ec66a29b4d147665ccdd0ff015577"
12SRCREV_machine_routerstationpro ?= "d4e6adefaf92a1e7b6539d371ba49b78bd194a84"
13SRCREV_machine_mpc8315e-rdb ?= "12dc46ba4efb80e135fec4dce913eeb87ee671b3"
14SRCREV_machine_beagleboard ?= "702040ac7c7ec66a29b4d147665ccdd0ff015577"
15
16COMPATIBLE_MACHINE_genericx86 = "genericx86"
17COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
18COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
19COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
20COMPATIBLE_MACHINE_beagleboard = "beagleboard"
21
22# routerstationpro has a flash size of 16mb
23KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216"