diff options
Diffstat (limited to 'meta-skeleton/recipes-kernel')
-rw-r--r-- | meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb | 10 |
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb index 05463c0263..cce44d9995 100644 --- a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb +++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb | |||
@@ -11,8 +11,8 @@ | |||
11 | # | 11 | # |
12 | # You must also provide a Linux kernel configuration. The most direct | 12 | # You must also provide a Linux kernel configuration. The most direct |
13 | # method is to copy your .config to files/defconfig in your layer, | 13 | # method is to copy your .config to files/defconfig in your layer, |
14 | # in the same directory as the bbappend and add file://defconfig to | 14 | # in the same directory as the copy (and rename) of this recipe and |
15 | # your SRC_URI. | 15 | # add file://defconfig to your SRC_URI. |
16 | # | 16 | # |
17 | # To use the yocto kernel tooling to generate a BSP configuration | 17 | # To use the yocto kernel tooling to generate a BSP configuration |
18 | # using modular configuration fragments, see the yocto-bsp and | 18 | # using modular configuration fragments, see the yocto-bsp and |
@@ -52,14 +52,14 @@ | |||
52 | inherit kernel | 52 | inherit kernel |
53 | require recipes-kernel/linux/linux-yocto.inc | 53 | require recipes-kernel/linux/linux-yocto.inc |
54 | 54 | ||
55 | # Override SRC_URI in a bbappend file to point at a different source | 55 | # Override SRC_URI in a copy of this recipe to point at a different source |
56 | # tree if you do not want to build from Linus' tree. | 56 | # tree if you do not want to build from Linus' tree. |
57 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine" | 57 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine" |
58 | 58 | ||
59 | LINUX_VERSION ?= "3.4" | 59 | LINUX_VERSION ?= "3.4" |
60 | LINUX_VERSION_EXTENSION ?= "-custom" | 60 | LINUX_VERSION_EXTENSION ?= "-custom" |
61 | 61 | ||
62 | # Override SRCREV to point to a different commit in a bbappend file to | 62 | # Modify SRCREV to a different commit hash in a copy of this recipe to |
63 | # build a different release of the Linux kernel. | 63 | # build a different release of the Linux kernel. |
64 | # tag: v3.4 76e10d158efb6d4516018846f60c2ab5501900bc | 64 | # tag: v3.4 76e10d158efb6d4516018846f60c2ab5501900bc |
65 | SRCREV_machine="76e10d158efb6d4516018846f60c2ab5501900bc" | 65 | SRCREV_machine="76e10d158efb6d4516018846f60c2ab5501900bc" |
@@ -67,6 +67,6 @@ SRCREV_machine="76e10d158efb6d4516018846f60c2ab5501900bc" | |||
67 | PR = "r1" | 67 | PR = "r1" |
68 | PV = "${LINUX_VERSION}+git${SRCPV}" | 68 | PV = "${LINUX_VERSION}+git${SRCPV}" |
69 | 69 | ||
70 | # Override COMPATIBLE_MACHINE to include your machine in a bbappend | 70 | # Override COMPATIBLE_MACHINE to include your machine in a copy of this recipe |
71 | # file. Leaving it empty here ensures an early explicit build failure. | 71 | # file. Leaving it empty here ensures an early explicit build failure. |
72 | COMPATIBLE_MACHINE = "(^$)" | 72 | COMPATIBLE_MACHINE = "(^$)" |