summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb')
-rw-r--r--meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
new file mode 100644
index 0000000000..c3291064bb
--- /dev/null
+++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
@@ -0,0 +1,64 @@
1# linux-yocto-custom.bb:
2#
3# An example kernel recipe that uses the linux-yocto and oe-core
4# kernel classes to apply a subset of yocto kernel management to git
5# managed kernel repositories.
6#
7# To use linux-yocto-custom in your layer, create a
8# linux-yocto-custom.bbappend file containing at least the following
9# lines:
10#
11# FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
12# COMPATIBLE_MACHINE_yourmachine = "yourmachine"
13#
14# You must also provide a Linux kernel configuration. The most direct
15# method is to copy your .config to files/defconfig in your layer,
16# in the same directory as the bbappend and add file://defconfig to
17# your SRC_URI.
18#
19# To use the yocto kernel tooling to generate a BSP configuration
20# using modular configuration fragments, see the yocto-bsp and
21# yocto-kernel tools documentation.
22#
23# Warning:
24#
25# Building this example without providing a defconfig or BSP
26# configuration will result in build or boot errors. This is not a
27# bug.
28#
29#
30# Notes:
31#
32# patches: patches can be merged into to the source git tree itself,
33# added via the SRC_URI, or controlled via a BSP
34# configuration.
35#
36# example configuration addition:
37# SRC_URI += "file://smp.cfg"
38# example patch addition (for kernel v3.4 only):
39# SRC_URI += "file://0001-linux-version-tweak.patch
40# example feature addition (for kernel v3.4 only):
41# SRC_URI += "file://feature.scc"
42#
43
44inherit kernel
45require recipes-kernel/linux/linux-yocto.inc
46
47# Override SRC_URI in a bbappend file to point at a different source
48# tree if you do not want to build from Linus' tree.
49SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine"
50
51LINUX_VERSION ?= "3.4"
52LINUX_VERSION_EXTENSION ?= "-custom"
53
54# Override SRCREV to point to a different commit in a bbappend file to
55# build a different release of the Linux kernel.
56# tag: v3.4 76e10d158efb6d4516018846f60c2ab5501900bc
57SRCREV_machine="76e10d158efb6d4516018846f60c2ab5501900bc"
58
59PR = "r1"
60PV = "${LINUX_VERSION}+git${SRCPV}"
61
62# Override COMPATIBLE_MACHINE to include your machine in a bbappend
63# file. Leaving it empty here ensures an early explicit build failure.
64COMPATIBLE_MACHINE = "(^$)"