summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb')
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
new file mode 100644
index 0000000000..3136ae7f16
--- /dev/null
+++ b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "hello-world-mod tests the module.bbclass mechanism."
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
4
5inherit module
6
7PR = "r0"
8PV = "0.1"
9
10SRC_URI = "file://Makefile \
11 file://hello.c \
12 file://COPYING \
13 "
14
15S = "${WORKDIR}"
16
17# The inherit of module.bbclass will automatically name module packages with
18# "kernel-module-" prefix as required by the oe-core build environment.