summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton/conf')
-rw-r--r--meta-skeleton/conf/layer.conf15
-rw-r--r--meta-skeleton/conf/multilib-example.conf13
-rw-r--r--meta-skeleton/conf/multilib-example2.conf13
3 files changed, 41 insertions, 0 deletions
diff --git a/meta-skeleton/conf/layer.conf b/meta-skeleton/conf/layer.conf
new file mode 100644
index 0000000000..aca1633420
--- /dev/null
+++ b/meta-skeleton/conf/layer.conf
@@ -0,0 +1,15 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
6
7BBFILE_COLLECTIONS += "skeleton"
8BBFILE_PATTERN_skeleton = "^${LAYERDIR}/"
9BBFILE_PRIORITY_skeleton = "1"
10
11# This should only be incremented on significant changes that will
12# cause compatibility issues with other layers
13LAYERVERSION_skeleton = "1"
14
15LAYERDEPENDS_skeleton = "core"
diff --git a/meta-skeleton/conf/multilib-example.conf b/meta-skeleton/conf/multilib-example.conf
new file mode 100644
index 0000000000..da6da7f1f6
--- /dev/null
+++ b/meta-skeleton/conf/multilib-example.conf
@@ -0,0 +1,13 @@
1#
2# Sample multilib configuration which the user can either add in local.conf
3# or specific in an configuration file like this, then require it.
4#
5# This configuration specifies an x86 64 bit machine as the main machine
6# type and then adds a multilib in the "lib32" directory where those
7# libraries are compiled with the "x86" tune.
8#
9
10MACHINE = "qemux86-64"
11require conf/multilib.conf
12MULTILIBS = "multilib:lib32"
13DEFAULTTUNE_virtclass-multilib-lib32 = "x86"
diff --git a/meta-skeleton/conf/multilib-example2.conf b/meta-skeleton/conf/multilib-example2.conf
new file mode 100644
index 0000000000..2596f61d9f
--- /dev/null
+++ b/meta-skeleton/conf/multilib-example2.conf
@@ -0,0 +1,13 @@
1#
2# Sample multilib configuration which the user can either add in local.conf
3# or specific in an configuration file like this, then require it.
4#
5# This configuration specifies an x86 64 bit machine as the main machine
6# type and then adds a multilib in the "libx32" directory where those
7# libraries are compiled with the "x86-64-x32" tune.
8#
9
10MACHINE = "qemux86-64"
11require conf/multilib.conf
12MULTILIBS = "multilib:libx32"
13DEFAULTTUNE_virtclass-multilib-libx32 = "x86-64-x32"