diff options
Diffstat (limited to 'meta-selftest')
-rw-r--r-- | meta-selftest/COPYING.MIT | 17 | ||||
-rw-r--r-- | meta-selftest/README | 3 | ||||
-rw-r--r-- | meta-selftest/classes/test_events.bbclass | 16 | ||||
-rw-r--r-- | meta-selftest/conf/layer.conf | 10 | ||||
-rw-r--r-- | meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb | 28 | ||||
-rw-r--r-- | meta-selftest/recipes-test/aspell/aspell_0.60.6.1.bbappend | 2 | ||||
-rw-r--r-- | meta-selftest/recipes-test/m4/m4_1.4.17.bbappend | 2 | ||||
-rw-r--r-- | meta-selftest/recipes-test/man/man/man-1.5h1-make.patch | 16 | ||||
-rw-r--r-- | meta-selftest/recipes-test/man/man_1.6g.bbappend | 2 | ||||
-rw-r--r-- | meta-selftest/recipes-test/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bbappend | 2 |
10 files changed, 98 insertions, 0 deletions
diff --git a/meta-selftest/COPYING.MIT b/meta-selftest/COPYING.MIT new file mode 100644 index 0000000000..89de354795 --- /dev/null +++ b/meta-selftest/COPYING.MIT | |||
@@ -0,0 +1,17 @@ | |||
1 | Permission is hereby granted, free of charge, to any person obtaining a copy | ||
2 | of this software and associated documentation files (the "Software"), to deal | ||
3 | in the Software without restriction, including without limitation the rights | ||
4 | to use, copy, modify, merge, publish, distribute, sublicense, and/or sell | ||
5 | copies of the Software, and to permit persons to whom the Software is | ||
6 | furnished to do so, subject to the following conditions: | ||
7 | |||
8 | The above copyright notice and this permission notice shall be included in | ||
9 | all copies or substantial portions of the Software. | ||
10 | |||
11 | THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR | ||
12 | IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, | ||
13 | FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE | ||
14 | AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER | ||
15 | LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, | ||
16 | OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN | ||
17 | THE SOFTWARE. | ||
diff --git a/meta-selftest/README b/meta-selftest/README new file mode 100644 index 0000000000..11a6fee2d0 --- /dev/null +++ b/meta-selftest/README | |||
@@ -0,0 +1,3 @@ | |||
1 | This layer is intended as test layer, used by scripts/oe-selftest | ||
2 | and it's probably a mistake to include it in your builds (unless you | ||
3 | want to run the script). | ||
diff --git a/meta-selftest/classes/test_events.bbclass b/meta-selftest/classes/test_events.bbclass new file mode 100644 index 0000000000..35324eb40b --- /dev/null +++ b/meta-selftest/classes/test_events.bbclass | |||
@@ -0,0 +1,16 @@ | |||
1 | python test1_eventhandler() { | ||
2 | bb.note("Test for bb.event.BuildStarted") | ||
3 | } | ||
4 | python test2_eventhandler() { | ||
5 | bb.note("Test for bb.event.BuildCompleted") | ||
6 | } | ||
7 | python test3_eventhandler() { | ||
8 | bb.note("Test for bb.event.InvalidEvent") | ||
9 | } | ||
10 | |||
11 | addhandler test1_eventhandler | ||
12 | test1_eventhandler[eventmask] = "bb.event.BuildStarted" | ||
13 | addhandler test2_eventhandler | ||
14 | test2_eventhandler[eventmask] = "bb.event.BuildCompleted" | ||
15 | addhandler test3_eventhandler | ||
16 | test3_eventhandler[eventmask] = "bb.event.InvalidEvent" | ||
diff --git a/meta-selftest/conf/layer.conf b/meta-selftest/conf/layer.conf new file mode 100644 index 0000000000..a847b78a20 --- /dev/null +++ b/meta-selftest/conf/layer.conf | |||
@@ -0,0 +1,10 @@ | |||
1 | # We have a conf and classes directory, add to BBPATH | ||
2 | BBPATH .= ":${LAYERDIR}" | ||
3 | |||
4 | # We have recipes-* directories, add to BBFILES | ||
5 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \ | ||
6 | ${LAYERDIR}/recipes-*/*/*.bbappend" | ||
7 | |||
8 | BBFILE_COLLECTIONS += "selftest" | ||
9 | BBFILE_PATTERN_selftest = "^${LAYERDIR}/" | ||
10 | BBFILE_PRIORITY_selftest = "5" | ||
diff --git a/meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb b/meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb new file mode 100644 index 0000000000..427726a9f1 --- /dev/null +++ b/meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | # This recipe is a copy from the oe-core one. | ||
2 | # It has a lower and invalid version number in order not to be accidentally used by bitbake. | ||
3 | # It is used for tests that require overlayed recipe files. | ||
4 | |||
5 | DESCRIPTION = "GNU Aspell spell-checker" | ||
6 | SECTION = "console/utils" | ||
7 | LICENSE="LGPLv2 | LGPLv2.1" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" | ||
9 | PR = "r1" | ||
10 | |||
11 | SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz" | ||
12 | SRC_URI[md5sum] = "e66a9c9af6a60dc46134fdacf6ce97d7" | ||
13 | SRC_URI[sha256sum] = "f52583a83a63633701c5f71db3dc40aab87b7f76b29723aeb27941eff42df6e1" | ||
14 | |||
15 | PACKAGECONFIG ??= "" | ||
16 | PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses" | ||
17 | |||
18 | PACKAGES += "libaspell libpspell libpspell-dev aspell-utils" | ||
19 | |||
20 | FILES_${PN}-dbg += "${libdir}/aspell-0.60/.debu*" | ||
21 | FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*" | ||
22 | FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*" | ||
23 | FILES_${PN} = "${bindir}/aspell" | ||
24 | FILES_libpspell = "${libdir}/libpspell.so.*" | ||
25 | FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell" | ||
26 | |||
27 | ARM_INSTRUCTION_SET = "arm" | ||
28 | inherit autotools gettext | ||
diff --git a/meta-selftest/recipes-test/aspell/aspell_0.60.6.1.bbappend b/meta-selftest/recipes-test/aspell/aspell_0.60.6.1.bbappend new file mode 100644 index 0000000000..205720982c --- /dev/null +++ b/meta-selftest/recipes-test/aspell/aspell_0.60.6.1.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | # This bbappend is used to alter the recipe using the test_recipe.inc file created by tests. | ||
2 | include test_recipe.inc | ||
diff --git a/meta-selftest/recipes-test/m4/m4_1.4.17.bbappend b/meta-selftest/recipes-test/m4/m4_1.4.17.bbappend new file mode 100644 index 0000000000..205720982c --- /dev/null +++ b/meta-selftest/recipes-test/m4/m4_1.4.17.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | # This bbappend is used to alter the recipe using the test_recipe.inc file created by tests. | ||
2 | include test_recipe.inc | ||
diff --git a/meta-selftest/recipes-test/man/man/man-1.5h1-make.patch b/meta-selftest/recipes-test/man/man/man-1.5h1-make.patch new file mode 100644 index 0000000000..a0d59b78ce --- /dev/null +++ b/meta-selftest/recipes-test/man/man/man-1.5h1-make.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | Test patch here! | ||
2 | This is invalid patch used by tests in scripts/lib/selftests. | ||
3 | |||
4 | --- man-1.5g/man/Makefile.in.mike Fri Apr 9 13:35:54 1999 | ||
5 | +++ man-1.5g/man/Makefile.in Fri Apr 9 13:36:45 1999 | ||
6 | @@ -1,8 +1,8 @@ | ||
7 | #MAKE THIS PATCH INVALID | ||
8 | MAN1 = man whatis apropos | ||
9 | -MAN5 = man.conf | ||
10 | +MAN5 = man.config | ||
11 | MAN8 = makewhatis | ||
12 | -ALL = man.1 whatis.1 apropos.1 man.conf.5 | ||
13 | +ALL = man.1 whatis.1 apropos.1 man.config.5 | ||
14 | MAYBE8 = makewhatis | ||
15 | |||
16 | .SUFFIXES: .man .1 .5 .8 | ||
diff --git a/meta-selftest/recipes-test/man/man_1.6g.bbappend b/meta-selftest/recipes-test/man/man_1.6g.bbappend new file mode 100644 index 0000000000..205720982c --- /dev/null +++ b/meta-selftest/recipes-test/man/man_1.6g.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | # This bbappend is used to alter the recipe using the test_recipe.inc file created by tests. | ||
2 | include test_recipe.inc | ||
diff --git a/meta-selftest/recipes-test/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bbappend b/meta-selftest/recipes-test/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bbappend new file mode 100644 index 0000000000..205720982c --- /dev/null +++ b/meta-selftest/recipes-test/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | # This bbappend is used to alter the recipe using the test_recipe.inc file created by tests. | ||
2 | include test_recipe.inc | ||