summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/poison/poison.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-selftest/recipes-test/poison/poison.bb b/meta-selftest/recipes-test/poison/poison.bb
index 7ace901cc3..e9eee0cdba 100644
--- a/meta-selftest/recipes-test/poison/poison.bb
+++ b/meta-selftest/recipes-test/poison/poison.bb
@@ -9,8 +9,12 @@ inherit nopackages
9# will result in compiler errors. This recipe should will fail to build and 9# will result in compiler errors. This recipe should will fail to build and
10# oe-selftest has a test that verifies that. 10# oe-selftest has a test that verifies that.
11do_compile() { 11do_compile() {
12 touch empty.c 12 bbnote Testing preprocessor
13 ${CPP} ${CFLAGS} -I/usr/include empty.c 13 echo "int main(int argc, char** argv) {}" | ${CPP} -I/usr/include -
14 bbnote Testing C compiler
15 echo "int main(int argc, char** argv) {}" | ${CC} -x c -I/usr/include -
16 bbnote Testing C++ compiler
17 echo "int main(int argc, char** argv) {}" | ${CC} -x c++ -I/usr/include -
14} 18}
15 19
16EXCLUDE_FROM_WORLD = "1" 20EXCLUDE_FROM_WORLD = "1"