summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/COPYING.MIT17
-rw-r--r--meta-selftest/README3
-rw-r--r--meta-selftest/classes/test_events.bbclass16
-rw-r--r--meta-selftest/conf/layer.conf10
-rw-r--r--meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb30
-rw-r--r--meta-selftest/recipes-test/aspell/aspell_0.60.6.1.bbappend2
-rw-r--r--meta-selftest/recipes-test/m4/m4_1.4.17.bbappend2
-rw-r--r--meta-selftest/recipes-test/man/man/man-1.5h1-make.patch16
-rw-r--r--meta-selftest/recipes-test/man/man_1.6g.bbappend2
-rw-r--r--meta-selftest/recipes-test/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bbappend2
10 files changed, 100 insertions, 0 deletions
diff --git a/meta-selftest/COPYING.MIT b/meta-selftest/COPYING.MIT
new file mode 100644
index 0000000000..89de354795
--- /dev/null
+++ b/meta-selftest/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-selftest/README b/meta-selftest/README
new file mode 100644
index 0000000000..11a6fee2d0
--- /dev/null
+++ b/meta-selftest/README
@@ -0,0 +1,3 @@
1This layer is intended as test layer, used by scripts/oe-selftest
2and it's probably a mistake to include it in your builds (unless you
3want to run the script).
diff --git a/meta-selftest/classes/test_events.bbclass b/meta-selftest/classes/test_events.bbclass
new file mode 100644
index 0000000000..35324eb40b
--- /dev/null
+++ b/meta-selftest/classes/test_events.bbclass
@@ -0,0 +1,16 @@
1python test1_eventhandler() {
2 bb.note("Test for bb.event.BuildStarted")
3}
4python test2_eventhandler() {
5 bb.note("Test for bb.event.BuildCompleted")
6}
7python test3_eventhandler() {
8 bb.note("Test for bb.event.InvalidEvent")
9}
10
11addhandler test1_eventhandler
12test1_eventhandler[eventmask] = "bb.event.BuildStarted"
13addhandler test2_eventhandler
14test2_eventhandler[eventmask] = "bb.event.BuildCompleted"
15addhandler test3_eventhandler
16test3_eventhandler[eventmask] = "bb.event.InvalidEvent"
diff --git a/meta-selftest/conf/layer.conf b/meta-selftest/conf/layer.conf
new file mode 100644
index 0000000000..a847b78a20
--- /dev/null
+++ b/meta-selftest/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "selftest"
9BBFILE_PATTERN_selftest = "^${LAYERDIR}/"
10BBFILE_PRIORITY_selftest = "5"
diff --git a/meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb b/meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb
new file mode 100644
index 0000000000..20a0ab7d39
--- /dev/null
+++ b/meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb
@@ -0,0 +1,30 @@
1# This recipe is a copy from the oe-core one.
2# It has a lower and invalid version number in order not to be accidentally used by bitbake.
3# It is used for tests that require overlayed recipe files.
4
5SUMMARY = "GNU Aspell spell-checker"
6SECTION = "console/utils"
7
8LICENSE = "LGPLv2 | LGPLv2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
10
11PR = "r1"
12
13SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz"
14SRC_URI[md5sum] = "e66a9c9af6a60dc46134fdacf6ce97d7"
15SRC_URI[sha256sum] = "f52583a83a63633701c5f71db3dc40aab87b7f76b29723aeb27941eff42df6e1"
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses"
19
20PACKAGES += "libaspell libpspell libpspell-dev aspell-utils"
21
22FILES_${PN}-dbg += "${libdir}/aspell-0.60/.debu*"
23FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*"
24FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*"
25FILES_${PN} = "${bindir}/aspell"
26FILES_libpspell = "${libdir}/libpspell.so.*"
27FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
28
29ARM_INSTRUCTION_SET = "arm"
30inherit autotools gettext
diff --git a/meta-selftest/recipes-test/aspell/aspell_0.60.6.1.bbappend b/meta-selftest/recipes-test/aspell/aspell_0.60.6.1.bbappend
new file mode 100644
index 0000000000..205720982c
--- /dev/null
+++ b/meta-selftest/recipes-test/aspell/aspell_0.60.6.1.bbappend
@@ -0,0 +1,2 @@
1# This bbappend is used to alter the recipe using the test_recipe.inc file created by tests.
2include test_recipe.inc
diff --git a/meta-selftest/recipes-test/m4/m4_1.4.17.bbappend b/meta-selftest/recipes-test/m4/m4_1.4.17.bbappend
new file mode 100644
index 0000000000..205720982c
--- /dev/null
+++ b/meta-selftest/recipes-test/m4/m4_1.4.17.bbappend
@@ -0,0 +1,2 @@
1# This bbappend is used to alter the recipe using the test_recipe.inc file created by tests.
2include test_recipe.inc
diff --git a/meta-selftest/recipes-test/man/man/man-1.5h1-make.patch b/meta-selftest/recipes-test/man/man/man-1.5h1-make.patch
new file mode 100644
index 0000000000..a0d59b78ce
--- /dev/null
+++ b/meta-selftest/recipes-test/man/man/man-1.5h1-make.patch
@@ -0,0 +1,16 @@
1Test patch here!
2This is invalid patch used by tests in scripts/lib/selftests.
3
4--- man-1.5g/man/Makefile.in.mike Fri Apr 9 13:35:54 1999
5+++ man-1.5g/man/Makefile.in Fri Apr 9 13:36:45 1999
6@@ -1,8 +1,8 @@
7 #MAKE THIS PATCH INVALID
8 MAN1 = man whatis apropos
9-MAN5 = man.conf
10+MAN5 = man.config
11 MAN8 = makewhatis
12-ALL = man.1 whatis.1 apropos.1 man.conf.5
13+ALL = man.1 whatis.1 apropos.1 man.config.5
14 MAYBE8 = makewhatis
15
16 .SUFFIXES: .man .1 .5 .8
diff --git a/meta-selftest/recipes-test/man/man_1.6g.bbappend b/meta-selftest/recipes-test/man/man_1.6g.bbappend
new file mode 100644
index 0000000000..205720982c
--- /dev/null
+++ b/meta-selftest/recipes-test/man/man_1.6g.bbappend
@@ -0,0 +1,2 @@
1# This bbappend is used to alter the recipe using the test_recipe.inc file created by tests.
2include test_recipe.inc
diff --git a/meta-selftest/recipes-test/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bbappend b/meta-selftest/recipes-test/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bbappend
new file mode 100644
index 0000000000..205720982c
--- /dev/null
+++ b/meta-selftest/recipes-test/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bbappend
@@ -0,0 +1,2 @@
1# This bbappend is used to alter the recipe using the test_recipe.inc file created by tests.
2include test_recipe.inc