diff options
Diffstat (limited to 'meta-selftest')
-rw-r--r-- | meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb b/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb new file mode 100644 index 0000000000..3dbc0f5d15 --- /dev/null +++ b/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | LICENSE = "MIT" | ||
2 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
3 | |||
4 | MCMACHINE_virtclass-mcextend-musl = "qemux86-64" | ||
5 | MCMACHINE_virtclass-mcextend-tiny = "qemux86" | ||
6 | MCIMGTYPE_virtclass-mcextend-musl = "ext4" | ||
7 | MCIMGTYPE_virtclass-mcextend-tiny = "cpio.gz" | ||
8 | |||
9 | MC_DEPLOY_DIR_IMAGE = "${TOPDIR}/tmp-mc-${MCNAME}/deploy/images/${MCMACHINE}" | ||
10 | |||
11 | do_install[mcdepends] += "multiconfig::${MCNAME}:core-image-minimal:do_image_complete multiconfig::${MCNAME}:virtual/kernel:do_deploy" | ||
12 | |||
13 | do_install () { | ||
14 | install -d ${D}/var/lib/machines/${MCNAME} | ||
15 | install ${MC_DEPLOY_DIR_IMAGE}/core-image-minimal-${MCMACHINE}.${MCIMGTYPE} ${D}/var/lib/machines/${MCNAME}/core-image-minimal.${MCIMGTYPE} | ||
16 | install ${MC_DEPLOY_DIR_IMAGE}/bzImage ${D}/var/lib/machines/${MCNAME} | ||
17 | } | ||
18 | |||
19 | python () { | ||
20 | mcname = d.getVar('MCNAME') | ||
21 | if not mcname: | ||
22 | raise bb.parse.SkipRecipe("Not a multiconfig target") | ||
23 | multiconfigs = d.getVar('BBMULTICONFIG') or "" | ||
24 | if mcname not in multiconfigs: | ||
25 | raise bb.parse.SkipRecipe("multiconfig target %s not enabled" % mcname) | ||
26 | } | ||
27 | |||
28 | BBCLASSEXTEND = "mcextend:tiny mcextend:musl" | ||