diff options
Diffstat (limited to 'meta-selftest/recipes-test')
-rw-r--r-- | meta-selftest/recipes-test/sysroot-test/sysroot-la-test_1.0.bb | 16 | ||||
-rw-r--r-- | meta-selftest/recipes-test/sysroot-test/sysroot-pc-test_1.0.bb | 12 |
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/sysroot-test/sysroot-la-test_1.0.bb b/meta-selftest/recipes-test/sysroot-test/sysroot-la-test_1.0.bb new file mode 100644 index 0000000000..21f06782fb --- /dev/null +++ b/meta-selftest/recipes-test/sysroot-test/sysroot-la-test_1.0.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "Produce a broken la file" | ||
2 | LICENSE = "CLOSED" | ||
3 | INHIBIT_DEFAULT_DEPS = "1" | ||
4 | |||
5 | EXCLUDE_FROM_WORLD = "1" | ||
6 | |||
7 | # remove-libtool.bbclass is inherited by default and removes all | ||
8 | # .la files which for this test we specifically do not want. | ||
9 | REMOVE_LIBTOOL_LA = "0" | ||
10 | |||
11 | do_install() { | ||
12 | install -d ${D}${libdir}/test/ | ||
13 | echo '${WORKDIR}' > ${D}${libdir}/test/la-test.la | ||
14 | } | ||
15 | |||
16 | BBCLASSEXTEND += "native" | ||
diff --git a/meta-selftest/recipes-test/sysroot-test/sysroot-pc-test_1.0.bb b/meta-selftest/recipes-test/sysroot-test/sysroot-pc-test_1.0.bb new file mode 100644 index 0000000000..e748310fc4 --- /dev/null +++ b/meta-selftest/recipes-test/sysroot-test/sysroot-pc-test_1.0.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | SUMMARY = "Produce a broken pc file" | ||
2 | LICENSE = "CLOSED" | ||
3 | INHIBIT_DEFAULT_DEPS = "1" | ||
4 | |||
5 | EXCLUDE_FROM_WORLD = "1" | ||
6 | |||
7 | do_install() { | ||
8 | install -d ${D}${libdir}/test/ | ||
9 | echo '${WORKDIR}' > ${D}${libdir}/test/test.pc | ||
10 | } | ||
11 | |||
12 | BBCLASSEXTEND += "native" | ||