diff options
Diffstat (limited to 'meta-selftest/recipes-test')
-rw-r--r-- | meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb | 22 | ||||
-rwxr-xr-x | meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink/gdb.sh | 8 |
2 files changed, 24 insertions, 6 deletions
diff --git a/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb index ec330fa9ff..842a9772cb 100644 --- a/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb +++ b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb | |||
@@ -2,19 +2,29 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda | |||
2 | 2 | ||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | 4 | ||
5 | SRC_URI = "file://hello.c" | 5 | SRC_URI = "file://hello.c \ |
6 | file://gdb.sh \ | ||
7 | " | ||
6 | 8 | ||
7 | S = "${WORKDIR}" | 9 | S = "${WORKDIR}" |
8 | 10 | ||
9 | do_compile () { | 11 | do_compile () { |
10 | ${CC} hello.c -o hello ${CFLAGS} ${LDFLAGS} | 12 | ${CC} hello.c -o hello1 ${CFLAGS} ${LDFLAGS} |
11 | } | 13 | } |
12 | 14 | ||
13 | do_install () { | 15 | do_install () { |
14 | install -d ${D}${bindir} | 16 | install -d ${D}${bindir} |
15 | install -m 755 hello ${D}${bindir}/hello | 17 | install -m 755 ${WORKDIR}/gdb.sh ${D}${bindir}/ |
16 | ln ${D}${bindir}/hello ${D}${bindir}/hello2 | 18 | install -m 755 hello1 ${D}${bindir}/hello1 |
17 | ln ${D}${bindir}/hello ${D}${bindir}/hello3 | 19 | ln ${D}${bindir}/hello1 ${D}${bindir}/hello2 |
18 | ln ${D}${bindir}/hello ${D}${bindir}/hello4 | 20 | |
21 | install -d ${D}${libexecdir} | ||
22 | ln ${D}${bindir}/hello1 ${D}${libexecdir}/hello3 | ||
23 | ln ${D}${bindir}/hello1 ${D}${libexecdir}/hello4 | ||
24 | |||
19 | dd if=/dev/zero of=${D}${bindir}/sparsetest bs=1 count=0 seek=1M | 25 | dd if=/dev/zero of=${D}${bindir}/sparsetest bs=1 count=0 seek=1M |
20 | } | 26 | } |
27 | |||
28 | RDEPENDS_${PN}-gdb += "gdb" | ||
29 | PACKAGES =+ "${PN}-gdb" | ||
30 | FILES_${PN}-gdb = "${bindir}/gdb.sh" | ||
diff --git a/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink/gdb.sh b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink/gdb.sh new file mode 100755 index 0000000000..f6417d5458 --- /dev/null +++ b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink/gdb.sh | |||
@@ -0,0 +1,8 @@ | |||
1 | #!/bin/sh | ||
2 | gdb -q $1 <<'EOF' | ||
3 | b main | ||
4 | r | ||
5 | c | ||
6 | q | ||
7 | EOF | ||
8 | echo "" | ||