diff options
Diffstat (limited to 'meta-selftest/recipes-test')
-rw-r--r-- | meta-selftest/recipes-test/error/error.bb | 11 | ||||
-rw-r--r-- | meta-selftest/recipes-test/images/error-image.bb | 8 |
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/error/error.bb b/meta-selftest/recipes-test/error/error.bb new file mode 100644 index 0000000000..a7bdecf29d --- /dev/null +++ b/meta-selftest/recipes-test/error/error.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | SUMMARY = "Error Test case that fails on do_compile" | ||
2 | DESCRIPTION = "This generates a compile time error to be used to for testing." | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
5 | |||
6 | INHIBIT_DEFAULT_DEPS = "1" | ||
7 | EXCLUDE_FROM_WORLD = "1" | ||
8 | |||
9 | do_compile() { | ||
10 | bbfatal "Failing as expected."; | ||
11 | } | ||
diff --git a/meta-selftest/recipes-test/images/error-image.bb b/meta-selftest/recipes-test/images/error-image.bb new file mode 100644 index 0000000000..13d9cc010e --- /dev/null +++ b/meta-selftest/recipes-test/images/error-image.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | SUMMARY = "An image that includes the error recipe and will therefore fail" | ||
2 | DESCRIPTION = "This generates an error. Not currently used by oe-selftest" | ||
3 | |||
4 | IMAGE_INSTALL = "error" | ||
5 | |||
6 | IMAGE_LINGUAS = " " | ||
7 | |||
8 | inherit core-image | ||